cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1442
Views
1
Helpful
1
Replies
Highlighted
Beginner

Problem during do-release-upgrade

Hello, I'm trying to upgrade our VIRL server, however, when I launch this command, I've got this result and I'm at a loss to find a solution to this.

any suggestions would be welcome :-)

Unknown Multi-Arch type 'no' for package 'compiz-core'

Unknown Multi-Arch type 'no' for package 'compiz-gnome'

Unknown Multi-Arch type 'no' for package 'libxapian-dev'

Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min

Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min

Unknown Multi-Arch type 'no' for package 'kwin'

Unknown Multi-Arch type 'no' for package 'kwin-dev'

Unknown Multi-Arch type 'no' for package 'kwin-wayland'

Unknown Multi-Arch type 'no' for package 'kwin-x11'

Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'

Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation

Ignoring Provides line with DepCompareOp for package php-psr-log-implementation

Ignoring Provides line with DepCompareOp for package php-seclib

Ignoring Provides line with DepCompareOp for package php-sabre-http

Ignoring Provides line with DepCompareOp for package php-math-biginteger

Ignoring Provides line with DepCompareOp for package pypy-cffi

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min

Unknown Multi-Arch type 'no' for package 'compiz-core'

Unknown Multi-Arch type 'no' for package 'compiz-gnome'

Unknown Multi-Arch type 'no' for package 'libxapian-dev'

Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min

Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min

Unknown Multi-Arch type 'no' for package 'kwin-dev'

Unknown Multi-Arch type 'no' for package 'kwin-wayland'

Unknown Multi-Arch type 'no' for package 'kwin-x11'

Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'

Ignoring Provides line with DepCompareOp for package pypy-cffi

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min

Unknown Multi-Arch type 'no' for package 'compiz-core'

Unknown Multi-Arch type 'no' for package 'compiz-gnome'

Ignoring Provides line with DepCompareOp for package xserver-xorg

Ignoring Provides line with DepCompareOp for package php-math-biginteger

Ignoring Provides line with DepCompareOp for package pypy-cffi

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min

Unknown Multi-Arch type 'no' for package 'compiz-core'

Unknown Multi-Arch type 'no' for package 'compiz-gnome'

Ignoring Provides line with DepCompareOp for package xserver-xorg

Ignoring Provides line with DepCompareOp for package pypy-cffi

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max

Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min

You may want to run apt-get update to correct these problems

Checking package manager

Reading package lists... Done

Building dependency tree

Reading state information... Done

  Hold prevents MarkGarbage of qemu-system-common [ amd64 ] < 1:2.2+dfsg-5expubuntu9.7~cloud5 -> 1:2.5+dfsg-5ubuntu10.10 > ( misc )

  Hold prevents MarkGarbage of python-dateutil [ amd64 ] < 1.5+dfsg-1ubuntu1 -> 2.4.2-1 > ( python )

  Hold prevents MarkGarbage of qemu-system-x86 [ amd64 ] < 1:2.2+dfsg-5expubuntu9.7~cloud5 -> 1:2.5+dfsg-5ubuntu10.10 > ( misc )

  Hold prevents MarkGarbage of qemu-system-common [ amd64 ] < 1:2.2+dfsg-5expubuntu9.7~cloud5 -> 1:2.5+dfsg-5ubuntu10.10 > ( misc )

  Hold prevents MarkGarbage of python-dateutil [ amd64 ] < 1.5+dfsg-1ubuntu1 -> 2.4.2-1 > ( python )

  Hold prevents MarkGarbage of qemu-system-x86 [ amd64 ] < 1:2.2+dfsg-5expubuntu9.7~cloud5 -> 1:2.5+dfsg-5ubuntu10.10 > ( misc )

Building data structures... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:

* Upgrading to a pre-release version of Ubuntu

* Running the current pre-release version of Ubuntu

* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the

command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

Restoring original system state

1 REPLY 1
Highlighted
Cisco Employee

Re: Problem during do-release-upgrade

Hi Laurent,

  Apologies for the delay in responding to you. Please check this related document for more info- VIRL 1.2.83 (October 2016 Release) - 31438 - The Cisco Learning Network

Also for further questions request to post under  new space -  ttps://learningnetwork.cisco.com/groups/virl

Thanks and Regards,

Geevarghese