cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
452
Views
0
Helpful
0
Replies

YDK Installation error on Debian

victorhb
Level 1
Level 1

I am having an issue installing ydk on debian v10, with the following error.

I have tried both building from the source and using the .deb version both with the same results.

Any help would be appriciated.

Thanks.

 

2019-03-11T18:29:12 Created temporary directory: /tmp/pip-ephem-wheel-cache-g5un759p
2019-03-11T18:29:12 Created temporary directory: /tmp/pip-req-tracker-k6alju4f
2019-03-11T18:29:12 Created requirements tracker '/tmp/pip-req-tracker-k6alju4f'
2019-03-11T18:29:12 Created temporary directory: /tmp/pip-install-_e6430vc
2019-03-11T18:29:12 Cleaning up...
2019-03-11T18:29:12 Removed build tracker '/tmp/pip-req-tracker-k6alju4f'
2019-03-11T18:29:12 ERROR: You must give at least one requirement to install (see "pip help install")
2019-03-11T18:29:12 Exception information:
2019-03-11T18:29:12 Traceback (most recent call last):
2019-03-11T18:29:12 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 179, in main
2019-03-11T18:29:12 status = self.run(options, args)
2019-03-11T18:29:12 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 289, in run
2019-03-11T18:29:12 self.name, wheel_cache
2019-03-11T18:29:12 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 306, in populate_requirement_set
2019-03-11T18:29:12 '(see "pip help %(name)s")' % opts)
2019-03-11T18:29:12 pip._internal.exceptions.CommandError: You must give at least one requirement to install (see "pip help install")
2019-03-11T18:29:22 Created temporary directory: /tmp/pip-ephem-wheel-cache-vp5pc5jo
2019-03-11T18:29:22 Created temporary directory: /tmp/pip-req-tracker-nv55hm9l
2019-03-11T18:29:22 Created requirements tracker '/tmp/pip-req-tracker-nv55hm9l'
2019-03-11T18:29:22 Created temporary directory: /tmp/pip-install-ftgsl09m
2019-03-11T18:29:22 Processing ./dist/ydk-0.8.1.tar.gz
2019-03-11T18:29:22 Created temporary directory: /tmp/pip-req-build-hc04iqch
2019-03-11T18:29:22 Added file:///var/tmp/ydk-0.8.1/dist/ydk-0.8.1.tar.gz to build tracker '/tmp/pip-req-tracker-nv55hm9l'
2019-03-11T18:29:22 Running setup.py (path:/tmp/pip-req-build-hc04iqch/setup.py) egg_info for package from file:///var/tmp/ydk-0.8.1/dist/ydk-0.8.1.tar.gz
2019-03-11T18:29:22 Running command python setup.py egg_info
2019-03-11T18:29:22 running egg_info
2019-03-11T18:29:22 creating pip-egg-info/ydk.egg-info
2019-03-11T18:29:22 writing pip-egg-info/ydk.egg-info/PKG-INFO
2019-03-11T18:29:22 writing dependency_links to pip-egg-info/ydk.egg-info/dependency_links.txt
2019-03-11T18:29:22 writing requirements to pip-egg-info/ydk.egg-info/requires.txt
2019-03-11T18:29:22 writing top-level names to pip-egg-info/ydk.egg-info/top_level.txt
2019-03-11T18:29:22 writing manifest file 'pip-egg-info/ydk.egg-info/SOURCES.txt'
2019-03-11T18:29:22 reading manifest file 'pip-egg-info/ydk.egg-info/SOURCES.txt'
2019-03-11T18:29:22 reading manifest template 'MANIFEST.in'
2019-03-11T18:29:22 writing manifest file 'pip-egg-info/ydk.egg-info/SOURCES.txt'
2019-03-11T18:29:22 Source in /tmp/pip-req-build-hc04iqch has version 0.8.1, which satisfies requirement ydk==0.8.1 from file:///var/tmp/ydk-0.8.1/dist/ydk-0.8.1.tar.gz
2019-03-11T18:29:22 Removed ydk==0.8.1 from file:///var/tmp/ydk-0.8.1/dist/ydk-0.8.1.tar.gz from build tracker '/tmp/pip-req-tracker-nv55hm9l'
2019-03-11T18:29:23 Requirement already satisfied: pybind11>=2.1.1 in /usr/local/lib/venv/lib/python3.7/site-packages (from ydk==0.8.1) (2.2.4)
2019-03-11T18:29:23 Installing collected packages: ydk
2019-03-11T18:29:23 Created temporary directory: /tmp/pip-record-m9wmic1r
2019-03-11T18:29:23 Running command /usr/local/lib/venv/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-req-build-hc04iqch/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" --no-user-cfg install --record /tmp/pip-record-m9wmic1r/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/lib/venv/include/site/python3.7/ydk
2019-03-11T18:29:23 running install
2019-03-11T18:29:23 running build
2019-03-11T18:29:23 running build_py
2019-03-11T18:29:23 creating build
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk
2019-03-11T18:29:23 copying ydk/exthook.py -> build/lib.linux-x86_64-3.7/ydk
2019-03-11T18:29:23 copying ydk/__init__.py -> build/lib.linux-x86_64-3.7/ydk
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/types
2019-03-11T18:29:23 copying ydk/types/py_types.py -> build/lib.linux-x86_64-3.7/ydk/types
2019-03-11T18:29:23 copying ydk/types/__init__.py -> build/lib.linux-x86_64-3.7/ydk/types
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 copying ydk/services/netconf_service.py -> build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 copying ydk/services/executor_service.py -> build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 copying ydk/services/crud_service.py -> build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 copying ydk/services/codec_service.py -> build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 copying ydk/services/__init__.py -> build/lib.linux-x86_64-3.7/ydk/services
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/providers
2019-03-11T18:29:23 copying ydk/providers/netconf_provider.py -> build/lib.linux-x86_64-3.7/ydk/providers
2019-03-11T18:29:23 copying ydk/providers/codec_provider.py -> build/lib.linux-x86_64-3.7/ydk/providers
2019-03-11T18:29:23 copying ydk/providers/__init__.py -> build/lib.linux-x86_64-3.7/ydk/providers
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/path
2019-03-11T18:29:23 copying ydk/path/__init__.py -> build/lib.linux-x86_64-3.7/ydk/path
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/models
2019-03-11T18:29:23 copying ydk/models/__init__.py -> build/lib.linux-x86_64-3.7/ydk/models
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/logging
2019-03-11T18:29:23 copying ydk/logging/__init__.py -> build/lib.linux-x86_64-3.7/ydk/logging
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/filters
2019-03-11T18:29:23 copying ydk/filters/__init__.py -> build/lib.linux-x86_64-3.7/ydk/filters
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/ext
2019-03-11T18:29:23 copying ydk/ext/__init__.py -> build/lib.linux-x86_64-3.7/ydk/ext
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/errors
2019-03-11T18:29:23 copying ydk/errors/error_handler.py -> build/lib.linux-x86_64-3.7/ydk/errors
2019-03-11T18:29:23 copying ydk/errors/__init__.py -> build/lib.linux-x86_64-3.7/ydk/errors
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/entity_utils
2019-03-11T18:29:23 copying ydk/entity_utils/entity_utils.py -> build/lib.linux-x86_64-3.7/ydk/entity_utils
2019-03-11T18:29:23 copying ydk/entity_utils/__init__.py -> build/lib.linux-x86_64-3.7/ydk/entity_utils
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/_core
2019-03-11T18:29:23 copying ydk/_core/_importer.py -> build/lib.linux-x86_64-3.7/ydk/_core
2019-03-11T18:29:23 copying ydk/_core/_dm_meta_info.py -> build/lib.linux-x86_64-3.7/ydk/_core
2019-03-11T18:29:23 copying ydk/_core/__init__.py -> build/lib.linux-x86_64-3.7/ydk/_core
2019-03-11T18:29:23 creating build/lib.linux-x86_64-3.7/ydk/path/sessions
2019-03-11T18:29:23 copying ydk/path/sessions/restconf_session.py -> build/lib.linux-x86_64-3.7/ydk/path/sessions
2019-03-11T18:29:23 copying ydk/path/sessions/netconf_session.py -> build/lib.linux-x86_64-3.7/ydk/path/sessions
2019-03-11T18:29:23 copying ydk/path/sessions/__init__.py -> build/lib.linux-x86_64-3.7/ydk/path/sessions
2019-03-11T18:29:23 running build_ext
2019-03-11T18:29:23 -- The C compiler identification is GNU 8.3.0
2019-03-11T18:29:23 -- The CXX compiler identification is GNU 8.3.0
2019-03-11T18:29:23 -- Check for working C compiler: /usr/bin/cc
2019-03-11T18:29:24 -- Check for working C compiler: /usr/bin/cc -- works
2019-03-11T18:29:24 -- Detecting C compiler ABI info
2019-03-11T18:29:24 -- Detecting C compiler ABI info - done
2019-03-11T18:29:24 -- Detecting C compile features
2019-03-11T18:29:24 -- Detecting C compile features - done
2019-03-11T18:29:24 -- Check for working CXX compiler: /usr/bin/c++
2019-03-11T18:29:24 -- Check for working CXX compiler: /usr/bin/c++ -- works
2019-03-11T18:29:24 -- Detecting CXX compiler ABI info
2019-03-11T18:29:24 -- Detecting CXX compiler ABI info - done
2019-03-11T18:29:24 -- Detecting CXX compile features
2019-03-11T18:29:25 -- Detecting CXX compile features - done
2019-03-11T18:29:25 python version: 3.7m
2019-03-11T18:29:25 -- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython3.7m.so (found version "3.7.2+")
2019-03-11T18:29:25 pybind11 include: /usr/local/lib/venv/include/site/python3.7;/usr/local/lib/venv/include/site/python3.7
2019-03-11T18:29:25 -- Configuring done
2019-03-11T18:29:25 -- Generating done
2019-03-11T18:29:25 -- Build files have been written to: /tmp/pip-req-build-hc04iqch/build/temp.linux-x86_64-3.7
2019-03-11T18:29:25 Scanning dependencies of target ydk_
2019-03-11T18:29:25 [ 50%] Building CXX object CMakeFiles/ydk_.dir/python.cpp.o
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp: In lambda function:
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp:539:39: warning: unused parameter ‘left’ [-Wunused-parameter]
2019-03-11T18:29:26 .def("__eq__", [](ydk::Empty& left, ydk::Empty& right)
2019-03-11T18:29:26 ~~~~~~~~~~~~^~~~
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp:539:57: warning: unused parameter ‘right’ [-Wunused-parameter]
2019-03-11T18:29:26 .def("__eq__", [](ydk::Empty& left, ydk::Empty& right)
2019-03-11T18:29:26 ~~~~~~~~~~~~^~~~~
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp: In lambda function:
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp:543:39: warning: unused parameter ‘left’ [-Wunused-parameter]
2019-03-11T18:29:26 .def("__ne__", [](ydk::Empty& left, ydk::Empty& right)
2019-03-11T18:29:26 ~~~~~~~~~~~~^~~~
2019-03-11T18:29:26 /tmp/pip-req-build-hc04iqch/python.cpp:543:57: warning: unused parameter ‘right’ [-Wunused-parameter]
2019-03-11T18:29:26 .def("__ne__", [](ydk::Empty& left, ydk::Empty& right)
2019-03-11T18:29:26 ~~~~~~~~~~~~^~~~~
2019-03-11T18:29:55 c++: fatal error: Killed signal terminated program cc1plus
2019-03-11T18:29:55 compilation terminated.
2019-03-11T18:29:55 make[2]: *** [CMakeFiles/ydk_.dir/build.make:63: CMakeFiles/ydk_.dir/python.cpp.o] Error 1
2019-03-11T18:29:55 make[1]: *** [CMakeFiles/Makefile2:73: CMakeFiles/ydk_.dir/all] Error 2
2019-03-11T18:29:55 make: *** [Makefile:84: all] Error 2
2019-03-11T18:29:56 Traceback (most recent call last):
2019-03-11T18:29:56 File "<string>", line 1, in <module>
2019-03-11T18:29:56 File "/tmp/pip-req-build-hc04iqch/setup.py", line 145, in <module>
2019-03-11T18:29:56 zip_safe=False,
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/setuptools/__init__.py", line 145, in setup
2019-03-11T18:29:56 return distutils.core.setup(**attrs)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/core.py", line 148, in setup
2019-03-11T18:29:56 dist.run_commands()
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/dist.py", line 966, in run_commands
2019-03-11T18:29:56 self.run_command(cmd)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/dist.py", line 985, in run_command
2019-03-11T18:29:56 cmd_obj.run()
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/setuptools/command/install.py", line 61, in run
2019-03-11T18:29:56 return orig.install.run(self)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/command/install.py", line 589, in run
2019-03-11T18:29:56 self.run_command('build')
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/cmd.py", line 313, in run_command
2019-03-11T18:29:56 self.distribution.run_command(command)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/dist.py", line 985, in run_command
2019-03-11T18:29:56 cmd_obj.run()
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/command/build.py", line 135, in run
2019-03-11T18:29:56 self.run_command(cmd_name)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/cmd.py", line 313, in run_command
2019-03-11T18:29:56 self.distribution.run_command(command)
2019-03-11T18:29:56 File "/usr/lib/python3.7/distutils/dist.py", line 985, in run_command
2019-03-11T18:29:56 cmd_obj.run()
2019-03-11T18:29:56 File "/tmp/pip-req-build-hc04iqch/setup.py", line 68, in run
2019-03-11T18:29:56 self.build_extension(ext)
2019-03-11T18:29:56 File "/tmp/pip-req-build-hc04iqch/setup.py", line 101, in build_extension
2019-03-11T18:29:56 subprocess.check_call([cmake_executable, '--build', '.'], cwd=self.build_temp)
2019-03-11T18:29:56 File "/usr/lib/python3.7/subprocess.py", line 347, in check_call
2019-03-11T18:29:56 raise CalledProcessError(retcode, cmd)
2019-03-11T18:29:56 subprocess.CalledProcessError: Command '['cmake', '--build', '.']' returned non-zero exit status 2.
2019-03-11T18:29:56 Cleaning up...
2019-03-11T18:29:56 Removing source in /tmp/pip-req-build-hc04iqch
2019-03-11T18:29:56 Removed build tracker '/tmp/pip-req-tracker-nv55hm9l'
2019-03-11T18:29:56 Command "/usr/local/lib/venv/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-req-build-hc04iqch/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" --no-user-cfg install --record /tmp/pip-record-m9wmic1r/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/lib/venv/include/site/python3.7/ydk" failed with error code 1 in /tmp/pip-req-build-hc04iqch/
2019-03-11T18:29:56 Exception information:
2019-03-11T18:29:56 Traceback (most recent call last):
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 179, in main
2019-03-11T18:29:56 status = self.run(options, args)
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 393, in run
2019-03-11T18:29:56 use_user_site=options.use_user_site,
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/req/__init__.py", line 57, in install_given_reqs
2019-03-11T18:29:56 **kwargs
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/req/req_install.py", line 945, in install
2019-03-11T18:29:56 spinner=spinner,
2019-03-11T18:29:56 File "/usr/local/lib/venv/lib/python3.7/site-packages/pip/_internal/utils/misc.py", line 761, in call_subprocess
2019-03-11T18:29:56 % (command_desc, proc.returncode, cwd))
2019-03-11T18:29:56 pip._internal.exceptions.InstallationError: Command "/usr/local/lib/venv/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-req-build-hc04iqch/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" --no-user-cfg install --record /tmp/pip-record-m9wmic1r/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/lib/venv/include/site/python3.7/ydk" failed with error code 1 in /tmp/pip-req-build-hc04iqch/

0 Replies 0