cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
885
Views
5
Helpful
16
Replies
Highlighted
Beginner

Shared Libraries Error while installing ydk

Hi,
I have included the python installation in LD_LIBRARY_PATH, but while installing ydk through "pip install ydk", I am getting the following error:

/tmp/pip-install-5vc0wm56/ydk/python.cpp:541:39: warning: unused parameter ‘left’ [-Wunused-parameter]
.def("__eq__", [](ydk::Empty& left, ydk::Empty& right)
^
/tmp/pip-install-5vc0wm56/ydk/python.cpp:541:57: warning: unused parameter ‘right’ [-Wunused-parameter]
.def("__eq__", [](ydk::Empty& left, ydk::Empty& right)
^
/tmp/pip-install-5vc0wm56/ydk/python.cpp:545:39: warning: unused parameter ‘left’ [-Wunused-parameter]
.def("__ne__", [](ydk::Empty& left, ydk::Empty& right)
^
/tmp/pip-install-5vc0wm56/ydk/python.cpp:545:57: warning: unused parameter ‘right’ [-Wunused-parameter]
.def("__ne__", [](ydk::Empty& left, ydk::Empty& right)
^
[100%] Linking CXX shared module ../lib.linux-x86_64-3.6/ydk_.so
/opt/rh/devtoolset-4/root/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/ld: /usr/local/lib/libpython3.6m.a(abstract.o): relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libpython3.6m.a: error adding symbols: Bad value
16 REPLIES 16
Highlighted

The key error:

Libyang error: Loading "/usr/local/lib/libyang/nacm.so" as an extension plugin failed (/lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/lib/libyang/nacm.so)).

The library loader cannot find system C library /lib64/libc.so.6. You need to find its location and include it to LD_LIBRARY_PATH. The last is must to be explicitly configured on fedora (RedHat, CentOS) based systems.

Yan Gorelik
YDK Solutions
Highlighted

I added it to LD_LIBRARY_PATH, but still the issue persists.

 

(netadc_sgang31) [root@xxx netadc3]# $LD_LIBRARY_PATH 
bash: /opt/rh/rh-mongodb32/root/usr/lib64:/lib64/libc.so.6:/home/sgang31/.venvs3/netadc3/bin/lib/libyang: No such file or directory

Error:

Path where models are to be downloaded: /root/.ydk/x.x.x.x
Data is invalid according to the yang model. Libyang error: Loading "/usr/local/lib/libyang/nacm.so" as an extension plugin failed (/lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/lib/libyang/nacm.so)).
Data is invalid according to the yang model. Libyang error: Loading "/usr/local/lib/libyang/metadata.so" as an extension plugin failed (/lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/lib/libyang/metadata.so)).
Data is invalid according to the yang model. Libyang error: Invalid keyword "type" as a child to "annotation". Path: '/'
Data is invalid according to the yang model. Libyang error: Module "yang" parsing failed.
Could not create repository in: /root/.ydk/x.x.x.x
This widget could not be displayed.