cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
377
Views
0
Helpful
3
Replies
Highlighted
Beginner

Problem after Upgrade to 4.2(4k) - VMM Enhanced LAG Policy

Hello, 

 

we recently updated the ACI fabric from version 3.2 (3n) to 4.2 (4k)

 

After that the following behavior occurs:

Associating an EPG with a physical domain works and all systems within the EPG can communicate with each other.

Association an EPG with a given VMM domain works but systems within the EPG can't communicate with each. 

 

All other EPGs which was assigned to a VMM domain before the upgrade works also fine. 

 

We got the following error: 

Affected    : comp/prov-VMware/ctrlr-[DVS-Production]-VCSA_Production

Cause       : oper-issues

Description : Operational issues detected on EnhancedLag Policy: lag1 in 

             VM Controller:VCSA_Production, VM Domain:DVS-Production, VM Provider:VMware,

             error: Cannot find a lacpEnhancedLag policy in the domain   

             for the EnhancedLag policy on the DVS   

 

Also I noticed since version 3.2(7n) there is a requirement for using Enhanced Lag Policy when VDS is > Verison 6.6

Currently we don't have an enhanced LAG Policy.

 

My questions: 

  • What happens if we create an Enhanced LAG Policy under the vSwitch Policy? 
  • What happens if we assign the new Enhanced LAG Policy to the EPG within the VMM association?
3 REPLIES 3
Highlighted
Cisco Employee

Hello.  While I am no VMware expert, I do use it in my own lab.  To me, this sounds like you have Enhanced Lag setting on the ESX side, and APIC is just telling you that you have not set anything on its side to match.  I would check how you set up your ESXi VMnics and see if you are somehow using Enhance Lag in vCenter. 

For my own opinion, I've always just used a Mac Pinning policy in my ACI fabric because I never had much luck with actual port channeling in ESX. 

For curiosity, I setup a new VMM domain in my fabric (not the upgrade that you used) and I chose DVS 6.6.  I did not need to set any enhanced lag policy to get it to work. 

Highlighted

Hi Joe,

 

thanks for your answer. We solved the problem while creating the enhanced LAG policy. 

It's a recommendation doing this should be in a maintenance window because the vSwitch lost its connections. 

 

Kind regards

Udo 

Highlighted

Hello Udo.  Just for my own learning, you had to make the eLag policy in APIC because your vCenter was requiring it (i.e that the ESX hosts were set up that way by the VM admin) right?

This widget could not be displayed.