cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
AMA event- Migrating Existing Networks to Cisco ACI
697
Views
0
Helpful
6
Replies
Beginner

Cisco WAAS and Content Switching Module compatiblity

We are planning to implement WAAS on our hub's 6500 core switches, so that TCP connections from the end sites users to the servers in the hub can be optimized. But we have the servers VLAN groups under the Cisco CSM module already. Are the client-server connections still able to be optimized by WAAS?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Cisco WAAS and Content Switching Module compatiblity

Hi Joe

let's seperate out the two topics here.

a) WAAS traffic interception with wccp

b) CSM

a) when you say vlan 200 is where target servers are connected, is that the CSM client side vlan? or the actual server vlan ?

the bottom line is you need to make sure the interface where you configure "ip wccp 61 redirect in" is recieving traffic from servers towards .

Good reference for WCCP best practices in 6500

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/white_paper_c11-629052.html

b) yes you can configure stickiness for session persistance as in below URL

http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/csm/4.2.x/configuration/guide/addftrs.html

Thanks

View solution in original post

6 REPLIES 6
Cisco Employee

Cisco WAAS and Content Switching Module compatiblity

Hi Joe

Are you referring to implementing WCCP traffic interception in the 6500 for WAAS ?

if yes, you can implement wccp in the 6500 with CSM module. in WCCP, what you need to make sure is your incoming and outgoung traffic is redirected by WCCP for WAE to look at, and you apply the wccp redirection in the right interfaces.

For incoming traffic from clients side, you should be able to apply the wccp redirection in the client facing interfaces. And for return traffic by servers (ie from CSM), you can apply the wccp redirection in the SVI (interface vlan in SUP) which connects with CSM client facing side.

However having the bit understanding of the topology will be helpful to further comment on this.

Thanks

Thusi

Beginner

Cisco WAAS and Content Switching Module compatiblity

Hi Thusi,

Yes, I'm referring to implementing WCCP traffic interception on the 6500 switches for WAAS.

We are going to apply the redirection with the configuration similar to the below:

interface GigabitEthernet0/0 (connecting to the WAN router, where the clients traffic coming from)

ip wccp 62 redirect in

!

interface Vlan200 (where the target servers are connecting to)

ip wccp 61 redirect in

!

Do we need to configure any stickiness in CSM for session persistence?

Thanks!

Cisco Employee

Cisco WAAS and Content Switching Module compatiblity

Hi Joe

let's seperate out the two topics here.

a) WAAS traffic interception with wccp

b) CSM

a) when you say vlan 200 is where target servers are connected, is that the CSM client side vlan? or the actual server vlan ?

the bottom line is you need to make sure the interface where you configure "ip wccp 61 redirect in" is recieving traffic from servers towards .

Good reference for WCCP best practices in 6500

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/white_paper_c11-629052.html

b) yes you can configure stickiness for session persistance as in below URL

http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/csm/4.2.x/configuration/guide/addftrs.html

Thanks

View solution in original post

Beginner

Cisco WAAS and Content Switching Module compatiblity

Hi Thusi,

The VLAN 200 is the CSM client side vlan, so that I could have the traffic from servers being redirected by "ip wccp 61 redirect in".

The CSM configuration is as below (in bridge mode):

module ContentSwitchingModule 5

!

vlan 200 client

  ip address 10.2.2.20 255.255.255.0 alt 10.2.2.21 255.255.255.0

  gateway 10.2.2.1

!

vlan 201 server

  ip address 10.2.2.20 255.255.255.0 alt 10.2.2.21 255.255.255.0

!

interface Vlan200

ip address 10.2.2.2 255.255.255.0

no ip redirects

no ip proxy-arp

standby 1 ip 10.2.2.1

standby 1 priority 110

standby 1 preempt

standby 1 name TEST-SERVERFARM

!

Thanks,
Joe

Cisco Employee

Cisco WAAS and Content Switching Module compatiblity

Hi Joe

looks good. Hope "ip wccp 61 redirect in" will be there under int Vlan200

regards

Thusi

Highlighted
Beginner

Cisco WAAS and Content Switching Module compatiblity

Thanks Thusi!

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards