cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

487
Views
0
Helpful
3
Replies
pamirian76
Beginner

CSS 11501 problem with cookie and load balancing

hi and thanks for reading,

the css works fine, I can load balance using balance leastconn but I'm having some problems using cookie.

here is what I have,

content web

add service myserver1

add service myserver2

vip address 1.0.76.19

port 8443

protocol tcp

balance leastconn

active

but when I change it to

content web

add service myserver1

add service myserver2

vip address 1.0.76.19

port 8443

protocol tcp

advanced-balance arrowpoint-cookie

active

with this nothing works.

actually I don't really understand who creates the cookie. does the CSS create the cookie in the client browser or an empty cookie must exist prior hitting the css?

any examples out there with some good explaining? I've done alot of reading on this site but still don't understand how this cookie sticky sessions really works.

thank you very much!!

3 REPLIES 3
melchib
Beginner

Hi.

This is an older document, but it might help you out:

http://www.cisco.com/warp/public/117/AP_cookies.html

drex_72
Beginner

In your "mrserver1" & "myserver2" service, add the following:

string

For instance:

service myserver1

ip address 10.10.10.5

keepalive port 80

protocol tcp

string myserver1

active

service myserver2

ip address 10.10.10.6

keepalive port 80

protocol tcp

string myserver2

active

cschneid
Cisco Employee

Typically you would add the following two

options to the content rule if you want to use

arrowpoint-cookies:

url "/*"

advanced-balance arrowpoint-cookie

However, this only works for http based connections. I see that you are using port 8443 and suggests that possibly this is an SSL content rule and not an http content rule. If it's SSL, then arrowpoint-cookie won't work for you in this content rule.

Regarding who creates the cookie, it's the CSS. It generates a session based cookie that is good as long as the browser is open (there are several options that can be configured for this but this is the default behavior).

Hope this helps.

-Chip

Content for Community-Ad
This widget could not be displayed.