cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Community Live- Tenant Routed Multicast in VXLAN EVPN Fabric
917
Views
0
Helpful
1
Replies
Highlighted

Unable to make call MS lync to CUCM if using ACE 4710 LB

Dear Team,

We have CUCM & lync server setup and its working fine if any one calling each other with DNS load balancing. But customer want ot use Cisco ACE 4710

instead of DNS LB.

We have configured Cisco LB and deploy but when CUCM user calling to lync user call going to disconnect after 4 sec and also Lync users unable to make call to CUCM.

And also LB deploye between share point but when users are trying to open web session that time web page going to show page cannot display.

For your reference please find the ace configuration

SPM-LB-ACE-2/Admin# sh run
Generating configuration....


logging enable
logging trap 7
logging monitor 7

resource-class LoadBalancingResources
  limit-resource all minimum 0.00 maximum unlimited

boot system image:c4710ace-mz.A4_2_0.bin

peer hostname SPM-LB-ACE-1
hostname SPM-LB-ACE-2
interface gigabitEthernet 1/1
  channel-group 48
  no shutdown
interface gigabitEthernet 1/2
  no shutdown
interface gigabitEthernet 1/3
  shutdown
interface gigabitEthernet 1/4
  shutdown
interface port-channel 48
  switchport trunk allowed vlan 1-350
  no shutdown


crypto authgroup auth_Group
context Admin
  member LoadBalancingResources

crypto csr-params ROOT_CICSO-HLB
  country IN
  state Delhi
  locality Delhi
  organization-name MHA
  organization-unit IT
  common-name ROOT_CICSO-HLB

access-list everyone line 8 extended permit ip any any
access-list everyone line 16 extended permit icmp any any

probe icmp ICMP
  interval 15
  passdetect interval 60
probe tcp TCP-443
  port 443
  interval 15
  passdetect interval 60
  open 1
probe tcp TCP-4443
  port 4443
  interval 15
  passdetect interval 60
  open 1
probe tcp TCP-80
  port 80
  interval 15
  passdetect interval 60
  open 1

rserver host SP01-EXC-ITV-01
  ip address 172.20.152.4
  inservice
rserver host SP01-EXC-ITV-02
  ip address 172.20.152.32
  inservice
rserver host SP01-LYC-ITV-01
  description Lync_Server1
  ip address 172.20.152.8
  probe ICMP
  inservice
rserver host SP01-LYC-ITV-02
  description Lync_Server2
  ip address 172.20.152.15
  probe ICMP
  inservice
rserver host SP01-SPS-ITV-01
  description Share_Point_Server1
  ip address 172.20.152.7
  inservice
rserver host SP01-SPS-ITV-02
  description Share_Point_Server2
  ip address 172.20.152.16
  inservice

serverfarm host Exchange_Server
  rserver SP01-EXC-ITV-01
    inservice
  rserver SP01-EXC-ITV-02
    inservice
serverfarm host Lync_Server_Farm
  description This the the Server Farm for Lync servers 1 & 2
  rserver SP01-LYC-ITV-01
    weight 1
    backup-rserver SP01-LYC-ITV-02
    inservice
  rserver SP01-LYC-ITV-02
    backup-rserver SP01-LYC-ITV-01
    inservice
serverfarm host SP01-LYC-ITV-DIR-01-443
  predictor response syn-to-close
  probe TCP-443
  rserver SP01-LYC-ITV-01
  rserver SP01-LYC-ITV-02
serverfarm host SP01-LYC-ITV-DIR-01-5061
  predictor response syn-to-close
  rserver SP01-LYC-ITV-01
  rserver SP01-LYC-ITV-02
serverfarm host Sharepoint_ServerFarn
  rserver SP01-SPS-ITV-01
    inservice
  rserver SP01-SPS-ITV-02
    inservice

sticky sip-header Call-ID Lync_Stick
  timeout activeconns
  replicate sticky
  serverfarm Lync_Server_Farm
  1 static header-value "1" rserver SP01-LYC-ITV-01 5061
  2 static header-value "2" rserver SP01-LYC-ITV-02 5061
sticky ip-netmask 255.255.255.255 address source S-SP01-LYC-ITV-DIR-01-443
  replicate sticky
  serverfarm SP01-LYC-ITV-DIR-01-443
sticky ip-netmask 255.255.255.255 address source S-SP01-LYC-ITV-DIR-01-5061
  replicate sticky
  serverfarm SP01-LYC-ITV-DIR-01-5061
sticky http-cookie MS-WSMAN S-SP01-LYC-ITV-DIR-01-5061-COOKIE
  cookie insert
  replicate sticky
  serverfarm SP01-LYC-ITV-DIR-01-5061
sticky http-cookie MS-WSMAN S-SP01-LYC-ITV-DIR-01-443-COOKIE
  cookie insert
  replicate sticky
  serverfarm SP01-LYC-ITV-DIR-01-443


class-map match-all 102-vip
  2 match virtual-address 172.20.152.100 tcp eq https
class-map match-all LYNCDIR01-4443
class-map match-all Lync_server_Virtual_IP
  2 match virtual-address 172.20.152.44 any
class-map match-all SP01-LYC-ITV-DIR-01-443-l7slb
class-map match-all SP01-LYC-ITV-DIR-01-5061-l7slb
class-map match-all Server_Load_Balancer_Virtual_IP_for_Sharepoint
  2 match virtual-address 172.20.152.43 any
class-map match-all Server_load_balancer-Virtual_IP
  2 match virtual-address 172.20.152.42 any
class-map type management match-any remote-access
  description remote-access-traffic-match
  2 match protocol telnet any
  3 match protocol ssh any
  4 match protocol icmp any
  5 match protocol http any
  6 match protocol https any

policy-map type management first-match mgmt-pm
  class class-default
    permit
policy-map type management first-match remote-mgmt
  class remote-access
    permit

policy-map type loadbalance first-match Lync_server_Virtual_IP-l7slb
  class class-default
    serverfarm Lync_Server_Farm
policy-map type loadbalance first-match SP01-LYC-ITV-DIR-01-443-l7slb
  class class-default
policy-map type loadbalance first-match SP01-LYC-ITV-DIR-01-5061-l7slb
  class class-default
policy-map type loadbalance first-match Server_Load_Balancer_Virtual_IP_for_Shar
epoint-l7slb
  class class-default
    serverfarm Sharepoint_ServerFarn
policy-map type loadbalance first-match Server_load_balancer
  class class-default
    serverfarm Exchange_Server

policy-map multi-match Client-virtual_IPs
  class Server_load_balancer-Virtual_IP
    loadbalance vip inservice
    loadbalance policy Server_load_balancer
    loadbalance vip icmp-reply active
    nat dynamic 100 vlan 152
  class Server_Load_Balancer_Virtual_IP_for_Sharepoint
    loadbalance vip inservice
    loadbalance policy Server_Load_Balancer_Virtual_IP_for_Sharepoint-l7slb
    nat dynamic 100 vlan 152
  class Lync_server_Virtual_IP
    loadbalance vip inservice
    loadbalance policy Lync_server_Virtual_IP-l7slb
    nat dynamic 100 vlan 152
policy-map multi-match int404

interface vlan 150
  ip address 172.20.150.102 255.255.255.0
  alias 172.20.150.100 255.255.255.0
  peer ip address 172.20.150.101 255.255.255.0
  service-policy input remote-mgmt
  no shutdown
interface vlan 152
  description "Client-Server VLAN"
  ip address 172.20.152.102 255.255.255.0
  alias 172.20.152.100 255.255.255.0
  peer ip address 172.20.152.101 255.255.255.0
  access-group input everyone
  nat-pool 100 20.20.20.1 20.20.20.32 netmask 255.255.255.0 pat
  service-policy input remote-mgmt
  service-policy input Client-virtual_IPs
  service-policy input mgmt-pm
  service-policy input int404
  no shutdown

ft interface vlan 300
  ip address 10.10.10.2 255.255.255.0
  peer ip address 10.10.10.1 255.255.255.0
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 20
  ft-interface vlan 300
  query-interface vlan 152
ft group 3
  peer 1
  peer priority 110
  associate-context Admin
  inservice

ip route 0.0.0.0 0.0.0.0 172.20.152.254


context LoadBalancing
  member LoadBalancingResources
context WAAS
  description WAAS Virtual Device

ft group 1
  peer 1
  peer priority 110
  associate-context LoadBalancing
  inservice
ft group 2
  peer 1
  peer priority 110
  associate-context WAAS
  inservice
username admin password 5 $1$55.bffEo$p1zjW9mAujWwn.nZ23jyi0  role Admin domain
default-domain
username www password 5 $1$JpZD7iQ3$xZoLa9zbEMR2asj4IKUOf.  role Admin domain de
fault-domain

ssh key rsa 1024 force


SPM-LB-ACE-2/Admin#

I am requesting you to please help me.

Regards,

Pushpendra

9899417387

Everyone's tags (9)
1 REPLY 1
Highlighted

Unable to make call MS lync to CUCM if using ACE 4710 LB

Please help us for the below questing..

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey