cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
194
Views
0
Helpful
4
Replies

CCA 3.2 ß & iPhone (Cisco Jabber client)

Arturo Bianchi
Beginner
Beginner

CiscoJabberWaiting.pngHi Team!

I'm trying to add an extension with Cisco Jabber, but the program does not register and I can not figure out what does not work.

I tried some debugging (voice register events, voice register errors, ephone error) but I see nothing. I double checked the manual and I see no specific guidance! In fact I have no idea if the problem is directly from the client (8.6.1.18384) or the version of iOS on my iPhone (4.3.5). I tried with and without authentication, only runs the hourglass and after a while writes that it is not possible to verify the account!

NB: The IP of the server is pingable from the iPhone. I have not tried restarting the UC500 because I guess it is not necessary.

More generally, I see that there is no debug CCA for this client, and that the extension with Cisco Mobile (!? Cisco Jabber!?) lacks the ability to declare the shared line (to associate it to other phones and/or mobile extension).

Happy New Year Folks!

73,

Arturo.

4 Replies 4

Arturo Bianchi
Beginner
Beginner

Opsss... I had forgotten the magic word :-) SEPxxxxxx on ID and now it is registered!

But except initially, now I can not call or receive calls, the symbol is green, the extension number is displayed but if I call I get a busy! Among other things I was not able to enable integration with the desk phone (but I have some doubts about the password) and still could not use the phone book where all the numbers with international prefix (+NN ...).

Think of it, I must have had some problems with a scheduled reboot on the UC500 ... I do some testing tomorrow! Now I just wanted to point out that I had entered the wrong ID (you can also see in the screenshot!).

73,

Arturo.

Arturo Bianchi ha scritto:

now I can not call or receive calls

Ok, it is a codec trouble:

%VOICE_IEC-3-GW: SIP: Internal Error (INVITE, codec mismatch): IEC=1.1.278.7.110.0 on callID 204

...This has happened because I enabled the flag for 'Lower bandwith' on the Cisco Jabber that I imagine use a codec not configured on UC500 (G.729 or other?)

So now Cisco Jabber works but still with some strange problem; the most important thing is not to start an outgoing call, I get lost the call after a few seconds and UC500 report message like:

%VOICE_IEC-3-GW: SIP: Internal Error (ACK wait timeout): IEC=1.1.129.7.66.0 on callID 209

While incoming calls work well, at least until it is pressed, on Cisco Jabber, the hold key! Yes, I forget what happens next ... the call is on hold but the keyboard screen has disappeared and I can not make the resume in any way . Possible that there are all these problems? It depends on the software versions, configuration of equipment, or other (myself ) ???

73,

Arturo.

Possible that there are all these problems? It depends on the software versions, configuration of equipment, or other....

Ok,

waiting for someone to want to add a few comments I continue to update you ....

Suddenly I noticed that I could not get more "Call Blast Groups", get a nice java error.... but having not touched anything on the groups I was puzzled and I threw a look at the cfg. do not ask me how or why, but I found something that, intuitively, does not convince me...

voice register dn  1

number 281

name Arturo Bianchi

no-reg

label Linea

!

voice register dn  2

number 281

name Arturo Bianchi

no-reg

!

voice register pool  1

id mac 0041.E64X.XXXX

!

voice register pool  2

registration-timer max 720 min 660

id mac 041E.64XX.XXXX

session-transport tcp

type CiscoMobile-iOS

number 1 dn 2

dtmf-relay rtp-nte

username iphone1 password 111111

codec g711ulaw

Two entries related to the extension 281 Given this I decided to remove the user configured, after that I look at cfg and I have only seen:

voice register dn  1

number 281

name Arturo Bianchi

no-reg

label Linea

!

voice register pool  1

id mac 0041.E64X.XXXX

I am sure that is the result of something done by the CCA because the extension is that the mac-address and even if a byte is moved to the phone; ok, I felt entitled to enter into CLI and type two commands: no voice register dn1 and no voice register pool 1 ...At this point I opened my CCA and I put back the desired extension with all previous data. The first thing I noticed is that it finally came back to see call blast groups, there was no more the java exception!!! Bingo! At least I thought at the time... I turned the phone ... and I imagined being able to check if he was better, but I found a nasty surprise, the phone does not register more... .

000446: voice_reg_get_reg_expires_timer: no voice register pool found
000447: VOICE_REG_POOL: Register request for (281) from (ip.ip.ip.ip)
000448: auth absent
000449: VOICE_REG_POOL: key(A40B388B00E3F480) added to nonce table
000450: VOICE_REG_POOL: Contact doesn't match any pools
000451: voice_reg_get_reg_expires_timer: no voice register pool found
000452: VOICE_REG_POOL: Register request for (281) from (ip.ip.ip.ip)
000453: auth present
000454: VOICE_REG_POOL: Contact doesn't match any pools
000455: voice_reg_get_reg_expires_timer: no voice register pool found
000456: VOICE_REG_POOL: Register request for (281) from (ip.ip.ip.ip)
000457: auth present
000458: VOICE_REG_POOL: Contact doesn't match any pools
000459: voice_reg_get_reg_expires_timer: no voice register pool found
000460: VOICE_REG_POOL: Register request for (281) from (ip.ip.ip.ip)
000461: auth present
000462: VOICE_REG_POOL: Contact doesn't match any pools
000463: voice_reg_get_reg_expires_timer: no voice register pool found
000464: VOICE_REG_POOL: Register request for (281) from (ip.ip.ip.ip)
000465: auth absent
000466: VOICE_REG_POOL: key(90A5FB4600E3F766) added to nonce table
000467: VOICE_REG_POOL: Contact doesn't match any pools

I do not understand ... maybe now I have to delete the profile from the phone and the repetition of registration or try to restart everything?

NB: Something must have gone wrong in the CCA from the entries that can only have left during a first attempt to enter the extension and that CCA could not see...

73,

Arturo.

For completeness, I add the output of the differences between the first configuration, where the iPhone work only to receive calls, and after the changes, where it does not register anymore! - Arturo Bianchi

waiting for someone to want to add a few comments I continue to update you ....

Hello,

can someone on the CCA team give me some indication??

I restored the intermediate conditions (accepts receiving calls) but I suspect that something is not working in the CCA, I can also delete and recreate the profile, but three things are certain (even if I do not understand why):

  • I can not make outgoing calls from iphone [SIP: Internal Error (ACK wait timeout)]
  • It does not work, on the iphone, the hold button (when pressed there is no way to return the call)
  • I can no longer change the profile password (if I put a new password does not align something and does not login more)

This tests are conducted in the local wifi.

Someone could make it work smoothly? Do you think there is some problem due to CCA or simply a local configuration rather badly digested by the CCA? Or what else .... somewhere, I show that, I must use Cisco Jabber (or supported) only from IOS 5.x, while still running 4.3.x on my phone?

73,

Arturo.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers