cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

282
Views
0
Helpful
2
Replies
karasshi
Beginner

No audio when using Jabber from AnyConnect Devnet Sandbox

Hi, 

I've reserved a UCCX 12.5 sandbox. Everything in the sandbox machines works fine. I can use Jabber in the RDC machine in sandbox LAN.

But when I tried to install AnyConnect in my home computer and use Jabber, something is wrong. I can use Jabber to login and use my Computer to make calls to IVR 6000. But I cannot hear anything. There is no RTP package at all through VPN. 

And I tried to use SIP Softphones to test. The same thing happened. I can make calls between VPN PC and LAN PC, but there is no RTP package. 

I even tried to use 2 different softphones in the same VPN PC. They can make calls to each other, but still no audio. 

 

Summary: 

1. Calls between 2 Jabbers in LAN: Good.

2. Calls between 2 Softphones in LAN: Good. 

3. Calls between 2 Jabbers in LAN and VPN: no audio. 

4. Calls between 2 Softphone in LAN and VPN: no audio.

5. Calls between 2 softphones in the same VPN PC: no audio. 

 

To me, it looks like that AnyConnect VPN is dropping RTP packets, so there is no audio for all cases in the VPN PC. I've tried to use the same PC and softphone with other SIP server when VPN was disconnected, they are all good. So there is no problem with my PC firewall or softphone. 

 

Does anyone know why is this and how to fix this? 

2 REPLIES 2
alexstev
Cisco Employee

 

Hello,

I reserved the UCCX 12.5 Sandbox to test it. I agree with you, we can chat and make calls but no audio.

 

Chat between Jabbers 1 and 2 successful in VPN

UCCX Chat Test.png

 

 

 

 

 

 

 

Calls between Jabbers 1 and 3 connection successful in VPN (but no audio can be heard)

UCCX Call Test.png

 

 

 

 

 

 

 

 

I was able to connect calls from these three places (but no audio can be heard):

 

  • Jabber app on my desktop
  • Japper app in Sandbox RDP
  • Finesse Agent Web Gui

 

So my first thought is there are two possible issues:

 

  1. There is a mechanism blocking audio between interfaces on a local machine (you cannot talk to yourself for good reason)
  2. The RTP or other packet/port is blocked for some reason

 

However, another thing I noticed is there is no microphone or speaker connected to the Jabber agent in the Sandbox RDP.

Sandbox RDP - No Speaker-Mic.png

I was eventually able to get the speaker recognized by going through Control Panel --> Sounds. However, no microphone could be found, even in the device manager. So that means using the RDP through the Sandbox for Jabber won't work. We must use Jabber on our Desktop of the Finesse GUI Dashboard (both in the VPN)

 

Speaker Fixed / Mic not found

Sandbox RDP Speaker fixed, no Mic.png

 

 

 

 

 

 

 

My testing is concluded, as I believe I need a physical phone at my location to hook up to the Finesse Dashboard for proper configuration and testing and I do not have it at this time.

 

My notes, in conclusion,

 

  • I confirm that calls can connect but no audio can be heard between calls
  • It could be a designed mechanism or sandbox misconfiguration
  • The Jabber on the Sandbox RDP is configured for no audio and even when configured correctly there is no microphone
  • Use a local Jabber or the Finesse Dashboard to call

 

I will now bring this discussion to the attention of the Developer Advocate assigned to this sandbox so we can get some answers and / or a fix.

alexstev
Cisco Employee

Hello @karasshi,

I have been advised the sandbox engineers will fix this issue in all applicable sandboxes during their next maintenance window. You can request this just for your sandbox lab in the support forum or ticket support system and they will try to accommodate. --> https://community.cisco.com/t5/devnet-sandbox/bd-p/4426j-disc-dev-devnet-sandbox

 

Hope this helps!

Create
Recognize Your Peers
Content for Community-Ad