cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
922
Views
0
Helpful
4
Replies

CSCuh24040 - BGP routes not marked Stale nor removed when peer down w/ BFD signaling

001307: Jul 22 01:10:36 edt: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001308: Jul 22 01:11:01 edt: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001469: Nov 19 02:26:18 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001470: Nov 19 02:26:52 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001487: Nov 26 01:57:45 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001488: Nov 26 01:58:57 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001489: Nov 26 02:35:29 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001490: Nov 26 02:37:15 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001491: Nov 26 03:24:17 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001492: Nov 26 03:25:14 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001493: Nov 27 14:12:46 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001494: Nov 27 14:13:22 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001495: Nov 27 21:35:44 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001496: Nov 27 21:36:11 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001497: Nov 27 21:55:30 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001498: Nov 27 21:55:58 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001499: Nov 28 00:54:12 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001500: Nov 28 00:56:42 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001511: Nov 28 08:33:19 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001512: Nov 28 08:33:40 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001513: Nov 28 13:57:11 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001514: Nov 28 13:59:04 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up
001515: Nov 28 14:00:14 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Down BFD adjacency down
001516: Nov 28 14:00:43 EST: %BGP-5-ADJCHANGE: neighbor 68.139.69.145 Up

4 Replies 4

We are getting these logs on device as checked with Carrier there is no issue.

 

isco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-M), Version 12.2(33)SXI9, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Fri 24-Feb-12 21:38 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)SX7, RELEASE SOFTWARE (fc1)

nys-05core1 uptime is 2 years, 11 weeks, 5 days, 4 hours, 26 minutes
Uptime for this control processor is 2 years, 11 weeks, 5 days, 3 hours, 35 minutes
Time since nys-05core1 switched to active is 2 years, 11 weeks, 5 days, 3 hours, 42 minutes
System returned to ROM by reload at 16:23:22 UTC Wed Sep 3 2014 (SP by reload)
System restarted at 11:27:48 edt Sat Sep 8 2018
System image file is "sup-bootdisk:s72033-ipservicesk9_wan-mz.122-33.SXI9.bin"
Last reload reason: Unknown reason

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C6506-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
Processor board ID SAL1107GWMS
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from s/w reset
1 Virtual Ethernet interface
50 Gigabit Ethernet interfaces
16 Ten Gigabit Ethernet interfaces
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

can i see config of both BGP and BFD?
is there any default route toward the loopback of neighbor BGP?

nys-05core1#sh bfd neighbors details

NeighAddr LD/RD RH/RS State Int
68.139.69.145 1/-2147155942 Up Up Gi1/17
Session state is UP and not using echo function.
OurAddr: 68.139.69.146
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 999000, MinRxInt: 999000, Multiplier: 3
Received MinRxInt: 999000, Received Multiplier: 3
Holddown (hits): 2221(0), Hello (hits): 999(16845)
Rx Count: 16144, Rx Interval (ms) min/max/avg: 260/1000/915 last: 776 ms ago
Tx Count: 16846, Tx Interval (ms) min/max/avg: 756/1008/879 last: 160 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Uptime: 04:06:28
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: -2147155942 - Your Discr.: 1
Min tx interval: 999000 - Min rx interval: 999000
Min Echo interval: 0
nys-05core1#
nys-05core1#
nys-05core1#sh run | i bgp
ip bgp fast-external-fallover permit
redistribute bgp 65438 route-map bgp-to-eigrp
router bgp 65438
bgp always-compare-med
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
redistribute eigrp 101 route-map eigrp-to-bgp
route-map eigrp-to-bgp permit 10
route-map eigrp-to-bgp deny 20
route-map bgp-to-eigrp permit 10
route-map bgp-to-eigrp permit 15
route-map bgp-to-eigrp deny 200
nys-05core1#
nys-05core1#
nys-05core1#sh run int
nys-05core1#sh run interface Gi1/17
Building configuration...

Current configuration : 329 bytes
!
interface GigabitEthernet1/17
description VN:VzB, CID:C1009210, TYPE:MPLS, LOCA:NY520, LOCZ:, BW:80MB
dampening 30 20 100 255
bandwidth 80000
ip address 68.139.69.146 255.255.255.252
ip flow ingress
ip bgp fast-external-fallover permit
load-interval 30
mls qos trust dscp
bfd interval 999 min_rx 999 multiplier 3
end

 

R1-R2
this BGP is direct or not ? even if you use update source please mention that ?
why BGP is direct or not import ?
ip bgp fast-external-fallover<- this use only for direct BGP neighbor it monitor the link between the two peer
ip bgp fast-fallover <- this use for multi hop neighbor it monitor the reachability of neighbor in routing table

other thing to consideration, 12.2(33) not support multi hop BFD.

so according to above inf. rearrange the config.