12-17-2023 04:52 PM
Currently I am using a Netcom NL1901ACV Modem for a Business NBN Connection that is configured as a iPOE connection with a static IP and VLAN of 100. I would like to change this out for a Cisco "C887VAG-4G-GA-K9" router but unsure how to configure the Cisco configuration below to include the ISP Static IP Details and VLAN ID: 100.
Any help would be much appreciated.
ISP Static IP Details:
VLAN ID: 100
IP address: 110.175.XXX.XXX
Gateway IP address: 110.175.XXX.XXX
Subnet Mask: 255.255.255.252
Primary DNS: 203.12.XXX.XXX
Secondary DNS: 203.12.XXX.XXX
Current Cisco 878VA Router:
controller VDSL 0
operating mode vdsl2
!
controller Cellular 0
no cdp run
!
track 1 ip sla 1 reachability
delay down 10 up 10
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
description WAN-INTERFACE
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
!
interface Vlan1
description RAPSEY-LOCAL-LAN
ip address 192.168.16.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface Dialer0
no ip address
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list LAN interface Ethernet0 overload
ip nat inside source list LAN1 interface Cellular0 overload
ip nat inside source route-map nat2cell interface Cellular0 overload
ip nat inside source route-map nat2dsl interface Ethernet0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0 track 1
ip route 0.0.0.0 0.0.0.0 Cellular0 10
ip route 8.8.4.4 255.255.255.255 Ethernet0 permanent
ip ssh version 2
!
ip access-list extended NAT
permit ip 192.168.16.0 0.0.0.255 any
!
ip sla 1
icmp-echo 8.8.4.4 source-interface Ethernet0
frequency 5
ip sla schedule 1 life forever start-time now
logging trap notifications
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
ipv6 ioam timestamp
!
route-map track-primary-if permit 192
match ip address 102
set interface Ethernet0
!
route-map nat2dsl permit 192
match ip address 101
match interface Ethernet0
!
route-map nat2cell permit 192
match ip address 101
match interface Cellular0
!
access-list 1 permit any
access-list 1 permit 0.0.0.0 255.255.255.0
access-list 1 permit 0.0.0.0 0.0.0.255
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.0.0.0 0.255.255.255 192.0.0.0 0.255.255.255
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
script dialer lte
no exec
rxspeed 100000000
txspeed 50000000
line 8
no exec
rxspeed 100000000
txspeed 50000000
line vty 0 4
access-class 23 in
privilege level 15
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
!
!
!
!
!
event manager applet NAT_CLEAR
event track 1 state any
action 0.0 cli command "enable"
action 1.0 cli command "clear ip nat trans *"
!
end
02-22-2025 06:07 PM
I think you will have to go like this :
interface ethernet0.100
encapsulation dot1Q 100
ip address dhcp
And go from there.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide