cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
223
Views
0
Helpful
5
Replies
Highlighted

DHCP Snooping bug relase Version 16.10.01 X9407R

Hi,

I have a problem when enabling DHCP snooping, all the clients get dropped from the switch when I disable it they work just fine. I am using version 16.10.01 on C9407R switch, does anyone have a similar issue or this is a bug and how to solve it. 

I appreciate your feedbacks.

5 REPLIES 5
Highlighted
Beginner

Re: DHCP Snooping bug relase Version 16.10.01 X9407R

Hello,

Could you please provide switch configuration?

I've checked release note and I've seen issue relative to IP source guard (CSCvn04524) but not with DHCP snooping.

 

Do you configure port connected to DHCP server (or the uplink port / port-channel) with "ip dhcp snooping trust"?

Highlighted

Re: DHCP Snooping bug relase Version 16.10.01 X9407R

Hi,

    find below configuration:

ip dhcp snooping vlan 1-4094
no ip dhcp snooping information option
ip dhcp snooping

!

!

interface GigabitEthernet1/0/19
description Link vs ROUTER 2
switchport access vlan 15
switchport mode access
speed 100
duplex full
service-policy input POLICY_FILESYSTEM_INBOUND
service-policy output POLICY_FILESYSTEM
ip dhcp snooping trust

Now the command "IP DHCP snooping" is not configured but this was the original configuration during the issue.

Highlighted
Beginner

Re: DHCP Snooping bug relase Version 16.10.01 X9407R

Thank you for the configuration provided.

 

Few more questions:

  • Why do you activate DHCP Snooping for ALL vlans and not just user ones?
    • In which VLAN are users that encounter issue? (vlan15?)
  • You provide the configuration of interface Gi1/0/19
    • I assume that DHCP server is connected behind this iface?

 

Highlighted

Re: DHCP Snooping bug relase Version 16.10.01 X9407R

 

  • Why do you activate DHCP Snooping for ALL vlans and not just user ones? it was a migration process from old switch to new switch and I was requested to migrate it as it is. 
    • In which VLAN are users that encounter issue? (vlan15?) yes vlan 15 and other vlans
  • You provide the configuration of interface Gi1/0/19
    • I assume that DHCP server is connected behind this face? yes 

 

Highlighted
Beginner

Re: DHCP Snooping bug relase Version 16.10.01 X9407R

Thank you for your answers.

 

Your issue seems to indicate that the "ip dhcp snooping trust" CLI command is not working properly.

By design, this command allow a port to receive DHCP OFFER from a DHCP server and, even if your configure this on the Gi1/0/19 it seems that your DHCP Requests get dropped on this interface.

 

To go further on this investigation, is it possible for you to activate DHCP snooping debugging "debug ip dhcp snooping event"?

This will probably helps us to understand the reason why these packets gets dropped.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey