cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
301
Views
0
Helpful
3
Replies
Highlighted
Beginner

second router doesn't give internet to vlan on packet tracer

The router in green has the following commands (to allow internet access to the vlans):

Each vlan has: ip nat inside

Then, the router has a list of the vlans created:

ip access-list standard MIS-REDES

permit 202.50.100.0 0.0.0.255    <----vlan 100

permit 202.50.120.0 0.0.0.255    <----vlan 120

permit 202.50.140.0 0.0.0.255    <----vlan 140

exit

 

And then, we added the net interface:

ip nat inside source list MIS-REDES interface fa0/0 overload      <----interfaz fa0/0

 

All vlans in the green area can access internet without any problem. 

But in the blue section we have the second router (connected to the first one), which has internet. But when I added the vlans to this router, they do not have internet access. I tried using the same commands as in the first router, but unsuccessfully.

 

How can the vlans for the second router get internet access?

Does anyone know if the commands have to be different?

 

 

3 REPLIES 3
Highlighted
Hall of Fame Community Legend

To all concerned,
It is very clear this thread is school work.
Help the students learn: Post the links to documents and configuration guides.
Please refrain from handing out answers.

Highlighted
VIP Advisor

Hi @PuckaB17 

 

Things to keep in mind:
-Only the border router should perform NAT.
-As the border router needs a default route to route packets to unknown destinations, other routers also need a default route to know where to send packets to an unknown destination.

-All internal interfaces of the border router must be indicated as ip nat inside.
-The border router must have a route to internal destinations, whether you learn them by a routing protocol or by static routes.

Check those parameters and let us know if they work for you.

 

Regards

 

Highlighted
Beginner

Hi  PuckaB17,

As per Topology shown-

 

Router 2-Router Anexo 2911---(has no internet on vlan, which is your problem to be solved?)--blue section

Router 1- UnADM ---has an internet--Green Section

Solution:

Layer 1 issue- Serial Connection is not configured properly - PPP connection required

Layer 2 issue- PPP connection w/Clock rate setting i.e. 56000 is required

Layer 3 issue- missing configuration on Rourter 1/ Router 2 on Advertising Internet traffic via Routing Protocol In RIP,

router 1

router rip

network 202.50.50.0 255.255.255.0      <----Internet interface

network 202.50.140.0 255.255.255.0    <----vlan 140

network 202.50.120.0 255.255.255.0    <----vlan 120

network 8.0.0.0 255.0.0.0                      <----WAN Network between R1 and R2

router 2

router rip

network 202.50.100.0 255.255.255.0    <----vlan 100

network 8.0.0.0 255.0.0.0                      <----WAN Network between R1 and R2

 

In Static,

router 1

ip route 202.50.50.0 255.255.255.0 8.0.0.2      <----Internet interface

ip route 202.50.140.0 255.255.255.0 8.0.0.2    <----vlan 140

network 202.50.120.0 255.255.255.0 8.0.0.2   <----vlan 120

router 2

ip route 202.50.100.0 255.255.255.0 8.0.0.1   <----vlan 100

 

In OSPF,

router 1

router ospf 1

router-id 1.1.1.1

network 202.50.50.0 0.0.0.255 area 0      <----Internet interface, should be in same AREA

network 202.50.140.0 0.0.0.255 area 0    <----vlan 140, should be in same AREA

network 202.50.120.0 0.0.0.255 area 0    <----vlan 120, should be in same AREA

network 8.0.0.0 0.255.255.255 area 0      <----WAN Network between R1 and R2, should be in same AREA

router 2

router ospf 1                <---------Process-ID can be same

router-id 2.2.2.2         <-------Router-ID must ne UNIQUE.

network 202.50.100.0 0.0.0.255 area 0    <----vlan 100, should be in same AREA

network 8.0.0.0 0.255.255.255 area 0      <----WAN Network between R1 and R2, should be in same AREA

 

In EIGRP,

router 1

router eigrp 101            <---- Autonomous Number should be same

network 202.50.50.0 0.0.0.255      <----Internet interface

network 202.50.140.0 0.0.0.255    <----vlan 140

network 202.50.120.0 0.0.0.255    <----vlan 120

network 8.0.0.0 0.255.255.255                      <----WAN Network between R1 and R2

router 2

router eigrp 101            <---- Autonomous Number should be same

network 202.50.100.0 0.0.0.255    <----vlan 100

network 8.0.0.0 0.255.255.255      <----WAN Network between R1 and R2

Use No auto-summary if needed if you want to apply classless Protocol on EIGRP else not necessary.

I hope this helps.

DM

Content for Community-Ad