cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16216
Views
8
Helpful
4
Replies
abhigup4
Cisco Employee

configure VM network on a pre-existing network

I am running devstack Juno on vmware ESXi 5.5. I have configured two interfaces on the VM:
eth0: connects to corporate network on 172.19* ip addresses
eth1: connect to switch in lab on a 10.* private network

I have ONE IP allocated to me on 172.* network where I can connect to management network i.e. access devstack horizon dashboard. I have an IP pool(100 ips) on 10.* network where I would like to create all my virtual machines. These IPs should be assigned based on DHCP pool on switch.

I would like to know:
1. what should be the setting in local.conf
2. how to setup my interfaces eth0 and eth1
3. any other bridge or network I need to create to accomplish this topology

Any suggestions or pointers in this regard will be highly helpful.

1 ACCEPTED SOLUTION

Accepted Solutions

I was able to resolve the issue after some troubleshooting and reading. Basically you have to make sure of the following:

1. the interface used for provider network should not have a static IP. in my case eth0 should not have a static ip.

sudo ifconfig eth0 0.0.0.0

sudo ifconfig eth0 promisc

2. create a bridge br-eth0 with static IP

sudo ovs-vsctl add-br br-eth0

sudo ifconfig br-eth0 promisc up

sudo ifconfig br-eth0 10.191.2.20 netmask 255.255.255.0

3. add eth0 to bridge

sudo ovs-vsctl add-port br-eth0 eth0

4. /etc/network/interfaces

auto eth0

iface eth0 inet manual

        up ifconfig $IFACE 0.0.0.0 up

        down ifconfig $IFACE 0.0.0.0 down

auto br-eth0

iface br-eth0 inet static

    address 10.191.2.20

    netmask 255.255.255.0

    bridge_stp off

    bridge_fd 0

4. enable ip forwarding i.e. add to /etc/sysctl.conf

net.ipv4.ip_forward=1

net.ipv4.conf.all.rp_filter=0

net.ipv4.conf.default.rp_filter=0

restart:

sudo sysctl -p

View solution in original post

4 REPLIES 4
roagarwa
Cisco Employee

Hi Abhishek, you may try to run this learning lab that will give you an idea of what's needed

-https://learninglabs.cisco.com/lab/openstack-install/step/1

Another good resource is this page that provides instructions on running all-in-one VM with devstack

-http://docs.openstack.org/developer/devstack/#all-in-one-single-vm

Thanks Rohit for the pointers. From the post-1, suggested to use NAT, I want to avoid using NAT and would like to create virtual machine instances on the VLAN created on switch.

If you could spare some time(15 - 20 mins), I can get on webex and explain in more detail about my setup. May be its something missing in my setup which you can point out quickly. Let me know if sometime works for you tomorrow or day after. Please note that the host on which devstack juno is installed is running on ESXi host on a UCS server.

I was able to resolve the issue after some troubleshooting and reading. Basically you have to make sure of the following:

1. the interface used for provider network should not have a static IP. in my case eth0 should not have a static ip.

sudo ifconfig eth0 0.0.0.0

sudo ifconfig eth0 promisc

2. create a bridge br-eth0 with static IP

sudo ovs-vsctl add-br br-eth0

sudo ifconfig br-eth0 promisc up

sudo ifconfig br-eth0 10.191.2.20 netmask 255.255.255.0

3. add eth0 to bridge

sudo ovs-vsctl add-port br-eth0 eth0

4. /etc/network/interfaces

auto eth0

iface eth0 inet manual

        up ifconfig $IFACE 0.0.0.0 up

        down ifconfig $IFACE 0.0.0.0 down

auto br-eth0

iface br-eth0 inet static

    address 10.191.2.20

    netmask 255.255.255.0

    bridge_stp off

    bridge_fd 0

4. enable ip forwarding i.e. add to /etc/sysctl.conf

net.ipv4.ip_forward=1

net.ipv4.conf.all.rp_filter=0

net.ipv4.conf.default.rp_filter=0

restart:

sudo sysctl -p

View solution in original post

Congrats on finding a solution, and thanks for sharing it.

Content for Community-Ad

This widget could not be displayed.