cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
155
Views
0
Helpful
1
Replies
Highlighted
Beginner

Getting invalid token when using XML API

We have an integration app created.  We are able to authenticate and obtain a valid access token.

Using our custom app, we are able to getUser info for the logged in user.  The logged in user is an organization admin in Webex.  When we attempt to getUser for other users, we get an invalid access token.  

The code worked fine when using basic authentication, however, using SSO, we had to create the integration, and that appears to be working fine because the application will display the logged in users information using the xml API GetUser.

 

Note, we've tried going the AuthenticateUser route and getting a session ticket, but that too resulted in an Invalid Token response.

 

To recap, we are using SSO, have an integration setup.  We are getting authenticated, obtaining our Code, getting our Access Token, and if needed are able to get a session ticket, however we are not able to call any of the XML API's for anyone other than the currently logged in user.

 

Hoping someone can provide some direction while we continue to try and resolve this issue.

1 REPLY 1
Highlighted
Beginner

Ok, we figured this out.  We were passing the wrong webExID in the SecurityContext.  We needed to pass the logged on users ID and we were passing the ID of the user were were attempting to look up.  

Content for Community-Ad

This widget could not be displayed.