cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements


        IMPORTANT! The sandboxes that can be reserved will be undergoing maintenance
from 12:01AM PDT Friday May 21 until 11:59PM Sunday May 23.
During this time, reserved sandboxes will be unavailable.
Always-On sandboxes are not affected and should still be available.
1478
Views
10
Helpful
7
Replies
nileshbhadane123
Beginner

SSH is not working 10.10.20.20 DevBox: CentOS 7 Workstation

When I am trying to do SSH to 10.10.20.20 DevBox: CentOS 7 Workstation, it is not not responding and getting hang. I am following steps from https://learninglabs.cisco.com/lab/nxos_telemetry_part1/step/2.  But this devbox is responding to ping command. Please help me to fix this issue.

1 ACCEPTED SOLUTION

Accepted Solutions
zowu
Cisco Employee

Hi Nilesh,

The Devbox should be 10.10.20.25 other than 10.10.20.20. I've tried a new reservation and the devbox is working here.

Thanks,

Bob

View solution in original post

7 REPLIES 7
zowu
Cisco Employee

Hi Nilesh,

The Devbox should be 10.10.20.25 other than 10.10.20.20. I've tried a new reservation and the devbox is working here.

Thanks,

Bob

View solution in original post

Hi,

I have got the same problem. I am using MacOS X High Sierra and the problem is that i can't ssh to 10.10.20.20 and RDP to 10.10.20.161. I did some troubleshooting and Ping does work with no problems. Also when I am doing telnet to 10.10.20.20 on port 22 then port is open. The problem for me looks like it's locally or because of VPN connection.

Interesting thing is that when I start windows on the same computer via VMware then I can access everything, but I do prefer to learn from my main system which is MacOS X of course.

In Addition there is no device under 10.10.20.25

Could you please help me investigate the problem?

PS: I suppose that all MAC users will have similar problem

Thanks

Adrian

Hi Adrian,

What Sandbox lab are you using?

Joe

Hi Joe,

I am using followind lab: NX-OS with Nexus 9Kv Lab (devnetsandboxlabs.cisco.com/rave36)


In Addition I did debug ssh on my MACBOOK and it stuck in: ssh2_msg_kexinit sent


BR

Adrian

Hi Joe,

Have you dad time to have a look in to this what I wrote?

In addition I have found that there is Packet fragmentation and My question is if may be there is a problem.

Max mtu without fragmentation is 12xx

admin11111
Enthusiast

Hi,

I have solved the issue and I would like to share with you hot to fix it.

When you connect to VPN it also negotiate the MTU and in my case it negotiated 1406 MTU.

When I did ping with DF bit set and with my negotiated MTU. Ping didn't work:

root@xxx:~# ping -s 1406 10.10.20.20

PING 10.10.20.20 (10.10.20.20) 1406(1434) bytes of data.

^C

After that I have changed MTU on tunnel interface:

root@xxx:~#  ifconfig tun0 mtu 1355

I set maximum possible MTU with no fragmentation.

Now I am able to connect to 10.10.20.20 with no problems

I believe such problem will be not only for Mac users but also for linux users. So this solution will be working for linux based users as well.

Hi, this solution worked for me but not with that MTU (1355), for me had to be something under the 12xx range.

Also a quick note for anyone testing this, you should test the ping with the -D flag to avoid fragmentation since Jumbo packets are enabled and you can actually ping all over 8184:

```

daniel$ ping -s 8184 10.10.20.20

PING 10.10.20.20 (10.10.20.20): 8184 data bytes

8192 bytes from 10.10.20.20: icmp_seq=0 ttl=63 time=147.845 ms

8192 bytes from 10.10.20.20: icmp_seq=1 ttl=63 time=147.635 ms

8192 bytes from 10.10.20.20: icmp_seq=2 ttl=63 time=147.429 ms

```

Content for Community-Ad