cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
437
Visitas
0
ÚTIL
6
Respuestas

Etherchannel

danielmanqui
Beginner
Beginner

Hola comunidad, un gran saludos a todos por acá.

Tengo una consulta sobre Etherchannel, cuando ejecuto el comando "show etherchannel x portchannel" deberia mostrarme el Index, Load y N° of Bits, de los enlaces participante en el Etherchannel, pero el Output del comando solo me devuelve 0, 00, 0 respectivamente, a que se deberá esto?, estamos revisando la carga individual de los enlaces en el etherchannel debido a que estamos viendo a través de gráficos de monitoreo que se esta utilizando solo un enlace activos del etherchannel:

Index    Load     Port      EC state                      No of bits
------+------+------+------------------+-----------
0          00         Gi1/0/1 Automatic-NonSl        0
0          00         Gi1/0/2 Automatic-NonSl        0
0          00         Gi1/0/3 Automatic-NonSl        0

método utilizado por defecto "src-mac":

switch C2960X

 

Cualquier ayuda o respuesta sera muy valiosa, saludos

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas

Hola Daniel,

Este tipo de información es esperada en estas plataformas (Cat2K, Cat3k). No verás ninguna información relacionada con el Index, el Load, ni la cantidad de bits en la salida de ese comando. En otros modelos como el 6500 y el 7600, tendrás esta información. La razón puede estar relacionada con la arquitectura interna del equipo.

En cuanto a tu inquietud sobre el balanceo de tráfico a través de los diferentes enlaces del Port-Channel, también es esperado que veas una mayor carga de tráfico en uno de los enlaces del Port-Channel y que no sea equitativa a través de todos los miembros del Port-Channel. Este es el funcionamiento normal que dependerá del hash y del flujo de tráfico, entre otras cosa. Puedes revisar la siguiente liga para mayores detalles

https://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/12023-4.html 

Espero sea util

Saludos

Leonardo

Ver la solución en mensaje original publicado

6 RESPUESTAS 6

luis_cordova
VIP Alumni
VIP Alumni

Hola

¿Podrias compartir la configuracion de las interfaces integrantes de Etherchannel y de la interfaz Portchannel?

Saludos

 

Hola Luis, por supuesto, el Etherchannel esta activo actualmente:

SWITCH-1

interface Port-channel1
switchport trunk allowed vlan 10
switchport mode trunk
spanning-tree portfast trunk
spanning-tree cost 3
!
interface GigabitEthernet1/0/1
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode auto non-silent
!
interface GigabitEthernet1/0/2
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode auto non-silent
!
interface GigabitEthernet1/0/3
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode auto non-silent
!

SWITCH-2
interface Port-channel1
switchport trunk allowed vlan 10
switchport mode trunk
spanning-tree portfast trunk
spanning-tree cost 3
!
interface GigabitEthernet1/0/1
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/0/2
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/0/3
switchport trunk allowed vlan 10
switchport mode trunk
speed 1000
duplex full
channel-protocol pagp
channel-group 1 mode desirable non-silent
!

------
Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Gi1/0/1(P) Gi1/0/2(P) Gi1/0/3(P)

 

hola

Si deseas revisar un etherchannel puedes utilizar: show etherchannel summary

En algunos switches puedes revisar el trafico a traves de:

test etherchannel load-balance interface port-channel

o

show etherchannel XXXX detail

 

Saludos,




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hola Julio, gracias por tu respuesta, te comento que conozco los comandos que mencionas y los he utilizado los 3, pero aun así, no no veo la carga (Load) de los enlaces:

Port: Gi1/0/1
------------

Port state = Up Mstr In-Bndl
Channel group = 1 Mode = Automatic-NonSl Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Gi1/0/1 SAC U6/S7 HQ 30s 1 128 Any 5001

Partner's information:

Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Gi1/0/1 SWITCH-2 94d4.6932.8765 Gi1/0/1 3s SC 10001

Age of the port in the current state: 2d:08h:30m:24s

Port: Gi1/0/2
------------

Port state = Up Mstr In-Bndl
Channel group = 1 Mode = Automatic-NonSl Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Gi1/0/2 SAC U6/S7 HQ 30s 1 128 Any 5001

Partner's information:

Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Gi1/0/2 SWITCH-2 94d4.6932.8765 Gi1/0/2 0s SC 10001

Age of the port in the current state: 2d:07h:22m:09s

Port: Gi1/0/3
------------

Port state = Up Mstr In-Bndl
Channel group = 1 Mode = Automatic-NonSl Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Gi1/0/3 SAC U6/S7 HQ 30s 1 128 Any 5001

Partner's information:

Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Gi1/0/3 SWITCH-2 94d4.6932.8765 Gi1/0/3 25s SC 10001

Age of the port in the current state: 2d:07h:21m:53s

 

Hola Daniel,

Este tipo de información es esperada en estas plataformas (Cat2K, Cat3k). No verás ninguna información relacionada con el Index, el Load, ni la cantidad de bits en la salida de ese comando. En otros modelos como el 6500 y el 7600, tendrás esta información. La razón puede estar relacionada con la arquitectura interna del equipo.

En cuanto a tu inquietud sobre el balanceo de tráfico a través de los diferentes enlaces del Port-Channel, también es esperado que veas una mayor carga de tráfico en uno de los enlaces del Port-Channel y que no sea equitativa a través de todos los miembros del Port-Channel. Este es el funcionamiento normal que dependerá del hash y del flujo de tráfico, entre otras cosa. Puedes revisar la siguiente liga para mayores detalles

https://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/12023-4.html 

Espero sea util

Saludos

Leonardo

Leonardo muchas gracias por tu comentario, me hace mas sentido lo que tu indicas, además que estos equipos son bastante antiguos, con respecto al link que compartes, ya lo había leído, me quedo claro que debo probar con otro modo de balanceo, probare con "dst-macsrc-dst-mac" ya que el etherchannel es Layer 2, también entendí que puede haber distintos métodos en ambos lados del etherchannel dependiendo del flujo de datos, mi flujo de datos es de varios host a varios host en cada extremo del port-channel, veré cual balancea mejor para mi

 

Gracias por la ayuda.

 

Vamos a comenzar

¡Conecte con otros expertos de Cisco y del mundo! Encuentre soluciones a sus problemas técnicos o comerciales, y aprenda compartiendo experiencias.

Queremos que su experiencia sea grata, le compartimos algunos links que le ayudarán a familiarizarse con la Comunidad de Cisco: