cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
cancel
Comunicados
143
Apresentações
0
Útil
3
Respostas

Dificuldades com VLANS e Trunk

Olá, tudo bem?
Estou tendo dificuldades com um laboratório utilizando vlans e trunk, não encontrei nada parecido com o meu problema então optei por vir até aqui.

No meu cenário, existem três switches, dois possuem computadores conectados e o outro faz o papel de switch "core" que também está conectado a um roteador(Gateway da rede).

Configurei as portas entre os switches no modo "Trunk" e as portas entre os computadores no modo "Access"(Estou utilizando as Vlans 10 e 20 para os computadores).

O problema da minha rede é que os computadores não conseguem pingar o gateway, já tentei de tudo mas não consigo achar uma solução cabível para o problema.

Deixarei uma captura de tela do meu laboratório junto com as configurações dos dispositivos.
Agradeço a todos que poderem me ajudar.

Config do Switch 1:

Current configuration : 1192 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 20
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Config do Switch 2:

Current configuration : 1192 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 20
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Config do Switch "Core"

Current configuration : 1272 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Config do roteador:

Current configuration : 423 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.10.254 255.255.255.0
 duplex auto
 speed auto
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Todos os computadores estão na rede 192.168.10.0/24, porém em vlans diferentes.

3 RESPOSTAS 3

Wellington boa noite,

A VLANs  são dominios logicos definidas na rede, segmentando dominios de broadcast, devices na mesma VLAN pode se falar sem a necessidade de um dispostivo de camada 3 (roteador, switch ou firewall)

Qual é o objetivo do seu lab?

Por que existem duas vlans com o mesmo endereçamento de rede?

Dicas:

  • Para fazer a comunicação entre vlans vc precisa de um device L3 para este roteamento.
  • O ideal é que cada vlan tenha sua rede
  • O switch core ou o seu roteador fazerem o roteamento de vlans
  • Sugiro dar uma estudada no conceito de vlans, roteamento entre vlans.

Bom estudos.

 

 

 

 

Regards
Leonardo Santana

*** Rate All Helpful Responses***
mateusanastacio
Beginner

 Wellington Matias,

 

É necessário fazer muita leitura para entender sobre VLAN, cada VLAN é uma sub rede e para que haja comunicação entre elas é necessário a existência de um elemento ou dispositivo da camada 3/L3 (Router). Caso precise de ajuda urgente, por favor entre em contacto pelo WhatsApp: +244928274929

 

Anastácio

Bom dia Wellington, tudo blz !?

 

Cara pelo que estava lendo aqui, se não me engano você deveria usar o "router on stick" para que essa comunicação funcione, sei que está usando tudo a mesma rede com vlans diferentes mas você precisa criar uma sub-interface e identificar a vlan algo como isso aqui:

conf t
! interface física sem config
interface ethernet 0/0
  no ip address
! Criar a sub-interface, definir o IP e informe a VLAN
interface Ethernet 0/0.10
  ip address 192.168.10.X 255.255.255.0
  encapsulation dot1q 10
! Repita o processo para a segunda interface
interface Ethernet 0/0.20
  ip address 192.168.20.X 255.255.255.0
  encapsulation dot1q 20

Lembrando que para cada vlan o ideal é ter um segmento de rede diferente para que você consiga segregar e rotear os acessos da melhor forma. Espero ter ajudado.

 

Se pesquisar na internet vai achar algumas leituras sobre "Router on stick".

 

Att,

Criar
Reconheça Seus Colegas
Content for Community-Ad

 Ask to Expert