cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
221
Views
0
Helpful
4
Replies
Highlighted
Contributor

AXL AddPhone DX 80 failed "Vendor Configuration is not in correct format for the specified product type"

Hi,
I don't know if this is the right place to ask that question.
Two clients encounter an error when adding a DX80 terminal using the AXL on his CUCM 12.5.
The error is "Vendor Configuration is not in correct format for the specified product type".
I didn't manage to reproduce this problem (the creation works) but I don't have exactly the same version.
The CUCM of the clients are a 12.5.1.11900-146 and 12.5.1.12900-150
I have tried on my CUCM (a 12.5.0.99835-6) and on the CUCM of the Cisco Sandbox (12.5.1.10000-22).
Here is the request that failed:

<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
	<S:Body>
		<ns2:addPhone xmlns:ns2="http://www.cisco.com/AXL/API/12.0">
			<phone>
				<name>SEP0000FFFFEEEE</name>
				<description>SEP0000FFFFEEEE</description>
				<product>Cisco Webex DX80</product>
				<class>Phone</class>
				<protocol>SIP</protocol>
				<protocolSide>User</protocolSide>
				<callingSearchSpaceName>CSS_DEVICE</callingSearchSpaceName>
				<devicePoolName>DP_SIT1097</devicePoolName>
				<commonDeviceConfigName/>
				<commonPhoneConfigName>Standard Common Phone Profile</commonPhoneConfigName>
				<locationName>Hub_None</locationName>
				<mediaResourceListName/>
				<automatedAlternateRoutingCssName/>
				<aarNeighborhoodName/>
				<loadInformation/>
				<vendorConfig>
					<disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
					<daysDisplayNotActive>null</daysDisplayNotActive>
					<appInstallFromAndroidMarket>false</appInstallFromAndroidMarket>
					<RoomName/>
					<enableCiscoUcmAppClient>false</enableCiscoUcmAppClient>
					<sshAccess>0</sshAccess>
					<webAccess>2</webAccess>
					<disableSpeaker>false</disableSpeaker>
					<SystemName>jkzla</SystemName>
					<MaxTotalDownstreamRate>3072</MaxTotalDownstreamRate>
					<MaxTotalUpstreamRate>3072</MaxTotalUpstreamRate>
					<AdminLoginDetails>
						<adminUserId>admin</adminUserId>
						<adminPassword>EjM7CMvmxFOqCABk</adminPassword>
					</AdminLoginDetails>
				</vendorConfig>
				<mlppDomainId xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:nil="true"/>
				<useTrustedRelayPoint>Default</useTrustedRelayPoint>
				<securityProfileName>universal.tls.xxx.com</securityProfileName>
				<sipProfileName>Standard SIP Profile For TelePresence XXX</sipProfileName>
				<cgpnTransformationCssName/>
				<useDevicePoolCgpnTransformCss>true</useDevicePoolCgpnTransformCss>
				<lines>
					<line>
						<index>1</index>
						<label>SEP0000FFFFEEEE - 1000000</label>
						<display>SEP0000FFFFEEEE</display>
						<dirn>
							<pattern>1000000</pattern>
							<routePartitionName>P_Intern</routePartitionName>
						</dirn>
						<ringSetting>Use System Default</ringSetting>
						<consecutiveRingSetting>Use System Default</consecutiveRingSetting>
						<ringSettingIdlePickupAlert>Use System Default</ringSettingIdlePickupAlert>
						<ringSettingActivePickupAlert>Use System Default</ringSettingActivePickupAlert>
						<displayAscii>SEP0000FFFFEEEE</displayAscii>
						<e164Mask>1XXXXXX</e164Mask>
						<mwlPolicy>Use System Policy</mwlPolicy>
						<maxNumCalls>4</maxNumCalls>
						<busyTrigger>4</busyTrigger>
						<callInfoDisplay>
							<callerName>true</callerName>
							<callerNumber>false</callerNumber>
							<redirectedNumber>false</redirectedNumber>
							<dialedNumber>true</dialedNumber>
						</callInfoDisplay>
						<recordingProfileName/>
						<monitoringCssName/>
						<recordingFlag>Call Recording Disabled</recordingFlag>
						<partitionUsage>General</partitionUsage>
						<missedCallLogging>false</missedCallLogging>
						<recordingMediaSource>Gateway Preferred</recordingMediaSource>
					</line>
				</lines>
				<phoneTemplateName>Standard Cisco Webex DX80</phoneTemplateName>
				<primaryPhoneName/>
				<addOnModules/>
				<userLocale>English United States</userLocale>
				<networkLocale/>
				<idleTimeout/>
				<authenticationUrl/>
				<directoryUrl/>
				<idleUrl/>
				<informationUrl/>
				<messagesUrl/>
				<proxyServerUrl/>
				<servicesUrl/>
				<services/>
				<softkeyTemplateName/>
				<enableExtensionMobility>false</enableExtensionMobility>
				<builtInBridgeStatus>Default</builtInBridgeStatus>
				<callInfoPrivacyStatus>Default</callInfoPrivacyStatus>
				<subscribeCallingSearchSpaceName>CSS_DEVICE</subscribeCallingSearchSpaceName>
				<rerouteCallingSearchSpaceName/>
				<presenceGroupName>Standard Presence group</presenceGroupName>
				<requireDtmfReception>false</requireDtmfReception>
				<deviceMobilityMode>Default</deviceMobilityMode>
				<dndOption>Ringer Off</dndOption>
				<dndRingSetting/>
				<dndStatus>false</dndStatus>
				<digestUser/>
				<secureInformationUrl/>
				<secureDirectoryUrl/>
				<secureMessageUrl/>
				<secureServicesUrl/>
				<secureAuthenticationUrl/>
				<secureIdleUrl/>
				<AllowPresentationSharingUsingBfcp>true</AllowPresentationSharingUsingBfcp>
				<elinGroup/>
				<enableActivationID>false</enableActivationID>
			</phone>
		</ns2:addPhone>
	</S:Body>
</S:Envelope>

Do you have an explanation for this error?
Best Regards,

FB

4 REPLIES 4
Highlighted
Contributor

Re: AXL AddPhone DX 80 failed "Vendor Configuration is not in correct format for the specified product type"

When I add "<xPrivate.Osd.TodaysBookings>Off</xPrivate.Osd.TodaysBookings>" in the vendor config, the creation of the device works. For me it looks to be a bug. What do you think?

Regards,

FB

Highlighted
Cisco Employee

Re: AXL AddPhone DX 80 failed "Vendor Configuration is not in correct format for the specified product type"

The vendor config data for a particular device could conceivably vary by CUCM version and/or by the version of a COP file (Cisco Option Pack) for an updated Device Pack, Service Update or Engineering Special - though I'm not sure I've heard of any variance as fragile as this one.

The contents of vendor config are not documented and therefore problems/challenges/issues are probably not ultimately Cisco-supportable (from the perspective of being able to open a defect or get a CUCM patch.)

Curious how you discovered that missing field...?  Typically one would configure a device (with the settings you are endeavoring to support), do a <getPhone> to inspect the vendor config data and then go from there.  If that's what you did, and its working on all the target versions, you're on the right track...

Highlighted
Contributor

Re: AXL AddPhone DX 80 failed "Vendor Configuration is not in correct format for the specified product type"

Hi,

Thank you for the answer.

As the clients want to know the origin of the problem (what versions are affected and if there is a correction), I have opened a ticket #3994.

To find out what was wrong with my request I actually made a getPhone on an existing one and then tried to create it with its data. As it worked, I then tried to find out what the differences were that made it work for one of the requests and not for the other.

The vendorConfig is optional in the creation request, so even if the content is not necessarily supported, the fact that the request doesn't work anymore is problematic for me...

Best Regards,

Highlighted
Beginner

Re: AXL AddPhone DX 80 failed "Vendor Configuration is not in correct format for the specified product type"

I ran into strange behavior with Vendor Config a few times.

Mostly what helped me getting it to work was to use a get Response to see the Layout as sometimes the Documentation of AXL does not list all mandatory Fields.

 

Espacially with Vendor Config it is alway a little bit tricky

This widget could not be displayed.