cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

284
Views
0
Helpful
1
Replies
Highlighted

"ATS failed system trust. error - code: -1200"

Good Day Experts,

 

I am trying to integrate my swift based IOS application with a Cisco Unified Communications Manager version 11.5 using standard RISPORT70 API:

 

https://developer.cisco.com/docs/sxml/#!risport70-api-reference/selectcmdevice

 

to get some responses generated off of the API Call.

 

I make the following call:

 

https://<server IP>:8443/realtimeservice2/services/RISService70?wsdl

with its corresponding SOAP envelop in the body but get a ATS failed system trust. error - code: -1200

 

The api call works without SSL Cert Verification on Postman but does not work on the actual app.

 

I have tried:

  1. Got an Internal PKI Signed certificate certificate on the Cisco Server and added the root, intermediate and the server cert on the local keychain.

  2. Tried to update the the info.plist with the following parameter:

    • Allow Arbitrary Loads for Media
    • Allow Arbitrary Loads
    • Allow Arbitrary Loads in web content
    • Added Exception Domains
    • Send a SOAP Enveloped Body.
    • Send this via Xcode to any Cisco Call Manager

Errors:

2019-10-09 16:54:56.336902-0400 APP[3556:172438] ATS failed system trust2019-10-09 16:54:56.337008-0400 APP[3556:172438] Connection 1: system TLS Trust evaluation failed(-9802)
2019-10-09 16:54:56.337125-0400 APP[3556:172438] Connection 1: TLS Trust encountered error 3:-9802
2019-10-09 16:54:56.337202-0400 APP[3556:172438] Connection 1: encountered error(3:-9802)
2019-10-09 16:54:56.340683-0400 APP[3556:172438] Task <2F074FBA-C54B-4972-B269-1B3EE5919344>.<1> HTTP load failed, 0/0 bytes (error code: -1200 [3:-9802])
Optional(Error Domain=NSURLErrorDomain Code=-1200 "An SSL error has occurred and a secure connection to the server cannot be made." UserInfo={NSURLErrorFailingURLPeerTrustErrorKey=<SecTrustRef: 0x60000071a2e0>, NSLocalizedRecoverySuggestion=Would you like to connect to the server anyway?, _kCFStreamErrorDomainKey=3, _kCFStreamErrorCodeKey=-9802, NSErrorPeerCertificateChainKey=(

 Any help here will be much appreciated.

 

Himank Pande

 

#xcode #cisco-axl #swift #cucm #callmanager #certificate

Everyone's tags (5)
1 REPLY 1
Beginner

Re: "ATS failed system trust. error - code: -1200"

Where is your application running?
I would say that the device dos not trust the certificate presented from CUCM.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here