cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

1259
Views
0
Helpful
7
Replies
Ben.Levin
Beginner

ACS 5.4 experiences?

I'm planning to upgrade from ACS 5.3 to 5.4 in a couple of weeks in order to take advantage of the IPv6 support. Is there anyone running 5.4 that can provide any info on 5.4 experiences/issues/caveats, etc?  Thanks!

7 REPLIES 7
jrabinow
Rising star

There are a couple of points that should be taken into consideration before upgrading:

(taken from release notes)

If you have either ACS 5.2 or ACS 5.3 installed on your machine, you can upgrade to ACS 5.4 using one of the following two methods:

Upgrading an ACS Server using the Application Upgrade Bundle

Reimaging and Upgrading an ACS Server

You can only perform an application upgrade bundle, on either a Cisco appliance or a virtual machine, if the disk size is greater than or equal to 500 GB. If you have a smaller disk size, you need to reimage to ACS 5.4 followed by a restore of the backup taken in ACS 5.2 or ACS 5.3 version to trigger the upgrade.

When you upgrade from ACS 5.3 to 5.4, it is mandatory to install ACS 5.3.0.40.8 prior to the upgrade or the upgrade may fail. If you use the version prior to ACS 5.3.0.40.6, then you might hit an error and the upgrade will not proceed. Note that ACS 5.4 does not include all fixes that are included in 5.3.0.40.8. Therefore, if any of these fixes in 5.3.0.40.8 are required in your deployment, then you should install patch 5.4.0.46.1 after you upgrade to ACS 5.4.

Will be interested to hear feedback on the TACACS+ IPv6 support

ds6123
Beginner

Same question here.  Is anyone having any major issues with 5.4 (besides what's in the release notes)?  Starting from scratch, should I load 5.3 and install the latest patch?  Or go to 5.4 with the latest patch?

No, no major issues have been reported yet.

Jatin Katyal


- Do rate helpful posts -

~Jatin

I successfully upgraded my 4 appliances from ACS 5.3 to 5.4 in March.  It was pretty straightward except that you have to shift the log collector around and detach each appliance from the cluster before you upgrade it.  This was a little confusing but essentially you detach the first instance, upgrade it, and then it becomes the primary for the subsequently upgraded instances.  Once you finish the upgrade you can set any of the instances as the primary and also set the log collector.

Some highlights for patches available for ACS 5.4

- Patch 1 provides support for later browser versions; particualrly for firefox (details in release notes)

- Patch 2 provides support for Windows 2012

Thanks everyone!  5.4 with the latest patches applied seems to work.

Hi Ben,

  To further add to the above posts, Here is the release notes that you can refer for ACS 5.4:

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.4/release/notes/acs_54_rn.html

Regards

Minakshi (Do rate the helpful posts )

Content for Community-Ad