cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
169
Views
5
Helpful
2
Replies
Beginner

[PACKET TRACER] OSPF Delete Area and/or Set a New Area (even using "clear ip ospf process")

So I'm not sure if this involves a nuance in Packet Tracer or if there's something I'm doing wrong -- one thing is for certain, though I don't yet totally understand the network command although I will have a question on that later. I want the neighbor relationship/adjacency to FAIL but oftentimes it simply doesn't, and I also want to make sure the deleted network doesn't show up when I run "show ip ospf interface"

I didn't think this question involved needing me to post my topology so I'll try to describe and ask my question without it.

 

So I have a fully OSPF network (1941 Routers):

 

PC1 ------------------- R1 ----------------- R2 ---------------- PC2

(10.0.0.1/24)              (10.0.0.2/24)/                 (20.0.0.2/24)/              (30.0.0.2/24)

                                   (20.0.0.1/24)                  (30.0.0.1/24)

 

Everything is in Area 0 and all are 1941 Routers.

 

The way I set the Routers:

R1:

> router ospf 1

> network 10.0.0.2 0.0.0.255 area 0

> network 20.0.0.1 0.0.0.255 area 0

 

R2:

> router ospf 1

> network 20.0.0.2 0.0.0.255 area 0

> network 30.0.0.1 0.0.0.255 area 0

 

 

On R1 the adjacency successfully forms BUT when i try to make the adjacency Fail, I have a problem 

To make it fail I try:

R1:

> no network 20.0.0.1 0.0.0.255 area 0

> end

> clear ip ospf process

 

 

But when I do this it usually simply reconverges and the adjacency is reestablished and the interface/network still shows as "area 0" when I run "show ip ospf interface".

I say USUALLY because there was once where I did it over and again, exclusively on R1 but used the commands:

R1

> no network 20.0.0.1 0.0.0.255 area 0

> no network 20.0.0.2 0.0.0.255 area 0

> end

> clear ip ospf process

 

And it worked after a while, but I was wondering "Why?" But more importantly why when running the initial commads, those didn't prevent the adjacency or remove the network from the area?

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: [PACKET TRACER] OSPF Delete Area and/or Set a New Area (even using "clear ip ospf process")

Hi @GillverK ,

 

Indeed, the area number is maintained after denying the network and executing the cleaning of the ospf processes.

In order to remove an interface from an associated area you must turn it off and on again.

Try this:

R1:

> no network 20.0.0.1 0.0.0.255 area 0

> end

> clear ip ospf process

> interface x/x

> shutdown

> no shutdown

show ip ospf interface

 

Regards

 

2 REPLIES 2
Advocate

Re: [PACKET TRACER] OSPF Delete Area and/or Set a New Area (even using "clear ip ospf process")

Hi @GillverK ,

 

Indeed, the area number is maintained after denying the network and executing the cleaning of the ospf processes.

In order to remove an interface from an associated area you must turn it off and on again.

Try this:

R1:

> no network 20.0.0.1 0.0.0.255 area 0

> end

> clear ip ospf process

> interface x/x

> shutdown

> no shutdown

show ip ospf interface

 

Regards

 

Beginner

Re: [PACKET TRACER] OSPF Delete Area and/or Set a New Area (even using "clear ip ospf process")

Oh wow. I have to flap that as well. 

I actually thought I only needed to flap when assigning interfaces without a protocol.

 

Thank you so much. i hope something like that isn't applicable to the exam. I would never have gotten it.

Really, thanks a ton!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards