cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
259
Views
1
Helpful
2
Replies

ASA 5505 no internet access from LAN

mytrashon
Level 1
Level 1

Hello

I'm trying to set it up according to the instructions and guides,.
There is a simple network of the form: ISP gateway x.x.x.x - > ISP Router 192.168.1.1(nat) -> ASA Eth0/0 Vlan1 outside 192.168.1.111 -> Eth 0/1-5 Vlan1 LAN 10.0.0.10
I reset ASA to default and start configuring it via the CLI.
I configure both vlans, register IPs, security-level, switchport access vlan, access-list, nat, route. I enable dhcp on the LAN, additionally enable and register access to ASDM and enable icmp. This completes the setup.
After this, the WAN cord is pluged in eth0/0, and I plug the local machine into eth1/1. The problem is the following:
ASA sees the Internet perfectly, everything pings from the console.
The local machine with static config (10.0.0.11, 255.255.255.0, 10.0.0.10) can ping port eth1/1 (10.0.0.10), similarly, ASA can ping the local machine (10.0.0.11). That's all. There is no Internet access, port Eth 0/0 192.168.1.111 does not ping. At the same time, ASDM shows that packets are flowing and nothing is blocked. I ran packet tracer from 10.0.0.11 (local machine) to 8.8.8.8, so it claims that there are no problems anywhere and everything should work.
What am I doing wrong? Please tell me. Thanks!

running conf below:

ASA Version 9.2(4)
!
hostname ciscoasa
enable password xx encrypted
passwd xx encrypted
names
!
interface Ethernet0/0
!
interface Ethernet0/1
switchport access vlan 10
!
interface Ethernet0/2
switchport access vlan 10
!
interface Ethernet0/3
switchport access vlan 10
shutdown
!
interface Ethernet0/4
switchport access vlan 10
!
interface Ethernet0/5
switchport access vlan 10
shutdown
!
interface Ethernet0/6
switchport access vlan 10
shutdown
!
interface Ethernet0/7
switchport access vlan 10
shutdown
!
interface Vlan1
nameif outside
security-level 100
ip address 192.168.1.111 255.255.255.0
!
interface Vlan10
nameif LAN
security-level 100
ip address 10.0.0.10 255.255.255.0
!
ftp mode passive
dns domain-lookup outside
dns server-group DefaultDNS
name-server 8.8.8.8
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network LAN
subnet 10.0.0.0 255.255.255.0
object network inside-net
subnet 10.0.0.0 255.255.255.0
object network OBJ_NAT_LAN
subnet 10.0.0.0 255.255.255.0
object network mapped_public_pool
range 192.168.1.10 192.168.1.100
object network my_internal_lan
subnet 10.0.0.0 255.255.255.0
access-list LAN_access_in extended permit ip any any
access-list outside_access_in extended permit ip any any
access-list global_access extended permit ip any any
access-list natoutacl extended permit ip 10.0.0.0 255.255.255.0 any
pager lines 24
mtu outside 1500
mtu LAN 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (LAN,outside) source static any any no-proxy-arp route-lookup
nat (outside,LAN) source static any any no-proxy-arp route-lookup
!
object network my_internal_lan
nat (LAN,outside) dynamic interface
access-group outside_access_in in interface outside
access-group LAN_access_in in interface LAN
access-group global_access global
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
dhcpd dns 8.8.8.8 interface LAN
dhcpd auto_config outside interface LAN
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username hq-admin password xx encrypted
!
!
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:2d72d6dbd853c1b0d2fe4fa7b45bf863
: end

1 Accepted Solution

Accepted Solutions

nat (LAN,outside) source static any any no-proxy-arp route-lookup
nat (outside,LAN) source static any any no-proxy-arp route-lookup

Remove above NAT 

Change secuirty level to be 0 for outside 

View solution in original post

2 Replies 2

@mytrashon change the security level of your outside interface to 0, not 100.

interface Vlan1
 nameif outside
 security-level 0

nat (LAN,outside) source static any any no-proxy-arp route-lookup
nat (outside,LAN) source static any any no-proxy-arp route-lookup

Remove above NAT 

Change secuirty level to be 0 for outside 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card