cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1417
Views
0
Helpful
10
Replies
Highlighted
Beginner

ASDM Access from a different sub-interface/vlan

I did a quick Google search but couldn't really find anything with the terms I searched for, but maybe someone here knows how. Is there any way to access the ASDM from a different subinterface/vlan?

 

For example my ASA is connected internally to an L3 Cisco 3650 switch with 5 VLANS configured on the switch and ASA. I will have all my PC devices on VLAN10 with 10.10.1.x IP addresses, but the ASA wouldn't allow me to use that address for the Management1/1 as it is assigned to the GigabigEthernet1/2.10 subinterface for VLAN10. So I gave the Management1/1 interface and SFR a 10.5.1.x IP address, but then I can't access ASDM from any of my PCs on VLAN10.

 

Is there a solution to fix this problem?

 

My complete ASA config is below.

 

: Saved

:
: Serial Number: 
: Hardware:   ASA5506, 4096 MB RAM, CPU Atom C2000 series 1250 MHz, 1 CPU (4 cores)
:
ASA Version 9.9(1)3
!
hostname HOME-FW1
domain-name home.internal
enable password 
names

!
interface GigabitEthernet1/1
 description WAN
 nameif outside
 security-level 0
 ip address 10.55.1.2 255.255.255.0
!
interface GigabitEthernet1/2
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/2.10
 description "Main VLAN"
 vlan 10
 nameif MAIN
 security-level 100
 ip address 10.10.1.1 255.255.255.0
!
interface GigabitEthernet1/2.20
 description "Media/Streaming VLAN"
 vlan 20
 nameif MEDIA
 security-level 95
 ip address 10.20.1.1 255.255.255.0
!
interface GigabitEthernet1/2.30
 description "WiFi Guest Network"
 vlan 30
 nameif GUEST
 security-level 80
 ip address 192.168.5.1 255.255.255.0
!
interface GigabitEthernet1/2.40
 description "Cameras and NVR"
 vlan 40
 nameif CAMERAS
 security-level 85
 ip address 10.40.1.1 255.255.255.0
!
interface GigabitEthernet1/2.50
 vlan 50
 nameif SECURITY
 security-level 90
 ip address 10.50.1.1 255.255.255.0
!
interface GigabitEthernet1/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/8
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management1/1
 management-only
 nameif management
 security-level 100
 ip address 10.5.1.1 255.255.255.0
!
ftp mode passive
clock timezone GMT -6
dns server-group DefaultDNS
 domain-name home.internal
object network MAIN-PAT
 subnet 10.10.1.0 255.255.255.0
object network MEDIA-PAT
 subnet 10.20.1.0 255.255.255.0
object network GUEST-PAT
 subnet 192.168.5.0 255.255.255.0
object network CAMERAS-PAT
 subnet 10.40.1.0 255.255.255.0
object network SECURITY-PAT
 subnet 10.50.1.0 255.255.255.0
access-list sfr_redirect extended permit ip any any
pager lines 24
mtu management 1500
mtu outside 1500
mtu MAIN 1500
mtu MEDIA 1500
mtu GUEST 1500
mtu CAMERAS 1500
mtu SECURITY 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
!
object network MAIN-PAT
 nat (MAIN,outside) dynamic interface
object network MEDIA-PAT
 nat (MEDIA,outside) dynamic interface
object network GUEST-PAT
 nat (GUEST,outside) dynamic interface
object network CAMERAS-PAT
 nat (CAMERAS,outside) dynamic interface
object network SECURITY-PAT
 nat (SECURITY,outside) dynamic interface
route outside 0.0.0.0 0.0.0.0 10.55.1.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
aaa authentication login-history
http server enable
http 10.10.1.25 255.255.255.255 MAIN
no snmp-server location
no snmp-server contact
no service password-recovery
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh 10.10.1.25 255.255.255.255 MAIN
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 5

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 132.163.96.1
ntp server 132.163.96.2
ntp server 129.6.15.29
ntp server 129.6.15.28 prefer
ssl cipher default low
ssl cipher tlsv1 low
ssl cipher tlsv1.1 low
ssl cipher tlsv1.2 low
ssl cipher dtlsv1 low
dynamic-access-policy-record DfltAccessPolicy
username  password  privilege 15
!
class-map sfr
 match access-list sfr_redirect
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
  no tcp-inspection
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
 class sfr
  sfr fail-open
policy-map type inspect dns migrated_dns_map_2
 parameters
  message-length maximum client auto
  message-length maximum 512
  no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:2f3927d85027fa3394dc3571043a766f
: end
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

So after taking a break for a while from this, I finally fixed it using some previous post from you (Marvin) and this PeteNetLive website which has alot of good information on configuring ASAs. https://www.petenetlive.com/KB/Article/0001173

 

I ended up removing the ip address, nameif and security level from y ASA's management interface. I then went back into the Firepower setup using 

session sfr

command and changed its IP address to one that is on my VLAN10 such as 10.10.1.3/24. I think took an Ethernet cable plugged it into the Management port on the ASA and connected the other end to one of my 3650 switch ports. I assigned this switch port as an access port on VLAN10. Once this was complete I had no problems accessing the ASA or Firepower through the ASDM application.

View solution in original post

10 REPLIES 10
Highlighted
Hall of Fame Guru

You can either allow ASDM access via the VLAN 10 subinterface directly or else add a management-only route to that subnet from the management interface.

 

By default an ASA only has a single routing table. So your traffic from VLAN 10 may reach the management interface but then the ASA will try to reply out the VLAN 10 subinterface and the tcp 3-way handshake will never complete successfully.

Highlighted

And how would I do either of those?

Highlighted

1. http <subnet> <mask> <nameif>

2. route management 0.0.0.0 0.0.0.0 <gateway>

 

(Assuming the nameif for your Management interfaces is "management".)

 

More info:

 

https://www.cisco.com/c/en/us/td/docs/security/asa/asa95/configuration/general/asa-95-general-config/route-overview.html#concept_40C0C8DE2C1247319250B9F7706C54A5

Highlighted

Actually I tried this and when I do the routing, what should the gateway be? The address of the management interface and the address of the VLAN return the same error message.

 

ERROR: Invalid next hop address 10.10.1.1, it matches our IP address.

So I tried changing the management interface to ip address 10.5.1.5/24 and then adding

route management 0.0.0.0 0.0.0.0 10.5.1.1

That was accepted, but I still can't access ASDM on 10.5.1.5 from my laptop on VLAN 10 (10.10.1.25). 

Highlighted

Looks like a routing issue still.

 

Does your laptop's gateway know how to reach the 10.5.1.0/24 subnet?

Highlighted

Not that I can tell. When I do show route on the ASA I get:

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, V - VPN
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is 10.55.1.1 to network 0.0.0.0

S*       0.0.0.0 0.0.0.0 [1/0] via 10.55.1.1, outside
C        10.10.1.0 255.255.255.0 is directly connected, MAIN
L        10.10.1.1 255.255.255.255 is directly connected, MAIN
C        10.20.1.0 255.255.255.0 is directly connected, MEDIA
L        10.20.1.1 255.255.255.255 is directly connected, MEDIA
C        10.40.1.0 255.255.255.0 is directly connected, CAMERAS
L        10.40.1.1 255.255.255.255 is directly connected, CAMERAS
C        10.50.1.0 255.255.255.0 is directly connected, SECURITY
L        10.50.1.1 255.255.255.255 is directly connected, SECURITY
C        10.55.1.0 255.255.255.0 is directly connected, outside
L        10.55.1.2 255.255.255.255 is directly connected, outside
C        192.168.5.0 255.255.255.0 is directly connected, GUEST
L        192.168.5.1 255.255.255.255 is directly connected, GUEST

When I do show route management I get:

Routing Table: mgmt-only
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, V - VPN
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set

Even though it shows in the running config this:

route management 0.0.0.0 0.0.0.0 10.5.1.1 1
Highlighted

So after taking a break for a while from this, I finally fixed it using some previous post from you (Marvin) and this PeteNetLive website which has alot of good information on configuring ASAs. https://www.petenetlive.com/KB/Article/0001173

 

I ended up removing the ip address, nameif and security level from y ASA's management interface. I then went back into the Firepower setup using 

session sfr

command and changed its IP address to one that is on my VLAN10 such as 10.10.1.3/24. I think took an Ethernet cable plugged it into the Management port on the ASA and connected the other end to one of my 3650 switch ports. I assigned this switch port as an access port on VLAN10. Once this was complete I had no problems accessing the ASA or Firepower through the ASDM application.

View solution in original post

Highlighted
Beginner

You may configure a manage vlan on you L3 Switch and connect one access port to your Fw.

Highlighted

Hi Jose,

  In that case, would I create a VLAN 5 for example on the switch then make a sub interface on the ASA as GigabitEthernet1/3.5? Would I need to do any routing on the ASA?

Highlighted

Mmm sorry,  I didn't think on traffic inspection.

Content for Community-Ad