11-16-2010 01:34 AM - edited 03-11-2019 12:10 PM
hello all,
I am attching my configuration. i configured citrix yesterday. it was working fine but today its not working.
can anyone help?
ASA Version 8.0(3)
!
hostname rama5510
enable password 2ry13OhtG57zeqsA encrypted
names
name 192.168.0.107 server
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 121.242.223.102 255.255.255.252
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet0/2
nameif vpn
security-level 50
ip address 10.1.89.82 255.255.255.252
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
no ip address
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
regex domainlist1 "\.yahoo\.com"
regex domainlist2 "\.google\.co\.in"
regex domainlist3 "\.orkut\.com"
regex domainlist4 "\.orkut\.co\.in"
regex domainlist5 "\.facebook\.com"
regex domainlist6 "\.gmail\.com"
regex domainlist7 "\.google\.com"
regex domainlist8 "\mahabhulekh\.mumbai\.nic\.in"
regex applicationheader "application/.*"
regex contenttype "content-type"
regex allow "\.google.\com"
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 121.242.190.180
name-server 121.242.190.211
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group network allow
network-object host 192.168.0.124
network-object host 192.168.0.14
network-object host 192.168.0.77
access-list vpn_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_access_in extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_access_in extended permit ip 192.168.0.0 255.255.255.0 any
access-list outside_access_in extended permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq citrix-ica
access-list outside_access_in extended permit tcp any interface outside eq 2598
access-list user-acl extended deny tcp object-group allow any eq 8080
access-list user-acl extended deny tcp object-group allow any eq www
access-list user-acl extended deny tcp any host 164.100.111.5 eq 8080
access-list user-acl extended deny tcp any host 164.100.111.5 eq www
access-list user-acl extended permit tcp any any eq 8080
access-list user-acl extended permit tcp any any eq www
access-list Outside_access_in extended permit tcp any host 121.242.223.102 eq www
access-list Outside_access_in extended permit tcp any host 121.242.223.102 eq citrix-ica
access-list Outside_access_in extended permit tcp any host 121.242.223.102 eq 2598
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu vpn 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) interface server netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 121.242.223.101 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no sysopt connection permit-vpn
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map vpn_map 1 match address vpn_1_cryptomap
crypto map vpn_map 1 set pfs
crypto map vpn_map 1 set peer 10.1.89.78
crypto map vpn_map 1 set transform-set ESP-3DES-SHA
crypto map vpn_map interface vpn
crypto isakmp enable vpn
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
username rama5510 password NQ35L.CrXDGEh3Wo encrypted privilege 15
tunnel-group 10.1.89.78 type ipsec-l2l
tunnel-group 10.1.89.78 ipsec-attributes
pre-shared-key *
!
class-map allow-user-class
match access-list user-acl
class-map type regex match-any domainblocklist
match regex domainlist1
match regex domainlist2
match regex domainlist3
match regex domainlist5
match regex domainlist4
match regex domainlist6
class-map type inspect http match-all blockdomainclass
match request header host regex class domainblocklist
class-map type inspect http match-all appheaderclass
match request header regex contenttype regex applicationheader
match req-resp content-type mismatch
class-map inspection_default
match default-inspection-traffic
class-map type inspect http match-all allow-url-class
match not request header host regex domainlist2
match not request header host regex domainlist7
match not request header host regex domainlist8
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map type inspect http http_inspection_policy
parameters
protocol-violation action drop-connection
match request method connect
drop-connection log
class appheaderclass
drop-connection log
class blockdomainclass
reset log
policy-map type inspect http allow-url-policy
parameters
class allow-url-class
drop-connection
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
policy-map allow-user-url-policy
class allow-user-class
inspect http allow-url-policy
!
service-policy global_policy global
service-policy allow-user-url-policy interface inside
prompt hostname context
Cryptochecksum:43ef278ec0a84fdb884d085562838469
: end
11-16-2010 03:07 AM
Hello,
Can anyone help me in this case???
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide