cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7978
Views
80
Helpful
10
Replies

FMC 6.7 and vmware tools problem

bodnar.p
Level 1
Level 1

hello 

After upgradit fmc 6.3 to 6.7, cannot start vmware tools. On system/configuration/VMware tools, after trying enable VMware tools, i got Error - Failed to enable VMware Tools. ESXi is supported version 6.7

so i tried to log-in into cli, and when trying to get tools status i got those errors:

root@vmfmc:/etc/vmware-tools/init# ./vmware-tools-services
./vmware-tools-services: line 17: /usr/lib/vmware-tools/moduleScripts/services/vmware-db.pl: No such file or directory
./vmware-tools-services: line 40: /usr/lib/vmware-tools/moduleScripts/services/vmware-db.pl: No such file or directory
./vmware-tools-services: line 41: /usr/lib/vmware-tools/moduleScripts/services/vmware-db.pl: No such file or directory
Usage: vmware-tools-services {start|stop|status|restart|force-reload}

so i checked /usr/lib (and just to be sure also /usr/lib64) and can't find directory vmware-tools

 

any ideas?

so i checked 

1 Accepted Solution

Accepted Solutions

cmonterr
Cisco Employee
Cisco Employee

Hello,

 

Please open a TAC case so an engineer can help you with the following workaround:

 

== Workaround to resolve vmware tools issue:

 

1. From expert, elevate to root user with sudo su and enter your password

root@firepower:/# updatedb
root@firepower:/# locate vmware | grep -vw sf


2. This will help you determine if VMWare has been previously installed. If it was installed you will see one or more of the following:

/usr/lib/vmware-tools
/etc/vmware-tools
/etc/init/vmware-tools.conf
/etc/ld.so.conf.d/vmware-tools-libraries.conf
/etc/modprobe.d/vmware-tools.conf
/etc/selinux/targeted/modules/active/modules/vmware.pp
/etc/dracut.conf.d/vmware-tools.conf
/usr/bin/vmware-*
/usr/sbin/vmware-*
/usr/share/doc/vmware-*


3. Verify if VMWare tools are currently installed:

root@firepower:/# rpm -qa --last | grep vmware | awk '{print $1}' | xargs rpm -e


4. Next, run the following:

root@firepower:/# rm -rf /usr/lib/vmware-tools
root@firepower:/# rm -rf /etc/vmware-tools


5. And run the previous command again to see if the files are still there:

root@firepower:/# updatedb
root@firepower:/# locate vmware | grep -vw sf


6. Finally, try to re-enable VMWare tools

View solution in original post

10 Replies 10

cmonterr
Cisco Employee
Cisco Employee

Hello,

 

Please open a TAC case so an engineer can help you with the following workaround:

 

== Workaround to resolve vmware tools issue:

 

1. From expert, elevate to root user with sudo su and enter your password

root@firepower:/# updatedb
root@firepower:/# locate vmware | grep -vw sf


2. This will help you determine if VMWare has been previously installed. If it was installed you will see one or more of the following:

/usr/lib/vmware-tools
/etc/vmware-tools
/etc/init/vmware-tools.conf
/etc/ld.so.conf.d/vmware-tools-libraries.conf
/etc/modprobe.d/vmware-tools.conf
/etc/selinux/targeted/modules/active/modules/vmware.pp
/etc/dracut.conf.d/vmware-tools.conf
/usr/bin/vmware-*
/usr/sbin/vmware-*
/usr/share/doc/vmware-*


3. Verify if VMWare tools are currently installed:

root@firepower:/# rpm -qa --last | grep vmware | awk '{print $1}' | xargs rpm -e


4. Next, run the following:

root@firepower:/# rm -rf /usr/lib/vmware-tools
root@firepower:/# rm -rf /etc/vmware-tools


5. And run the previous command again to see if the files are still there:

root@firepower:/# updatedb
root@firepower:/# locate vmware | grep -vw sf


6. Finally, try to re-enable VMWare tools

This worked for me also.

This just worked for me in 6.7.0.2. Re-enable VMware Tools in the FMC by going to System>Configuration>VMware Tools.

worked for me also

but the locate seems not working anymore

this command:  rpm -qa --last | grep vmware | awk '{print $1}' | xargs rpm -e
was giving me this: rpm: no packages given for erase

so assume was not installed

run these

rm -rf /usr/lib/vmware-tools
 rm -rf /etc/vmware-tools 

 

then updatedb

and was able to enable the tools from the configuration page

This just worked for me as well under 7.0.1 the /usr/lib/vmware-tools directory did not exist on my system and the locate returned this error locate: Old-format locate database '/var/locatedb' is too short to be valid. 

However I was able to enable vmwater-tools now.

 

 

 

Everything else besides these:

rm -rf /usr/lib/vmware-tools
rm -rf /etc/vmware-tools

is just for verification and not strictly required.

 

Can confirm this works as a workaround for 7.0.1

This worked for me with 7.0.1 as well.

Hi

 

that works for me

Thx

Yordan

srayancha
Level 1
Level 1

These steps worked perfectly for me.

bodnar.p
Level 1
Level 1

Can confirm, it is working

thanks for help

Review Cisco Networking for a $25 gift card