cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1004
Views
0
Helpful
5
Replies
Highlighted
Frequent Contributor

SSH timeout not available while on ssh connection

Hi Everyone,

I found that ssh timeout command is  only available when you console to ASA.

It is not available when you do the ssh connection to ASA is this default behaviour? or any reason behind it?

Thanks

Mahesh

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

SSH timeout not available while on ssh connection

when you say it's not available, what do you mean? Do you mean that it is NOT actually timing out after the configured timeout?

What do you configure the SSH timeout to be?

Pls kindly be advised that it is actually IDLE timeout, so you can't do any activities for that configured timeout, as it is IDLE. And once it hits the minutes configured on the idle timeout, the SSH connection will be disconnected. When you try to do something again afterwards, it will reconnect and prompt you for username and password.

View solution in original post

5 REPLIES 5
Highlighted
Cisco Employee

SSH timeout not available while on ssh connection

Yes, there is command to configure the idle timeout for SSH connection to the ASA:

ssh timeout

Here is the command for your reference:

http://www.cisco.com/en/US/docs/security/asa/asa83/command/reference/s8.html#wp1561729

Hope that helps.

Highlighted
Frequent Contributor

SSH timeout not available while on ssh connection

Hi Jennifer,

That command i know but my question was this that

ssh timeout is not available when i access the ASA  through ssh connection.

Need to know if this is by design?

Thanks

Mahesh

Highlighted
Cisco Employee

SSH timeout not available while on ssh connection

when you say it's not available, what do you mean? Do you mean that it is NOT actually timing out after the configured timeout?

What do you configure the SSH timeout to be?

Pls kindly be advised that it is actually IDLE timeout, so you can't do any activities for that configured timeout, as it is IDLE. And once it hits the minutes configured on the idle timeout, the SSH connection will be disconnected. When you try to do something again afterwards, it will reconnect and prompt you for username and password.

View solution in original post

Highlighted
Frequent Contributor

SSH timeout not available while on ssh connection

Hi Jennifer,

My bad actually i overlooked the command.

it does have  option

ciscoasa(config)# ssh                         ?

configure mode commands/options:

  Hostname or A.B.C.D  The IP address of the host and/or network authorized to

                       login to the system

  X:X:X:X::X/<0-128>   IPv6 address/prefix authorized to login to the system

  scopy                Secure Copy mode

  timeout              Configure ssh idle timeout ?????????????

  version              Specify protocol version to be supported

exec mode commands/options:

  disconnect  Specify SSH session id to be disconnected after this keyword

Thanks for help.

MAhesh

Highlighted
Cisco Employee

SSH timeout not available while on ssh connection

Not a problem. Glad that it's just an overlooked