cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

128
Views
15
Helpful
2
Replies
Highlighted
Beginner

Static Nat issue unable to resolved tried everything.

Hi

i have a cisco asa 5515 with asa ver 9.4.1 and asdm 7.4

i have issue with static nat configuration as i have a server inside which ip is 172.16.1.85 and

my outside interface has configured with a static ip. 

internet is working fine but unable to configure static nat ...

here is my running config please check and let me know what i am missing.. 

 

thanks 

 

ASA Version 9.4(1)
!
hostname ciscoasa

names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 151.253.97.182 255.255.255.248
!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 ip address 172.16.1.1 255.255.255.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
boot system disk0:/asa941-smp-k8.bin
ftp mode passive
object service remote-desktop
 service tcp source eq 3389 destination eq 3389
 description remote desktop
object network RDP_SERVER
 host 172.16.1.85
access-list outside_access_in extended permit object remote-desktop any4 object RDP_SERVER
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-743.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network RDP_SERVER
 nat (inside,outside) static interface service tcp 3389 3389
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 151.253.97.177 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
http server enable
http server idle-timeout 50
http 192.168.1.0 255.255.255.0 management

telnet 192.168.1.0 255.255.255.0 management
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.1.0 255.255.255.0 management
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
vpdn username bricks12 password ***** store-local
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username imran password guVrfhrJftPA/rQZ encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous

ciscoasa#

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Cisco Employee

Hi,Change this ACL:-access

Hi,

Change this ACL:-

access-list outside_access_in extended permit object remote-desktop any4 object RDP_SERVER

to

access-list outside_access_in extended permit tcp any4 object RDP_SERVER eq 3389

Thanks and Regards,

Vibhor Amrodia

View solution in original post

Highlighted
VIP Advisor

The problem with this is the

The problem with this is the object group you are referencing in the ACL

object service remote-desktop
 service tcp source eq 3389 destination eq 3389

you are defining both source and destination as 3389.  The source will almost always be a random high port so your object group should be changed to the following:

object service remote-desktop
 service tcp destination eq 3389

That should sort out your issue.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

View solution in original post

2 REPLIES 2
Highlighted
Cisco Employee

Hi,Change this ACL:-access

Hi,

Change this ACL:-

access-list outside_access_in extended permit object remote-desktop any4 object RDP_SERVER

to

access-list outside_access_in extended permit tcp any4 object RDP_SERVER eq 3389

Thanks and Regards,

Vibhor Amrodia

View solution in original post

Highlighted
VIP Advisor

The problem with this is the

The problem with this is the object group you are referencing in the ACL

object service remote-desktop
 service tcp source eq 3389 destination eq 3389

you are defining both source and destination as 3389.  The source will almost always be a random high port so your object group should be changed to the following:

object service remote-desktop
 service tcp destination eq 3389

That should sort out your issue.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

View solution in original post