cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
952
Views
0
Helpful
5
Replies

Sub Interface on ASA 5505

milan_ver
Beginner
Beginner

Hi,

I want to creat sub int on ASA 5505

but when I am trying below command it show error.

------------------------------------

config t

int f0/0.3400

------------------------------------

My ASA software version is 8.2(5).

Please share the command for configuring the sub int.

Regards,

Milan Verma

5 Replies 5

Jouni Forss
Mentor
Mentor

Hi,

Subinterfaces are used in ASA models 5510 and forward and then they are associated with a Vlan

In ASA 5505 you configure addiotional Vlan interface directly and attach the Vlans either to Trunk interfaces or Access ports on the ASA5505

- Jouni

please share the commands for it...

For example

Interface Vlan2

nameif outside

security-level 0

ip add 1.2.3.4 255.255.255.0

interface Vlan1

nameif inside

security-level 100

ip add 10.10.10.1 255.255.255.0

interface Ethernet0

switchport mode access

switchport access vlan 2

interface Ethernet0/1

switchport mode access

switchport access vlan 1

Some of the above interface commands are enabled by default with the actual command (= Ports in access mode and if no vlan specified it belongs to Vlan1)

- Jouni

but i want to give encepsulation

Hi,

Then you need to configure "switchport mode trunk" under an physical interface and allow the allowed Vlan

Provided your ASA 5505 license supports trunkin.

interface Ethernet0/0

switchport mode trunk

switchport trunk allowed vlan x,y,z

If you dont configure the "allowed vlan" line every Vlan will be allowed through the Trunk port.

- Jouni

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers