Showing results for 
Search instead for 
Did you mean: 

Frequent Contributor

using microsoft exchange with ssl vpn

i need to use microsoft exchange mails(not OWA) & also mircosoft office communicator via our ssl vpn setup.

When i try to connect to MS Exchange from vpn the main opening instance of exchange outlook just hangs in there & OC cant connect.

Any help towards enabling this will be appreciated.


Cisco Employee

Are you using Clientless SSLVPN or AnyConnect (SVC)? Also, are you using a router or ASA as the WebVPN server?

Frequent Contributor

We use both SVC & WebVPN on an ASA 5520 with ver 8.0.

I have tried making exchange/OC work with both clientless or svc, but doesnt seem to be happening.

Appreciate your assistance!

As for exchange, I am assuming you're using outlook, in which case you would be using the SVC (AnyConnect) client. What error message do you get?

If you are using clientless then you are most likely using OWA, which should work as well - what is the problem you are experiencing - do you get the auth prompt? Does it get past a certain point and then fail?

Frequent Contributor

Thats correct, am using Microsoft Outlook.

if i try to open Outlook after connecting to SVC, it doesnt open up & hangs in there with opening template.& i have to terminate it.& when on SVC, my Microsoft OC also gets disconnected.

If i connect to SVC after having the outlook completely opened & then try to send/receive an email, error says"The connection to MS Outlook is not available,Outlook must be connected/online to complete this action"

Is there any restriction that MS Outlook can only be used with SVC & not with Clientless.


Well clientless will only allow OWA to work, as it is only the browser that is connected - you can't use any applications with it unless you use smart tunnels.

As for SVC, please read the following article and make the changes to the registry and see if it works:

See if that also fixes the OC. If not, then on the ASA, please remove SIP inspection under the policy-map global_policy.

PS. please rate this post.

Frequent Contributor

Thanks for your response. I will check these out.

Any suggestions on how to enable smart tunnels to use certain applications like sharedrive & other websites via clientless.

Btw, is there any way to capture the packets moving thru VPN. i tried this but it only captures based on the main vpn ip rather than individual sessions.


Frequent Contributor

i tried removing from policy map but OC still doesnt comeup.

Any other things i need to check for this.



Is your DNS setup correctly?

For example on the VPN setup, do u have your group pointing to your internal DNS servers?

Frequent Contributor

Thanks everyone for the help.i got resolved, turned out to be a route issue of an intermediate device which was not being managed by us.

Appreciate all of your help!