cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

DHCP client fails to install def route on VRF interface

1541
Views
0
Helpful
0
Comments

I have a 3560-48PS doing layer 3 switching and have a single VRF configured on it.  The VRF contains two SVI's - one is configured with a static IP address and the other is configured to obtain its IP address via dhcp.  The dhcp address is obtained, but the default route does not show up in the global or the VRF forwarding tables.  I'm looking for a little insight on whether I'm missing something or if this is due to a bug.

I've dropped in configuration and version information below.  Any help is greatly appreciated.

dsl-test(config-if)#no shut

dsl-test(config-if)#

3d01h: DHCP: DHCP client process started: 10

3d01h: RAC: Starting DHCP discover on Vlan30

3d01h: DHCP: Try 1 to acquire address for Vlan30

3d01h: DHCP: allocate request

3d01h: DHCP: Lease server or giaddr changed. Removing lease entry for : 192.168.1.1 (10)

3d01h: DHCP: deleting entry 5714690 192.168.1.1 from list

3d01h: DHCP: new entry. add to queue

3d01h: DHCP: SDiscover attempt # 1 for entry:

3d01h: DHCP: SDiscover: sending 296 byte length DHCP packet

3d01h: DHCP: SDiscover 296 bytes

3d01h:             B'cast on Vlan30 interface from 0.0.0.0

3d01h: DHCP: Received a BOOTREP pkt

3d01h: DHCP: offer received from 192.168.1.109

3d01h: DHCP: SRequest attempt # 1 for entry:

3d01h: DHCP: SRequest- Server ID option: 192.168.1.109

3d01h: DHCP: SRequest- Requested IP addr option: 192.168.1.1

3d01h: DHCP: SRequest placed lease len option: 600

3d01h: DHCP: SRequest: 314 bytes

3d01h: DHCP: SRequest: 314 bytes

3d01h:             B'cast on Vlan30 interface from 0.0.0.0

3d01h: DHCP: Received a BOOTREP pkt

*Mar  3 20:27:00 EST: %LINK-3-UPDOWN: Interface Vlan30, changed state to up

*Mar  3 20:27:00 EST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

3d01h: DHCP Client Pooling: ***Allocated IP address: 192.168.1.1

3d01h: Allocated IP address = 192.168.1.1  255.255.255.0

*Mar  3 20:27:01 EST: %DHCP-6-ADDRESS_ASSIGN: Interface Vlan30 assigned DHCP address 192.168.1.1, mask 255.255.255.0, hostname dsl-test

^Z

dsl-test#sh ip rou

*Mar  3 20:27:06 EST: %SYS-5-CONFIG_I: Configured from console by cjaffree on vty0 (10.2.36.124)te vrf dsl

Routing Table: dsl

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.31.0.0/24 is subnetted, 1 subnets

C       172.31.255.0 is directly connected, Vlan1050

C    192.168.1.0/24 is directly connected, Vlan30

dsl-test#sh int vlan30

Vlan30 is up, line protocol is up

  Hardware is EtherSVI, address is 0013.c304.f9c1 (bia 0013.c304.f9c1)

  Internet address is 192.168.1.1/24

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:29, output 00:00:26, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     151078 packets input, 9136117 bytes, 0 no buffer

     Received 0 broadcasts (9 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     6396 packets output, 2141012 bytes, 0 underruns

     0 output errors, 8 interface resets

     0 output buffer failures, 0 output buffers swapped out

dsl-test#

dsl-test#

dsl-test#

dsl-test#

dsl-test#

dsl-test#

dsl-test#

dsl-test#sh dhcp

dsl-test#sh dhcp ?

  lease   Show DHCP Addresses leased from a server

  server  Show DHCP Servers we know about

dsl-test#sh dhcp le

dsl-test#sh dhcp lease ?

  interface  Show DHCP information on one interface

  |          Output modifiers

  <cr>

dsl-test#sh dhcp lease

Temp IP addr: 192.168.1.1  for peer on Interface: Vlan30

Temp  sub net mask: 255.255.255.0

   DHCP Lease server: 192.168.1.109, state: 5 Bound

   DHCP transaction id: 1390

   Lease: 600 secs,  Renewal: 300 secs,  Rebind: 525 secs

Temp default-gateway addr: 192.168.1.254

   Next timer fires after: 00:04:20

   Retry count: 0   Client-ID: cisco-0013.c304.f9c1-Vl30

   Client-ID hex dump: 636973636F2D303031332E633330342E

                       663963312D566C3330

   Hostname: dsl-test

dsl-test#sh run

Building configuration...

Current configuration : 5241 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname dsl-test

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxx

!

username ts privilege 7 password 7 xxxxxxxxxx

!

!

aaa new-model

!

!

aaa authentication login default local group tacacs+

aaa authorization exec default local group tacacs+

!

!

!

aaa session-id common

clock timezone EST -5

clock summer-time EDT recurring

system mtu routing 1500

vtp domain dsl-test

vtp mode transparent

no ip subnet-zero

ip routing

ip domain-name usa.ts.com

ip dhcp excluded-address 172.31.255.1

!

ip dhcp pool dsl

   vrf dsl

   network 172.31.255.0 255.255.255.0

   subnet prefix-length 24

   dns-server 10.1.10.8 10.1.10.11

   domain-name tsguest.ts.net

   lease 0 1

   renew deny unknown

   remember

!

!

ip vrf dsl

rd 100:10

!

!

!

crypto pki trustpoint TP-self-signed-3271883136

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3271883136

revocation-check none

rsakeypair TP-self-signed-3271883136

!

!

crypto pki certificate chain TP-self-signed-3271883136

certificate self-signed 01

  30820259 308201C2 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33323731 38383331 3336301E 170D3933 30333031 30303031

  30395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32373138

  38333133 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BA42 0F20F7BA 06CE9B93 65DCDA9D 8C853299 1A2EF3DA C01DC2C7 28F86B67

  37B3E8EC 2D733901 91A046D4 FA3FBF1E 278AA266 5403D259 553BBC93 92B6448B

  2871C610 9A1DC9BC 03E622E7 7D3CF3BA 036F80C9 713CA148 BDD16D81 74829753

  2FC06E3E D12F4E5C B374EEC9 1CA2FD71 93DA0E90 FFB6FC08 CF924A56 D3873B25

  1C690203 010001A3 8180307E 300F0603 551D1301 01FF0405 30030101 FF302B06

  03551D11 04243022 82206473 6C2D7465 73742E75 73612E74 726F7574 6D616E73

  616E6465 72732E63 6F6D301F 0603551D 23041830 16801405 C5054924 52CCBEDF

  2D6FE4C1 82492F31 D2C69B30 1D060355 1D0E0416 041405C5 05492452 CCBEDF2D

  6FE4C182 492F31D2 C69B300D 06092A86 4886F70D 01010405 00038181 00A091D2

  15555276 27626FC2 26C82A5E 0F349002 18F52D0F D39B903D D551DAEF C65E2746

  61F882D4 06106E2C DDAB4331 AE068884 F349EDE2 B6558830 7DD3BEDE 2916E6F6

  8E66B26A B1E1EEB5 EBB01EC8 60D20311 A70EBCE7 E48F779D CFE4F47E A0E4F349

  06150DB0 713EBED2 2B7832AF C5EBC305 980980FF 713BA334 3766E208 30

  quit

!

!

!

!

spanning-tree mode pvst

spanning-tree portfast bpdufilter default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1-1000 priority 24576

!

vlan internal allocation policy ascending

!

vlan 30

name dsl-test outside

!

vlan 136

name FL36_Vlan

!

vlan 1050

name dsl-inside

!

vlan 1051

name dsl-outside

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!        

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree bpdufilter enable

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!        

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

switchport access vlan 30

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface Vlan1

no ip address

shutdown

!

interface Vlan30

ip vrf forwarding dsl

ip address dhcp

!

interface Vlan136

ip address 10.2.36.4 255.255.255.0

!

interface Vlan1050

description DSL-Test Inside

ip vrf forwarding dsl

ip address 172.31.255.1 255.255.255.0

no ip proxy-arp

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.2.36.1

ip http server

ip http secure-server

!

!

ip sla enable reaction-alerts

!

tacacs-server host 10.1.10.27

tacacs-server directed-request

tacacs-server key 7 xxxxxxxxxxxxx

!

!

line con 0

line vty 5 15

!

end

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here