cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Fixing Partition Backbone Area with Virtual Links

1517
Views
0
Helpful
0
Comments

Here is a configuration example for fixing Two OSPF Backbone (0) Areas

 

 

Topoly Diagram

Partition_Backbone.JPG

 

 

Configurations

 

ASBR1

 

interface Loopback11

 

ip address 11.11.11.11 255.255.255.255

 

!

 

interface FastEthernet0/0

 

ip address 192.168.12.1 255.255.255.0

 

duplex auto

 

speed auto

 

!

 

interface FastEthernet0/1

 

ip address 201.23.23.1 255.255.255.0

 

ip ospf network point-to-point

 

duplex auto

 

speed auto

 

!

 

router ospf 100

 

router-id 1.1.1.1

 

log-adjacency-changes

 

area 3 virtual-link 3.3.3.3

 

network 11.11.11.11 0.0.0.0 area 0

 

network 192.168.12.1 0.0.0.0 area 0

 

network 201.23.23.1 0.0.0.0 area 3

 

!

 

 

 

Internal_Router1

 

interface Loopback22

 

ip address 22.22.22.22 255.255.255.255

 

!

 

interface FastEthernet0/0

 

ip address 192.168.12.2 255.255.255.0

 

duplex auto

 

speed auto

 

!

 

router ospf 100

 

router-id 2.2.2.2

 

log-adjacency-changes

 

network 22.22.22.22 0.0.0.0 area 1

 

network 192.168.12.2 0.0.0.0 area 0

 

ASBR2

 

interface FastEthernet0/0

 

ip address 172.16.34.1 255.255.255.0

 

duplex auto

 

speed auto

 

!

 

interface FastEthernet0/1

 

ip address 201.23.23.2 255.255.255.0

 

ip ospf network point-to-point

 

duplex auto

 

speed auto

 

!

 

router ospf 100

 

router-id 3.3.3.3

 

log-adjacency-changes

 

area 3 virtual-link 1.1.1.1

 

network 172.16.34.1 0.0.0.0 area 0

 

network 201.23.23.2 0.0.0.0 area 3

 

 

 

Internal_Router2

 

interface Loopback44

 

ip address 44.44.44.44 255.255.255.255

 

!

 

interface FastEthernet0/0

 

ip address 172.16.34.2 255.255.255.0

 

duplex auto

 

speed auto

 

!

 

router ospf 100

 

router-id 4.4.4.4

 

log-adjacency-changes

 

network 44.44.44.44 0.0.0.0 area 1

 

network 172.16.34.2 0.0.0.0 area 0

 

!

 

Verification Commands

 

On ASBR1

 

 

 

ASBR1#show ip ospf neighbor

 

 

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

 

3.3.3.3           0   FULL/  -           -        201.23.23.2     OSPF_VL0

 

2.2.2.2           1   FULL/BDR        00:00:36    192.168.12.2    FastEthernet0/0

 

3.3.3.3           0   FULL/  -        00:00:32    201.23.23.2     FastEthernet0/1

 

 

 

 

 

ASBR1#show ip ospf database

 

 

 

            OSPF Router with ID (1.1.1.1) (Process ID 100)

 

 

 

                Router Link States (Area 0)

 

 

 

Link ID         ADV Router      Age         Seq#       Checksum Link count

 

1.1.1.1         1.1.1.1         771         0x8000000A 0x00CF10 3

 

2.2.2.2         2.2.2.2         383         0x80000007 0x0034F9 1

 

3.3.3.3         3.3.3.3         1     (DNA) 0x80000006 0x002520 2

 

4.4.4.4         4.4.4.4         557   (DNA) 0x80000003 0x00341B 1

 

 

 

                Net Link States (Area 0)

 

 

 

Link ID         ADV Router      Age         Seq#       Checksum

 

172.16.34.1     3.3.3.3         573   (DNA) 0x80000001 0x006DC4

 

192.168.12.1    1.1.1.1         528         0x80000005 0x00BFEF

 

 

 

                Summary Net Link States (Area 0)

 

 

 

Link ID         ADV Router      Age         Seq#       Checksum

 

22.22.22.22     2.2.2.2         383         0x80000005 0x005780

 

44.44.44.44     4.4.4.4         553   (DNA) 0x80000001 0x002B50

 

201.23.23.0     1.1.1.1         1500        0x80000004 0x001D20

 

201.23.23.0     3.3.3.3         306   (DNA) 0x80000001 0x00E651

 

 

 

                Router Link States (Area 3)

 

 

 

Link ID         ADV Router      Age         Seq#       Checksum Link count

 

1.1.1.1         1.1.1.1         773         0x80000009 0x002BE5 2

 

3.3.3.3         3.3.3.3         881         0x80000009 0x005CAB 2

 

 

 

                Summary Net Link States (Area 3)

 

 

 

Link ID         ADV Router      Age         Seq#       Checksum

 

11.11.11.11     1.1.1.1         1256        0x80000004 0x007395

 

22.22.22.22     1.1.1.1         1502        0x80000004 0x00815A

 

44.44.44.44     3.3.3.3         1369        0x80000005 0x004B2F

 

172.16.34.0     3.3.3.3         1369        0x80000005 0x003419

 

192.168.12.0    1.1.1.1         1502        0x80000004 0x003986

 

 

 

On Internal_Router1

 

 

 

Internal_Router1#show ip route

 

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

 

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

 

       E1 - OSPF external type 1, E2 - OSPF external type 2

 

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

 

       ia - IS-IS inter area, * - candidate default, U - per-user static route

 

       o - ODR, P - periodic downloaded static route

 

 

 

Gateway of last resort is not set

 

 

 

C    192.168.12.0/24 is directly connected, FastEthernet0/0

 

O IA 201.23.23.0/24 [110/2] via 192.168.12.1, 02:04:30, FastEthernet0/0

 

     172.16.0.0/24 is subnetted, 1 subnets

 

O       172.16.34.0 [110/3] via 192.168.12.1, 01:54:54, FastEthernet0/0

 

     22.0.0.0/32 is subnetted, 1 subnets

 

C       22.22.22.22 is directly connected, Loopback22

 

    11.0.0.0/32 is subnetted, 1 subnets

 

O       11.11.11.11 [110/2] via 192.168.12.1, 02:01:48, FastEthernet0/0

 

     44.0.0.0/32 is subnetted, 1 subnets

 

O IA    44.44.44.44 [110/4] via 192.168.12.1, 01:54:55, FastEthernet0/0

 

 

 

Internal_Router1#ping 44.44.44.44

 

 

 

Type escape sequence to abort.

 

Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:

 

!!!!!

 

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

 

 

On ASBR2

 

 

 

ASBR2#show ip ospf neighbor

 

 

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

 

1.1.1.1           0   FULL/  -           -        201.23.23.1     OSPF_VL0

 

4.4.4.4           1   FULL/BDR        00:00:32    172.16.34.2     FastEthernet0/0

 

1.1.1.1           0   FULL/  -        00:00:38    201.23.23.1     FastEthernet0/1

 

 

 

Internal_Router2#show ip route

 

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

 

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

 

      E1 - OSPF external type 1, E2 - OSPF external type 2

 

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

 

       ia - IS-IS inter area, * - candidate default, U - per-user static route

 

       o - ODR, P - periodic downloaded static route

 

 

 

Gateway of last resort is not set

 

 

 

O    192.168.12.0/24 [110/3] via 172.16.34.1, 01:55:51, FastEthernet0/0

 

O IA 201.23.23.0/24 [110/2] via 172.16.34.1, 02:06:25, FastEthernet0/0

 

     172.16.0.0/24 is subnetted, 1 subnets

 

C       172.16.34.0 is directly connected, FastEthernet0/0

 

     22.0.0.0/32 is subnetted, 1 subnets

 

O IA    22.22.22.22 [110/4] via 172.16.34.1, 01:55:51, FastEthernet0/0

 

     11.0.0.0/32 is subnetted, 1 subnets

 

O       11.11.11.11 [110/3] via 172.16.34.1, 01:55:51, FastEthernet0/0

 

     44.0.0.0/32 is subnetted, 1 subnets

 

C       44.44.44.44 is directly connected, Loopback44

 

 

 

On Internal_Router2

 

 

 

Internal_Router2#ping 22.22.22.22

 

 

 

Type escape sequence to abort.

 

Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:

 

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

If you think the document was helpful, please vote for it.