cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1742
Views
0
Helpful
0
Comments
teegeorg
Cisco Employee
Cisco Employee

In the case of route distribution between BGP and LISP.

Description of the issue

  • The external host or server is unreachable from the Fabric host
  • The DHCP IP assignment fails

Pre SD-Access:

=== Core ===
router ospf 10
router-id 71.0.0.1
network 50.0.0.0 0.255.255.255 area 0


router bgp 65001
bgp router-id interface Loopback0
address-family ipv4 vrf Engineering
neighbor 200.0.0.2 remote-as 65002

With SD-Access:

##### FB1  ########

interface Loopback0

 description Fabric Node Router ID

 ip address 71.0.0.1 255.255.255.255

ip router isis

!

vrf definition Engineering

 rd 1:4099

 !

 address-family ipv4

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

 !

 address-family ipv6

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

!

interface Loopback1021 ----- ( Anycast gateway IP configured for DHCP OFFER punt)

 vrf forwarding Engineering

 ip address 100.1.1.1 255.255.255.255

!

router lisp

 locator-set rloc_set1

  IPv4-interface Loopback0 priority 10 weight 10

  auto-discover-rlocs

  exit-locator-set

 !

 service ipv4

  encapsulation vxlan

  map-cache-limit 5119

  database-mapping limit dynamic 3000

  itr map-resolver 71.0.0.1

  etr map-server 71.0.0.1 key key1

  etr map-server 71.0.0.1 proxy-reply

  etr

  sgt

  proxy-etr

  proxy-itr 71.0.0.1

  map-server

  map-resolver

  exit-service-ipv4

 !

instance-id 4097

  remote-rloc-probe on-route-change

  service ipv4

   eid-table default

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

  exit-instance-id

 !

 instance-id 4098

  remote-rloc-probe on-route-change

  service ipv4

   eid-table vrf DEFAULT_VN

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

exit-instance-id

 !

 instance-id 4099

  remote-rloc-probe on-route-change

  service ipv4

   eid-table vrf Engineering

route-import database bgp 65001 route-map database locator-set rloc_set1 ( — Replacement of redistribute bgp under router ospf)

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

  exit-instance-id

 !

!

 site site_uci

  authentication-key key1

  eid-record instance-id 4097 0.0.0.0/0 accept-more-specifics

  eid-record instance-id 4098 0.0.0.0/0 accept-more-specifics

  eid-record instance-id 4099 0.0.0.0/0 accept-more-specifics

  exit-site

 !

 !

 ipv4 locator reachability exclude-default

 ipv4 source-locator Loopback0

 exit-router-lisp

!

!

router bgp 65001

 bgp router-id interface Loopback0

 bgp log-neighbor-changes

 bgp graceful-restart

 !

address-family ipv4 vrf vn1

  network 173.168.127.1 mask 255.255.255.255 

  aggregate-address 173.168.227.0 255.255.255.0 summary-only

  aggregate-address 173.168.127.0 255.255.255.0 summary-only

  neighbor 200.0.0.2 remote-as 65002

  neighbor 200.0.0.2 activate

 exit-address-family

!

ip routing

!

route-map database permit 10

 match ip address prefix-list external_prefix

!

ip prefix-list external_prefix seq 5 permit 200.0.0.0/8

Solution

Ensure that the external prefixes learned from BGP are redistributed to LISP and registered to Control Plane and fabric LISP prefixes redistributed to BGP.

Pre-SDA Troubleshooting

show ip ospf neighbor

show ip bgp summary

show ip route ospf

show ip route bgp

Post-SDA Troubleshooting

Verify Export the MS/MR registrations into RIB

show lisp site

LISP Site Registration Information

* = Some locators are down or unreachable

# = Some registrations are sourced by reliable transport




Site Name      Last           Up     Who Last                   Inst     EID Prefix

                      Register             Registered                  ID       

site_uci        2d14h     yes#       70.0.0.1                  4099       100.1.1.100/32




show ip route vrf Engineering

Routing Table: abcd

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B – BGP

            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

            E1 - OSPF external type 1, E2 - OSPF external type 2

            i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

            ia - IS-IS inter area, * - candidate default, U - per-user static route

            o - ODR, P - periodic downloaded static route, H - NHRP, l – LISP

            a - application route

            + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      200.0.0.0/32 is subnetted, 1 subnets

l       100.1.1.100 [240/1], 17:57:50, Null0


Verify Redistribute of LISP routes into BGP
show bgp vpnv4 unicast vrf Engineering

BGP table version is 4, local router ID is 71.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

              t secondary path,

Origin codes: i - IGP, e - EGP, ? – incomplete

RPKI validation codes: V valid, I invalid, N Not found

    Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 1:2 (default for vrf PACAF)

Export Map: vrf_to_global, Address-Family: IPv4 Unicast, Pfx Count/Limit: 1/1000

 *>   100.1.1.100/32      0.0.0.0                  0         32768 i

Verify Import of  BGP routes into LISP

show ip lisp route-import database instance-id 10




LISP IPv4 imported routes for EID-table vrf PACAF (IID 10)

Config: 1, Entries: 5 (limit 1000)

Prefix                    Uptime    Source               RLOC-set   Cache/DB   State

200.0.0.0/8              2d14h     bgp 65002            border     installed 




show lisp site

LISP Site Registration Information

* = Some locators are down or unreachable

# = Some registrations are sourced by reliable transport




Site Name      Last           Up     Who Last                   Inst     EID Prefix

                       Register             Registered                  ID       

site_uci           2d14h     yes#    70.0.0.1                     4099      100.1.1.100/32

                       2d14h     yes#    71.0.0.1                      4099     200.0.0.0/8
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: