cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15609
Views
10
Helpful
2
Comments
ashirkar
Level 7
Level 7

 

Introduction:

 

In this document you will learn "include-connected"  word use in IPv6 redistribution.

 

In IPv4, when you redistribute routes from one routing protocol into other or from one process to another, routers do two things:

1) It will see check “show ip route <protocol name>" and then redistribute this route into other protocol.

2) It will also see your connected subnets on which routing protocols enable using “show ip route connected” command and these connected subnets will redistribute.

 

For example:

 

If you are redistributing EIGRP into OSPF then as discussed above, router will two things:

 

1) It will check "show ip route eigrp" output and redistribute EIGRP routes into OSPF.

2) Also it will check "show ip route connected" command output and all connected route on which EIGRP is enable will also redistribute into OSPF.

 

In IPv6, this logic is bit different. In IPv6, when you send packet from source to destion ,on the link, IPv6 uses link local IPv6 address (FE80: /64) that will result in saving of IPv6 address pool.

 

When you redistribute routes in IPv6, router will only check “show ipv6 route <protocol name>" command output and only redistribute those routes not connected interface on which that protocol enabled.

 

For example:

If you are redistributing EIGRPv6 into OSPFv3, router will only check “Show IPv6 route eigrp” command and only advertise these routes into OSPF database, router does not include the connected routes during redistribution.

 

To include EIGRV6 enabled connected IPv6 interfaces to be redistributed into OSPFv3, you need to use  "redistribute eigrp <process_name> include-connected command under OSPFv3 configuration mode.

 

Configuration Example:

 

In this example, we will be redistributing EIGRPv6 to OSPFv3 on R2. Here are the basic configuration and topology diagram.

 

inlude-connected.jpg

 

 

R1R2R3

hostname R1

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ipv6 address 3001::1/128

ipv6 eigrp 100

!

interface FastEthernet0/0

ipv6 address 2001::1/64

ipv6 eigrp 100

!

ipv6 router eigrp 100

no shutdown

hostname R2

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

ipv6 address 3001::2/128

ipv6 eigrp 100

!

interface FastEthernet1/0

ipv6 address 2001::2/64

ipv6 eigrp 100

!

interface FastEthernet1/1

ipv6 address 2002::2/64

ipv6 ospf 100 area 0

!

ipv6 router eigrp 100

no sh

!

ipv6 router ospf 100

!

hostname R3

!

ipv6 unicast-routing

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

ipv6 address 3001::3/128

ipv6 ospf 100 area 0

!

interface FastEthernet0/0

speed auto

ipv6 address 2002::3/64

ipv6 ospf 100 area 0

!

ipv6 router ospf 100

log-adjacency-changes

 

 

Let’s do redistribution the on R2 from EIGRP to OSPF

 

R2(config)#ipv6 router ospf 100

R2(config-rtr)#redistribute eigrp 100

R2(config-rtr)#end

 

Now let’s verify IPv6 routes on R3 and OSPF external database on R2:

 

R3#sh ipv6 route ospf

IPv6 Routing Table - 5 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route, M - MIPv6

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

       D - EIGRP, EX - EIGRP external

OE2 3001::1/128 [110/20]

     via FE80::C803:20FF:FE78:1D, FastEthernet0/0

 

R2#sh ipv6 ospf database | beg Ex

               Type-5 AS External Link States

 

ADV Router       Age         Seq#       Prefix

2.2.2.2         246         0x80000001 3001::1/128

 

From above output you can see R2 only redistribute subnet learnt from R1 through EIGRP (i.e. 3001::1/128),it  didn’t redistribute connected subnets running EIGRP on it.

 

Now let’s add "include-connected" word in redistribution and again verify external database on R2 and IPv6 route on R3.

 

R2(config)#ipv6 router ospf 100

R2(config-rtr)#redistribute eigrp 100 in

R2(config-rtr)#redistribute eigrp 100 include-connected

R2(config-rtr)#end

R2#

 

Verification:

R2#sh ipv6 ospf database | beg Ex

               Type-5 AS External Link States

 

ADV Router       Age         Seq#       Prefix

2.2.2.2         800         0x80000001 3001::1/128

2.2.2.2         2           0x80000001 2001::/64

2.2.2.2         2           0x80000001 3001::2/128

 

R3#sh ipv6 route ospf

IPv6 Routing Table - 7 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route, M - MIPv6

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

     ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

       D - EIGRP, EX - EIGRP external

OE2 2001::/64 [110/20]

     via FE80::C803:20FF:FE78:1D, FastEthernet0/0

OE2 3001::1/128 [110/20]

     via FE80::C803:20FF:FE78:1D, FastEthernet0/0

OE2 3001::2/128 [110/20]

     via FE80::C803:20FF:FE78:1D, FastEthernet0/0

 

Note: You can also redistribute connected subnet using “redistribute connected” command but router will redistribute all connected IPv6 interfaces on the router to OSPFv3, not just EIGRPv6 enabled interfaces.

Related Information:

IPv6 Routing: Route Redistribution

Comments
timroth
Cisco Employee
Cisco Employee

Good Article, 

My only thoughts here....I dont believe the configuration shown about is truly OSPFv3 IPv6 configuration. I believe the configuration shown above is OSPFv2 IPv6 config. 

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_ospf/configuration/15-sy/iro-15-sy-book/ip6-route-ospfv3.html

 

 

Bahaa J
Level 1
Level 1

Thank you Ashirkar,

Allow me to add and please validate, that is command can be used in case we are doing mutual redistributing i mean from OSPF into EIGRP.

For instance we are doing in above example mutual redistribution on R2, the configuration might look R2 as below

-

ipv6 eigrp 100

 redistribute ospf 100 include-connected

!

I Hope That Will Help

 

Bahaa Jaafar

 

 

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: