You'll need something like the following:
interface Ethernet0
description Inside interface
ip address 10.1.1.1 255.255.255.0
ip nat inside
interface Ethernet1
description Outside/Internet interface
ip address 200.200.200.1 255.255.255.0
ip nat outside
ip nat inside source list 100 interface Ethernet1 overload
access-list 100 permit ip 10.1.1.0 0.0.0.255 any
Obviously your inside and outside IP addresses will be different, so just replace them as you need to in the examples above. This will have all your inside users on the 10.1.1.0 network share the same external IP address when they go out to the Internet.