cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
200
Views
5
Helpful
5
Replies
Highlighted
Beginner

Can Ping Internet From Router, but not From Host?

Hello,

 

I'm trying to set up a separate network for my home lab.

My internet comes in from my Netgear Router on 192.168.0.1

I've set up my 2811 with FA0/1: 192.168.0.2, FA0/0 198.168.0.1

Host device is 198.168.0.10

Configured RIP(v2) between 192.168.0.0 and 198.168.0.0

Configured default route on the 2811: 0.0.0.0 0.0.0.0 192.168.0.1

 

I can ping the internet from the router itself, but I cannot ping from my host on the 198.168.0.0 network.

I've also configured two ACLs to permit traffic from both the 192 and 198 networks.

 

I'm not sure why I can't get the host to reach outside to the internet, any suggestions. Thank you. Below is the router config:

 


Current configuration : 1212 bytes
!
! Last configuration change at 05:58:21 UTC Mon Mar 16 2020
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1113A24R
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 198.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
router rip
version 2
network 192.168.0.0
network 198.168.0.0
default-information originate
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 198.168.0.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

 

5 REPLIES 5
Highlighted
VIP Mentor

Re: Can Ping Internet From Router, but not From Host?

Hello,

 

interface FastEthernet0/0
ip address 198.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto

 

Both interfaces have an IP address from the same address space. You need to use a different IP subnet on FastEthernet0/1 (which I assume is the LAN interface), and then either configure the Netgear router to route and NAT this new network, or use double NAT on your 2901. What model is the Netgear ?

Highlighted
VIP Mentor

Re: Can Ping Internet From Router, but not From Host?

Hello


@JovanGeary94 wrote:

I can ping the internet from the router itself, but I cannot ping from my host on the 198.168.0.0 network.

I've also configured two ACLs to permit traffic from both the 192 and 198 networks.

 

I'm not sure why I can't get the host to reach outside to the internet, any suggestions. Thank you. Below is the router config:


.

The reason being is the negear router is performing network translation for 192.168.1.0/24 however it isnt for the 192.168.2.0/24, so you need either to configure the netgear router to nat for the 192.168.2.0/24 of do this on your attached router

 

on the router:

int fa0/1

ip nat inside

int fa0/0

ip nat outside

access-list 10 permit 192.168.2.0 0.0.0.255
ip nat inside source list 10 interface fa0/0

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Can Ping Internet From Router, but not From Host?

Hello,

 

Thanks for the reply.

 

FA0/1 is actually WAN facing, however from what you've posted it doesn't sound like I can get the host to reach the internet via RIP and a default route, I'd have to set up NAT. I've actually already done this however I was hoping I could configure internet access to the host through RIP so I wouldn't have to VPN/TeamViewer to the host for management. Thank you.

Highlighted
VIP Mentor

Re: Can Ping Internet From Router, but not From Host?

Hello,

 

you can use RIP or statc routes or whatever you want, as long as the networks can reach the Netgear. On the Netgear, you have to configure NAT for the additional network configured on the Cisco, and a route to that network. Or, as stated, NAT the new Cisco network to the IP address that is part of the Netgear LAN subnet...

 

Does that make sense ?

Highlighted
Hall of Fame Master

Re: Can Ping Internet From Router, but not From Host?

There are things that we do not know about the environment of the original poster. But if the environment really is one subnet (one interface) for local connection and one subnet (one interface) for a transit connection to the Internet provider then there is not any need for a routing protocol like RIP. All that is required is a static default route pointing to the Internet provider. And unless the original poster has a registered Public IP subnet for their Lan then address translation is required. Logically this would probably be done on their Cisco router but it might possibly be done on the Netgear (assuming that they have configuration access for the Netgear.)

HTH

Rick