cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8518
Views
0
Helpful
12
Replies

Cisco 1941 Basic Home Config

cortdillon
Beginner
Beginner

Hello, 

I'm sorry for the basic question however I am desperate. I recently purchased a new Cisco 1941 router for my growing small business. I was hopeful that once configured properly this would be the proper solution to scale. 


Unfortunatley my first attempts at performing a basic configuration of this router have proven to be unsuccessful and I am seeking help. 

I basically need it to do the following: 

  1. Act as a gateway to the internet 
  2. Connect to my ISP modem and get dynamic ip for access to the internet
  3. Connect to my Cisco Managed switch and act as a DHCP server for all devices on the network

I would like to use GE0/0 for my internal LAN connection and use GE0/1 as my external WAN connection. 

I'm sorry to seem obtuse, but any help, basic configs, or links to decent step by step article would be most appreciated. 

Thank you advance for any help!

All my best // CD

1 Accepted Solution

Accepted Solutions

cortdillon,

Its been cleared now that your PC dont have logical connectivity to the router inside interface gi0/0. we will start tshoot the network from this point. mostly, no conectivity between clients and network device belong to hardware defect, I assume you connecting your pc to router directly.  if so, the utp cable must be cross over. is it so ?

also, dhcp service from isp is connected to gi0/1. so gi0/1 must have its ip address dynamically. do show ip interface brief command inside router to chick if its gets its ip or not. upload the result please.

thanks for clarification on the steps you did it helps for troubleshooting.

View solution in original post

12 Replies 12

saif musa
Enthusiast
Enthusiast

cortdillon,

First of all I need you to be ensure that you got internet service from isp cable connected directly to your PC befor you follow the steps below..

1- To act as gateway to internet >>>

config t

interface gigethernet 0/0

ip address 192.168.1.1 255.255.255.0

no shutdown

 exit

wr

2- To act as dhcp server for all clients >>>

config t

ip dhcp pool 192.168.1.0 255.255.255.0

default-router 192.168.1.1

network 192.168.1.0 255.255.255.0

dns-server 4.2.2.2 8.8.8.8

ip dhcp excluded-address 192.168.1.1 192.168.1.20

end

wr

3- To enable internet service through the device >>>

config t

ip route 0.0.0.0 0.0.0.0 gigethernet 0/1

interface gigethernet 0/1

ip nat outside

exit

interface gigethernet 0/0

ip nat inside

exit

ip nat inside source list 101 interface gigethernet 0/1 overload

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

wr

4- To enable gigethernet as wan interface and in dhcp client mode >>>

config t

interface gigethernet 0/1

ip address dhcp

no shutdown

end

wr

Let us know how its going with you, hope that helps

Regards

Please rate if its helpful

Hi Saif, 
Thanks for your reply. One quick question before I begin. 

First of all I need you to be ensure that you got internet service from isp cable connected directly to your PC befor you follow the steps below..

To be sure, you want the ethernet cable connected from the ISP modem directly to my computer and the console cable connected directly to the same computer from the 1941 router? 

Once I run all of the commands you've outlined above, I can then connect the ethernet cable from the modem to the router? 

Again, sorry to be obtuse but I want to be sure I do this properly. 

Best // CD

the idea behind that is to confirm that there is a dhcp service from isp and there is internet connection befor we start configuring the router with the above configuartion. so we will manimize the troubleshooting procdure if we dont get internet service from your 1941 router.

Regards

Hi Saif!

Thank you for your clarification above. Here are the steps, I followed: 

  1. Connected directly from the modem to the PC and established an internet connection. No problem.
  2. Connected the console cable to the 1941 and completed your steps. (I've included the config below)
  3. I find it worth noting that when I type "interface gigethernet 0/0" or "interface gigethernet 0/1" I would recevie the following error: 

Router(config)#interface gigethernet 0/0
                                            ^
% Invalid input detected at '^' marker.

I could only access them by typing "gi0/0" or "gi0/1"

Config:

Router#show config
Using 1456 out of 262136 bytes
!
! Last configuration change at 05:07:49 UTC Tue Dec 1 2015
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.1.20
!
ip dhcp pool 192.168.1.0 255.255.255.0
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
!
license udi pid CISCO1941/K9 sn FTX1917849L
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
!
!
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

At this point, I'm still unable to connect to the internet via the router. What am I going wrong? 

Best // CD

Hi CortDillon,

Did you got an ip address from inside interface router dhcp service ?

Hi Saif, 

Please see below: 

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::48f7:56f8:c7ef:95d0%2
Autoconfiguration IPv4 Address. . : 169.254.149.208
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

This from ipconfig on that ethernet connection on the pc. 

Your PC didn't got ip address from router, set ip address statically and let it be 

192.168.1.50

255.255.255.0

192.168.1.1

4.2.2.2

8.8.8.8

And do ping from pc to 192.168.1.1 if it's successful then do ping to 4.2.2.2 and tell me the result

We will use static ip address to chick Internet service regardless dhcp service we will tshoot it later

Regards

Hi Saif!

I've followed your instructions and have included a few items for review below. Also want you to know I called my ISP, they confirmed DHCP on the modem but also stated that its in bridge mode. Not sure if that matters. 

Please see below:

Your PC didn't got ip address from router, set ip address statically and let it be 

192.168.1.50

255.255.255.0

192.168.1.1

4.2.2.2

8.8.8.8

And do ping from pc to 192.168.1.1 if it's successful then do ping to 4.2.2.2 and tell me the result

We will use static ip address to chick Internet service regardless dhcp service we will tshoot it later

Set the ip statically: 

Ping Results: 

C:\Users\>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\>ping 4.2.2.2

Pinging 4.2.2.2 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 4.2.2.2:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


For fun I also attempted to ping from the router via console connected directly to the modem: 


Router#ping 4.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


Looking forward to your next steps. 

Best // CD

cortdillon,

Its been cleared now that your PC dont have logical connectivity to the router inside interface gi0/0. we will start tshoot the network from this point. mostly, no conectivity between clients and network device belong to hardware defect, I assume you connecting your pc to router directly.  if so, the utp cable must be cross over. is it so ?

also, dhcp service from isp is connected to gi0/1. so gi0/1 must have its ip address dynamically. do show ip interface brief command inside router to chick if its gets its ip or not. upload the result please.

thanks for clarification on the steps you did it helps for troubleshooting.

Hi Saif, 
You are correct. It was the cable! I changed our the cable and everything is working fine. 

DHCP from the modem, Router connected to the switch and providing DHCP to the switch. All is good my friend, thanks for your patience! 

Now, is there any way that I can get back to the CP express interface just for general maitenance, passwords, etc? 

All best // Cortlin

Great.

CP express configuration guid in attachment below, passwords you can configure it using router wizard. login to device and enter the command  <setup> and follow the wizard.

enjoy accessing internet ...

Regards

Glenn Martin
Cisco Employee
Cisco Employee

Reassigned post to the appropriate community: Network Infrastructure>Routing

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: