cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
541
Views
0
Helpful
6
Replies
Highlighted
Beginner

cisco 2511-rj45 menu commands

Below i have attached the boot-up info from my 2511-rj45.

What im trying to do is set up a menu and everything goes according to plan until i try to create a prompt, options or command.

 

Commands to telnet go through fine following the cisco documentation. When i try to use for exampt

menu cisco prompt ^ Whatever message ^
or
menu cisco command e menu-exit

it does not work at all. I see that those commands are available  since version 10 unless im missing something any help is appreciated. Thank you!

 

Screen Shot 2018-08-17 at 1.47.33 AM.pngScreen Shot 2018-08-17 at 12.42.20 PM.png

 

6 REPLIES 6
Highlighted
VIP Expert

Hello,

 

post the full running config of your router, something might be missing...

Highlighted

Screen Shot 2018-08-17 at 12.42.20 PM.png

Highlighted

Hello,

 

is this the full output ? There is no menu configured. Post the output of 'menu TS'.

 

Below is a sample config. Refer to the document linked at the bottom for details:

 

TS#sh run
Building configuration...

Current configuration : 3925 bytes
!
! Last configuration change at 17:54:41 UTC Fri Aug 17 2018
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TS
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ethernet lmi ce
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
no ip icmp rate-limit unreachable
!
no ip domain lookup
ip host R1 2003 10.1.1.1
ip host R2 2004 10.1.1.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
menu cisco title ^C
+++++++++++++++++++++++++++++++++++++++++++++++++
Welcome to the Terminal Server
to exit from the device, use Ctrl+Shift+6 then press x
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
^C
menu cisco prompt ^C
Choose your option
^C
menu cisco text 1 login to R1
menu cisco command 1 telnet 10.1.1.1 2003
menu cisco text 2 login to R2
menu cisco command 2 resume R2 / connect telnet R2
menu cisco text e menu-exit
menu cisco command e menu-exit
menu cisco text q disconnect from terminal server
menu cisco command q exit
menu cisco clear-screen
menu cisco line-mode
!
menu main status-line
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login local
autocommand menu cisco
transport input all
transport output all
!
no scheduler allocate
!
end

 

https://www.cisco.com/c/en/us/support/docs/dial-access/asynchronous-connections/200462-Terminal-server-configuration-using-Menu.html

 

Highlighted

Yes its the full output. Sorry i reloaded the device after the command wouldn't work but im able to use the

menu cisco tittle 
menu cisco text
menu cisco clear-screen
menu cisco line-mode
menu cisco command (but can only use numbers after this one not letters like in your run)

The only command i havent used is the following:

autocommand menu cisco
Highlighted

Hello,

 

make sure you use the procedure described in the linked document in the previous post...

Highlighted

im running 11.6. Anyway you can share that ios version 15??