cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1010
Views
0
Helpful
5
Replies
Highlighted
Beginner

High CPU Utilization on 7200-VXR with NPEG2

Hi,

My router is running with BGP (One eBGP and One IBGP session). I have filterdown the BGP roting table by using prefix-List and default route to upstream router.But still found the CPU process is high (80%/80% with 60MB traffic). Find the bellow out put and assist me.

Sh Proc CPU

-------------------

CPU utilization for five seconds: 88%/88%; one minute: 87%; five minutes: 87%

PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process

   2         180        4759         37  0.07%  0.06%  0.07%   0 Load Meter    

141         240     5936995          0  0.15%  0.15%  0.15%   0 HQF Shaper Backg

Sh Version

-------------------

KAYSGR1#sh version

Cisco IOS Software, 7200 Software (C7200P-ADVIPSERVICESK9-M), Version 12.4(24)T5, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Fri 04-Mar-11 07:11 by prod_rel_team

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)

BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 12.4(4)XD5, RELEASE SOFTWARE (fc1)

KAYSGR1 uptime is 6 hours, 37 minutes

System returned to ROM by reload at 04:55:20 UTC Sat Dec 1 2012

System image file is "disk2:c7200p-advipservicesk9-mz.124-24.T5.bin"

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 7206VXR (NPE-G2) processor (revision A) with 917504K/65536K bytes of memory.

Processor board ID 21288417

MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2

6 slot VXR midplane, Version 2.0

Last reset from power-on

PCI bus mb1 (Slots 1, 3 and 5) has a capacity of 600 bandwidth points.

Current configuration on bus mb1 has a total of 300 bandwidth points.

This configuration is within the PCI bus capacity and is supported.

PCI bus mb2 (Slots 2, 4 and 6) has a capacity of 600 bandwidth points.

Current configuration on bus mb2 has a total of 0 bandwidth points.

This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port Adaptor

Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>

for c7200 bandwidth points oversubscription and usage guidelines.

1 FastEthernet interface

3 Gigabit Ethernet interfaces

1 Packet over SONET interface

2045K bytes of NVRAM.

254464K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).

65536K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102

5 REPLIES 5
Highlighted
Cisco Employee

Your High CPU is not due to any process. It is because of interupts

Interrupt cpu normally due to traffic switching.

CPU utilization for five seconds: 88%/88%; one minute: 87%; five minutes: 87%

Check the following outputs

Show interfaces | inc up|rate|drop

Show interface stat

Thank you

Raju

Highlighted

Hi Rajs,

I could see droping in my POS1/0 port.

KAYSGR1#sh int | in up|rate|drop

GigabitEthernet0/1 is up, line protocol is up

  Full-duplex, 1000Mb/s, link type is force-up, media type is LX

  output flow-control is XON, input flow-control is unsupported

  Input queue: 0/75/0/660 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  5 minute input rate 64871000 bits/sec, 95991 packets/sec

  5 minute output rate 71232000 bits/sec, 106673 packets/sec

     0 unknown protocol drops

  Full-duplex, 100Mb/s

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 unknown protocol drops

GigabitEthernet0/2 is up, line protocol is up

  Full-duplex, 1000Mb/s, link type is force-up, media type is LX

  output flow-control is XON, input flow-control is unsupported

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  5 minute input rate 2000 bits/sec, 5 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     823 unknown protocol drops

  Full-duplex, 1000Mb/s, link type is force-up, media type is LX

  output flow-control is XON, input flow-control is unsupported

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 unknown protocol drops

POS1/0 is up, line protocol is up

  Input queue: 0/75/0/738 (size/max/drops/flushes); Total output drops: 1031

  Queueing strategy: fifo

  5 minute input rate 62796000 bits/sec, 106805 packets/sec

  5 minute output rate 57215000 bits/sec, 96077 packets/sec

     0 unknown protocol drops

Loopback0 is up, line protocol is up

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 unknown protocol drops

------------------------------------------

Sh int stat

--------------------

KAYSGR1#sh int stats

GigabitEthernet0/1

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

               Processor     754223   80812128     843013   81277297

             Route cache 1046381403 1167213846 1205612468 2755282718

                   Total 1047135626 1248025974 1206455481 2836560015

Interface FastEthernet0/2 is disabled

GigabitEthernet0/2

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

               Processor     116319    7137306       5712     468269

             Route cache       9555     763076       9341    2833799

                   Total     125874    7900382      15053    3302068

GigabitEthernet0/3

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

               Processor          0          0          0          0

             Route cache          0          0          0          0

                   Total          0          0          0          0

POS1/0

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

               Processor     777943   68481332     691191   59953778

             Route cache 1205816136 3599364353 1046535591 3455245224

                   Total 1206594079 3667845685 1047226782 3515199002

Loopback0

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

               Processor          0          0          0          0

             Route cache          0          0          0          0

                   Total          0          0          0          0

KAYSGR1#

Highlighted

Hi

7200 is a CEF router.

It's CPU utilization will go high if the traffic rate goes up. This is expected becasue it uses CPU to switch the traffic

You can also check on your interface configs to see if there is any other features like GRE, QOS, ACL which can furhter add to the CPU

Thank you

Raju

Highlighted

Hi Rajs,

Yes,  but CPU consumption is 80/90% with 60/70MB Traffic is very unlikely.No we are not using QOS, GRE but we are using Prefix-List to bringdown the BGP table.We thought it because of full BGP table and recently deploy this Prefix-list with default route but problem remain same.Please see my Sh run

Sh run

-----------

Building configuration...

Current configuration : 2224 bytes

!

upgrade fpd auto

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname KAYSGR1

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

ip cef

!

!

!

!

ip name-server 165.21.100.88

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username ---- privilege 15 secret 5 $1$rEK6$0TCQJ/v4WPTjYnXACPxTu/

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 10.10.12.12 255.255.255.255

!

interface GigabitEthernet0/1

description Connect To NetroNext ISP

ip address X.X.X.X  255.255.255.252

duplex auto

speed 1000

media-type sfp

no negotiation auto

!

interface FastEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

description Connect to Kay SG LAN

ip address X.X.X.X 255.255.255.240

duplex auto

speed 1000

media-type sfp

no negotiation auto

!

interface GigabitEthernet0/3

no ip address

duplex full

speed 1000

media-type sfp

no negotiation auto

!

interface POS1/0

description Connect To IPLC

ip address X.X.X.X  255.255.255.252

crc 32

clock source internal

pos framing sdh

pos scramble-atm

!

router ospf 100

log-adjacency-changes

network 10.10.12.12 0.0.0.0 area 0

network X.X.X.X 0.0.0.3 area 0

!

router bgp XXXX

no synchronization

bgp router-id X.X.X.X

bgp log-neighbor-changes

network X.X.X.X mask 255.255.254.0

neighbor 10.10.13.13 remote-as 2.1248

neighbor 10.10.13.13 update-source Loopback0

neighbor 10.10.13.13 next-hop-self

neighbor 10.10.13.13 default-originate

neighbor X.X.X.X remote-as 2.1265

neighbor X.X.X.X update-source GigabitEthernet0/1

neighbor X.X.X.X prefix-list ktel-PL in

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 X.X.X.X

ip route X.X.X.X 255.255.254.0 Null0

no ip http server

no ip http secure-server

!

!

!

!

ip prefix-list ktel-PL seq 5 deny 0.0.0.0/0 le 32

!

!

!

!

!

snmp-server community XX RO

!

control-plane

!

!

!

!

!

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login local

!

end

KAYSGR1#

Highlighted
Beginner

Generate the following:
1.) Sh Proc CPU hist
2.) complete "Sh Proc CPU"

My suspect is the SNMP process causing it.