cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3183
Views
0
Helpful
8
Replies

Multiple OSPF Instance Question

John Early
Beginner
Beginner

I am in the process of switching out my WAN provider for my company.  I am currently running a single OSPF instance and am planning to add a second for my new carrier.  We are planning to run both carriers for some time as we migrate over.  Below is my current configuration, my question is can I add a second OSPF line on the VLAN interface?  Or how can I run 2 OSPF instances at once with different weights.

interface Vlan10
ip address 192.168.10.254/24
ip ospf passive-interface
ip router ospf 50 area 0.0.0.0
ip pim sparse-mode

interface Vlan100
no ip redirects
ip address 192.168.100.254/24
ip ospf passive-interface
ip router ospf 50 area 0.0.0.0

interface Vlan200
ip address 192.168.200.254/24
ip ospf dead-interval 10
ip ospf hello-interval 2
ip ospf network broadcast
ip router ospf 50 area 0.0.0.0
no shutdown

router ospf 50
network 192.168.200.254/32 area 0.0.0.0
default-information originate
log-adjacency-changes

I plan to add:

router ospf 100
network 192.168.250.254/32 area 0.0.0.0

interface Vlan100
no ip redirects
ip address 192.168.100.254/24
ip ospf passive-interface
ip router ospf 50 area 0.0.0.0
ip router ospf 100 area 0.0.0.0  <<  Can I add another OSPF line to an interface?

8 Replies 8

Jon Marshall
VIP Community Legend VIP Community Legend
VIP Community Legend

You can't do this or rather they will only show up in one of the OSPF processes but not both.

What you can do redistribute from one process to another but then the redistributed routes will be external routes and I'm assuming the existing ones are intra or inter area routes so they will always be preferred.

Would need to know more about the topology and what you currently have.

Jon

I didn't set this network up originally, but the existing OSPF 50 might only be used so that I can get the routing table from the carrier.  If I do a show ip route ospf then I see plenty of routes from ospf 50.  Is there a way to see if I am even sending routes?  If I understand how this works the "ip router ospf 50 area 0.0.0.0" line on the vlan interface is intented to send that network to the OSPF neighbor, right?

The OSPF statement tells your router to start sending and receiving hellos on that intefrace and also to advertise the network.

What is the WAN ie. point to point, MPLS, VPLS something else ?

If you are receiving routes you will be advertising routes to the remote sites.

What does a "sh ip ospf neighbor" show on your device ?

What do the OSPF routes from the remote sites look like ie. are they intra area, inter area or externals ?

Without a full understanding of how everything works at the moment impossible to say how you might approach it.

Jon