cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
287
Views
3
Helpful
2
Replies
Highlighted
Beginner

NAT issue.

Hello All,

10.X.X.X subnet need to be natted to 192.168.X.x

Here customer LAN is 10.X.X.x  and 192.168.X.X is the place where client server is located.

We have to NAT 10.x.x.x  to 192.168.x.x as 10.x.x.x subnet is not permitted at server end.

There is only one router where we can possibly perform natting.In this router interface toward LAN(i.e. toward 10.x.x.x) is already configured as Outside.

and interface toward server is configured as inside.(I can't change this nat inside and nat outside on router as they are used for other purposes also)

what could be the possible solution.How to nat in this router. Is there anything like destination based natting?

Regards

MJ

2 REPLIES 2
Highlighted
Beginner

NAT issue.

Hello Mukul,

One work around will be to add sub interfaces on one of your fastethernet interfaces this was you can assign more than one ip address to these subinterfaces and then you can do NAT Overload with  theses subinterface

please see the example below for  the configuration :

interface FastEthernet0/0

description Trunk to  switch

no ip address

speed 100

full-duplex

interface FastEthernet0/0.1

description Link 1

encapsulation dot1Q 2

ip address 192.168.x.x 255.255.255.0

ip nat outside

ip virtual-reassembly

!

interface FastEthernet0/0.2

description Link 2

encapsulation dot1Q 4

ip address 172.16.x.x.  255.255.255.0

ip nat outside

ip nat source Access list 100 interface FastEthernet0/0.1 overload

ip nat source Access list 200 interface FastEthernet0/0.2 overload

This is just an example to give an idea of how you can do it

Hope it will help

Ahmed Sonba

Beginner

NAT issue.

Hi Ahmed ,

It worked thanx

MJ

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here