cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
671
Views
0
Helpful
9
Replies

Need Help Setting Up My Cisco

blatter123
Beginner
Beginner

everyone bare with me here as i am a beginner CCNA. I am in college and i have a basic knowledge of this stuff. Here goes... I have a cisco 2801 router, My ISP in which i receive my bandwidth from has assigned me a ip address/gateway etc for my FA0/0 from our Telco switch. I need to figure out how to bridge through the public ip scheme they are issuing me through FA0/1 (setting up a transparent bridge) so in example  if i was givin 192.168.1.189 on a /30 network for my router (assigned to FA0/0) how to i set it up to bridge through the publics?

Matt

9 Replies 9

Cory Dryden
Beginner
Beginner

Are you talking about needing a NAT setup on your router here? Or setting a default gateway?

I guess both I would imagine. I had properly nat'd in a test environment (where a dhcp server handed my wan port fa00 it's own address)

Basically I need

FA0/0 to have the up address of 66.43.35.189 and the gateway or upstream router is 66.43.35.190/30. That upstream router is routing a batch of 69.54.xxx.xx/24 public addresses for customer user through us. I need l figure out how to make it bridge through correctly

Hi there,

In this case, you don't need to bridge. You can route the subnet instead.

If the subnet is to be connected directly to the router, configure it on the other interface. (fa0/1)

If not, configure a static route pointing to the next-hop where the subnet is to be found.

regards,

Leo

fb_webuser
Frequent Contributor
Frequent Contributor

Are you needing to setup NAT/PAT on your router so you can have your private addresses go out to the Internet? I'm a little confused on what you're trying to accomplish.

---

Posted by WebUser Adam Sibille

blatter123
Beginner
Beginner

Current configuration : 812 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MMBC

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

--More--                           !

--More--                           voice-card 0

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           interface FastEthernet0/0

--More--                            ip address 66.43.35.189 255.255.255.252

--More--                            speed 100

--More--                            full-duplex

--More--                           !

--More--                           interface FastEthernet0/1

--More--                            ip address 69.54.155.1 255.255.255.0

--More--                            duplex auto

--More--                            speed auto

--More--                           !

--More--                           interface Serial0/1/0

--More--                            no ip address

--More--                            shutdown

--More--                           !

--More--                           interface Serial0/2/0

--More--                            no ip address

--More--                            shutdown

--More--                           !

--More--                           ip route 0.0.0.0 0.0.0.0 66.43.35.190

--More--                           ip route 69.54.155.0 255.255.255.0 66.43.35.190

--More--                           !

--More--                           !

--More--                           ip http server

--More--                           no ip http secure-server

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           control-plane

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           !

--More--                           line con 0

--More--                           line aux 0

--More--                           line vty 0 4

--More--                            login

--More--                           !

--More--                           scheduler allocate 20000 1000

--More--                           end

--More--                          

there is my running config... 66.43.35.190 is supposed to route me 69.54.155.0/24 addresses dynamically..as it sits right now if i set a 69.54.155.2 255.255.255.0 in my computer statically i can get internet and pull my 50x50 connection. But it wil not hand me a dynamic address...

Matt

hi matt,

if i understand you correctly, you want to dynamically allocate the 69.54.155.0/24 subnet for your LAN? you would need DHCP enabled on your router in order to achieve this. try to configure as below:

ip dhcp excluded-address 69.54.155.1

ip dhcp pool LAN

   network 69.54.155.0 255.255.255.0

   default-router 69.54.155.1

   dns-server    OR

   dns-server 4.2.2.2

you can ignore and remove this static route since you have the default static route for all your LAN traffic.

no ip route 69.54.155.0 255.255.255.0 66.43.35.190

Hey John,

That situation works for handing me an IP address but the problem with that is im not supposed to be handing out the address's myself. The ISP

gave me this information

The New point to point customer / 30 ip network for the link to your router is as follows

66.43.35.188/30 (255.255.255.252)

66.43.35.188 network address

66.43.35.189 customer router (us)

66.43.35.190 (upstream router/ gateway)

66.43.35.191 broadcast (this is all the information i have to set up FA0/0)

now

The new customer /24 IP network which is routed to you at 66.43.35.189 for your use as follows.

69.54.155.0/24

69.54.155.0 (net address)

69.54.155.1 first usable ip address (FA0/1 interface i presume)

69.54.155.2 - 69.54.155.254 address available

69.54.155.255 (broadcast)

our DNS servers are as follows

66.43.32.105

66.43.42.105

66.43.32.101

66.43.42.101

I tried the DHCP server on the lan side handing out the 69.54.155.0/24 addresses this morning it handed me an address, but my telco switch threw a red light at me and i maybe pulled 1MB/1MB out of my 50X50 Connection in my headend. (sorry to be a bother just trying to learn here)

matt

Let me also add that the 66.43.35.190/30 (gateway or upstream router) is at a remote location (ISP) it is coming in through Fiber optic into our telco switch then out through ethernet to my Cisco 2801 Router.

Hi Matt,

The only way you could use your 69.54.155.0/24 subnet provided by your ISP is to either assign them manually on your LAN hosts or dynamically via DHCP. As Leo had mentioned in his early post, you need to put a static default route on your 2800 to route all LAN traffic towards the ISP.

About the red light on the telco switch (probably the MetroE MUX), I doubt it's due to the recent change you've made. Better if you'd take this up with your SP.

Sent from Cisco Technical Support iPhone App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: