cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
751
Views
20
Helpful
5
Replies
raphaeloester
Beginner

OSPF Loading/Full loop

Hello, 

I'm having a bit of a trouble trying to configure an OSPF setup here on packet tracer. You can find my topology in the attachement Capture.PNG.

 

What's happening is that my "BERLIN" labelled router just doesn't get any of the routes it's supposed to via OSPF :

 

 

Router#show ip route

!!!snip!!!

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

C 10.10.6.0/24 is directly connected, GigabitEthernet0/1

L 10.10.6.254/32 is directly connected, GigabitEthernet0/1

C 10.10.100.0/28 is directly connected, GigabitEthernet0/0

L 10.10.100.6/32 is directly connected, GigabitEthernet0/0

 

The wierd part is that i constantly get logging messages on this router, like so : 

 

00:23:55: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:05: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:15: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:25: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:35: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:45: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:50: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

00:24:55: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

It's just alternating between 2.2.2.2 ( MADRID ) and 1.1.1.1 ( LISBOA )

 

Although my configuration seems fine : 

BERLIN'S CONFIGURATION :

 

Current configuration : 770 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO1941/K9 sn FTX15244MM2

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.10.100.6 255.255.255.240

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.10.6.254 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router ospf 10

router-id 6.6.6.6

log-adjacency-changes

network 10.10.6.0 0.0.0.255 area 0

network 10.10.100.0 0.0.0.15 area 0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Here's LISBOA'S configuration, which seems to be chosent as DR.

Current configuration : 994 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO1941/K9 sn FTX152425E6

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.10.1.254 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.10.100.2 255.255.255.240

duplex auto

speed auto

!

interface Serial0/0/0

ip address 10.10.100.17 255.255.255.252

!

interface Serial0/0/1

ip address 10.10.100.21 255.255.255.252

clock rate 2000000

!

interface Vlan1

no ip address

shutdown

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

network 10.10.1.0 0.0.0.255 area 0

network 10.10.100.16 0.0.0.3 area 0

network 10.10.100.20 0.0.0.3 area 0

network 10.10.100.0 0.0.0.15 area 0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Finally, MADRID :

Router#show run

Building configuration...

 

Current configuration : 977 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO1941/K9 sn FTX1524DL27

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.10.100.2 255.255.255.240

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.10.2.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

ip address 10.10.100.18 255.255.255.252

clock rate 2000000

!

interface Serial0/0/1

ip address 10.10.100.25 255.255.255.252

clock rate 2000000

!

interface Vlan1

no ip address

shutdown

!

router ospf 10

router-id 2.2.2.2

log-adjacency-changes

network 10.10.2.0 0.0.0.255 area 0

network 10.10.100.16 0.0.0.3 area 0

network 10.10.100.0 0.0.0.15 area 0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Thanks for your help !

1 ACCEPTED SOLUTION

Accepted Solutions

now I see two 10.10.100.2 ip, please can correct it and check again.

View solution in original post

5 REPLIES 5
MHM Cisco World
Collaborator

can I see show ip interface brief for Berlin branch ?

I see double IP address 10.10.100.6 config in to two routers this is issue I think, please change one of them.

My mistake, i pasted twice the same configuration when I created the post. Now it's edited. Here is the IP interface brief for Berlin :

 

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 10.10.100.6 YES manual up up

GigabitEthernet0/1 10.10.6.254 YES manual up up

Vlan1 unassigned YES unset administratively down down

 

Thanks for your help

 

now I see two 10.10.100.2 ip, please can correct it and check again.

View solution in original post

Oh my god... I can't believe i banged my head against the wall for two days because of a simple ip address duplicate... Thanks for your response anyway.

Conclusion : weird loops like this may be caused by two routers having the same IP address on the same subnetwork. Hope it can help someone to know this

You are So So Welcome