cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1037
Views
0
Helpful
12
Replies
Highlighted
Beginner

Pagp Problem and Loop packet

Hi

In our project, we had to configure PAGP between catalyst cisco 3110.

there is no problem in configuration of PAGP and everythin is ok,and channel is up.but after reload cisco, chanel can not be up and between switches all packet are in loop between 2 switches.in order to solve this probelm I have to shutdown all port and again create chanel for every port.

I could not find any solution for this problem.

Thanks in advance

12 REPLIES 12
Highlighted
Contributor

Hi Nima,

Can you share config of port-channel and corresponding ports...

Also, check if its any bug related to IOS...

Regards,

Smitesh

Highlighted
Beginner

Thanks for your attention

Output of "show run" :

-


Interface port-Channel1

Switchport access vlan 2

Switchport mode access

...

.

.

.

Interface gigabitethernet1/0/1

Switchport access vlan 2

Switchport mode access

Channel-group 1 mode desirable

Interface gigabitethernet1/0/2

Switchport access vlan 2

Switchport mode access

Channel-group 1 mode desirable

.

.

.

.

Interface gigabitethernet1/0/8

Switchport access vlan 2

Switchport mode access

Channel-group 1 mode desirable

-


I have bundled 8 port with same properties.but after reload because pagp can not up port into bundle.

Where can I find related bugs about cisco IOS?

Thanks

Sent from Cisco Technical Support iPad App

Highlighted

Hi Nima,

If possible can you change port-channel frpm desirable to simple ON and check...

interface range gi1/0/1 - 1/0/8

channel-group 1 mode on

no shut

Regards,

Smitesh

Highlighted

Hi again

I forgot another problem in configuration, if I set pagp related command "channel-group 1 mode desirable" in Interface range gig x/x/x, I got same result and loop between 8 ports.so I had to run that command for every port separately.

Ok I check your solution but I think this solution is not our purpose,because "on" mode does not do same as "desirable" for failover checking and remove disconnected port from bundle!

Thanks for more help.

Sent from Cisco Technical Support iPad App

Highlighted

Hi

Unfortunately this problem is not solved.

Is there any solution that I set one cron or schedule in order to set some configuration after cisco is booted ??

In fact I want to add some script as same as linux script that after boot OS,those scripts to be excuted.Is there such facility in cisco devices ?

Thanks in advance

Highlighted

Hi Nima,

Cisco IOS can support TCL scripting ( just an advise to be used only if you are familiar with TCL scripting. Or else you can have a loop in your script and can have unbootable or an responsive or unusuable device).

So, in conjunction with Cisco's EEM, you can have event based triggering of execution of commands or script.

Regards,

Smitesh

Message was edited by: smitesh kharecha

Highlighted
Beginner

Dear concerned,

Try to configure link add trunk instead of access vlan and allow only desire vlan on it

I. e

Switchport trunk allowed vlan 2

See If it solves your problem or not

I f not

Next step, change it from pagp to lacp

Regards

Musab

Sent from Cisco Technical Support Android App

Highlighted
Beginner

As trunk*****

Sent from Cisco Technical Support Android App

Highlighted

Thanks

I think this problem is "bug". So I want to write some script in EEM for "up" interfaces after switch is reloaded.

One Question:

If I use trunk instead of access, Are all packets tagged ?

Anyhow thanks for your attention.

Highlighted

hey Nima,

I dont think its a bug in IOS. but sometimes in the process of creating and operating ether channels, the bundle doesnt directly go to up up state unless you manually shut / no shut the Portchannel interface on both ends.

dont know why is that so, but a simple shut no shut of JUST the Portchannel int (not all the bundle ints) solves it.

I couldnt find a bug related to etherchannel anywhere thou

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.
Highlighted

If I use trunk instead of access, Are all packets tagged ?

yes, in case of using trunks, because of it nature which makes it capable of handling traffic from different vlans, all your packets are tagged with regards to their respective Vlan ID. there is an exception thou, in case of using 802.1q - native vlan doesnt get any tags.

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.
Highlighted
Beginner

Every packet on trunk has to be tagged except packets that doesn't belong to any vlan, are untagged thus belong to native vlan (dot1q).

Regards

Musab

Sent from Cisco Technical Support Android App