cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Routing issues - EIGRP

ALIAOF_
Frequent Contributor
Frequent Contributor

I have a Cisco router connected to a core switch via pass through VLAN. 

 

Cisco PO1(172.16.0.1/30) -------- Juniper (LAG) (172.16.0.2/30)

There are multiple SVI's on the Juniper switch.

 

Cisco EIGRP config is like this.  I see the EIGRP neighbor and it is up.

 

H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.0.56.153             Gi0/0                     6 00:08:48    1   100  0  2294151

 

router eigrp 100
 network 10.0.0.0
 redistribute static
 eigrp stub connected static summary redistributed

My routes are showing up like this:

 

S*    0.0.0.0/0 [1/0] via 10.0.56.153
      10.0.0.0/8 is variably subnetted, 12 subnets, 7 masks
C        10.0.40.88/30 is directly connected, Port-channel1.888
L        10.0.40.89/32 is directly connected, Port-channel1.888
C        10.0.56.152/29 is directly connected, GigabitEthernet0/0
L        10.0.56.155/32 is directly connected, GigabitEthernet0/0
C        10.0.67.180/30 is directly connected, Loopback1
L        10.0.67.182/32 is directly connected, Loopback1
S        10.26.192.0/19 [1/0] via 10.0.40.90
S        10.80.3.0/24 [1/0] via 10.0.40.90
S        10.82.3.0/24 [1/0] via 10.0.40.90
S        10.126.192.0/20 [1/0] via 10.0.40.90
S        10.126.208.0/23 [1/0] via 10.0.40.90
S        10.226.192.0/20 [1/0] via 10.0.40.90

From the LAN I can ping the router, I can ping the 10.0.40.90 which is the Juniper L3 interface connected to the Cisco. I can also ping the Cisco's Interface 10.0.40.89.  But I can not ping out public IPs.  If I remove the "redistribute static" command and update "eigrp stub connected summary" I am able to ping public IP's sourced from the L3 interface of the switch (10.0.40.90) that is about it.  What am I missing here?

 

I have also tried to update the config as follows:

 

router eigrp 100
 network 10.0.40.88 0.0.0.3
 network 10.0.56.152 0.0.0.7
 network 10.26.192.0 0.0.31.255
 network 10.126.208.0 0.0.1.255
 redistribute static
 eigrp stub connected static redistributed
1 ACCEPTED SOLUTION

Accepted Solutions

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello @ALIAOF_ ,

 

>> I can also ping the Cisco's Interface 10.0.40.89. But I can not ping out public IPs. If I remove the "redistribute static" command and update "eigrp stub connected summary" I am able to ping public IP's sourced from the L3 interface of the switch (10.0.40.90) that is about it. What am I missing here?

 

You have a default static route in the IP routing table and if you redistribute you may be injecting a default route in EIGRP and this can influence the other EIGRP device .

Check what happens on the other EIGRP device you may be overriding its default route and this can break connectivity to the public IP addresses  ( for example NAT s not triggered )

 

Hope to help

Giuseppe

 

View solution in original post

4 REPLIES 4

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

who is the EIGRP neighbor ?

 

Post a diagram of your topology, as it is unclear where you are pinging from...

ALIAOF_
Frequent Contributor
Frequent Contributor

10.0.56.153 is the PE and EIGRP neighbor.  Sorry I did not get a chance to draw the diagram in Visio it's been a busy day.  But here is a high level.

 

Cisco PO1(172.16.0.1/30)

|

These two are connected via a port channel and using a pass through VLAN.

|

Juniper (LAG) (172.16.0.2/30)

    - VLAN1 - 10.26.192.0/19

    - VLAN802 - 10.126.208.0/23

    - There are more but I'm just going to use these two for simplicity and this example

 

I have tried to ping from a laptop that is sitting on VLAN1.

 

 

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello @ALIAOF_ ,

 

>> I can also ping the Cisco's Interface 10.0.40.89. But I can not ping out public IPs. If I remove the "redistribute static" command and update "eigrp stub connected summary" I am able to ping public IP's sourced from the L3 interface of the switch (10.0.40.90) that is about it. What am I missing here?

 

You have a default static route in the IP routing table and if you redistribute you may be injecting a default route in EIGRP and this can influence the other EIGRP device .

Check what happens on the other EIGRP device you may be overriding its default route and this can break connectivity to the public IP addresses  ( for example NAT s not triggered )

 

Hope to help

Giuseppe

 

You have a default static route in the IP routing table and if you redistribute you may be injecting a 
default route in EIGRP and this can influence the other EIGRP device .

I have tried to take that command out as as well and done something like this too:

router eigrp 100
 network 10.0.40.88 0.0.0.3
 network 10.0.56.152 0.0.0.7
 network 10.26.192.0 0.0.31.255
 network 10.126.208.0 0.0.1.255
 eigrp stub connected static
---------------------------------
Also tried this:
router eigrp 100
 network 10.0.40.88 0.0.0.3
 network 10.0.56.152 0.0.0.7
 network 10.26.192.0 0.0.31.255
 network 10.126.208.0 0.0.1.255
 eigrp stub connected 
Check what happens on the other EIGRP device you may be overriding its default route and this can break 
connectivity to the public IP addresses ( for example NAT s not triggered )

After doing some troubleshooting today, I feel like there are further config related issues on the PE, which I do not have access too.  Will need to understand more about the flow I think.  So far I can only ping any public IP if I source it from the p2p interfaces on the router or the switch.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: