cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1519
Views
0
Helpful
24
Replies
christopherwms
Beginner

Routing through switch

I'm unable to connect to the internet and despretly need help.

My university gave us student permission toset up a cisco lab.

I hve an 1841 router and a 2950 catalyst switch in a single room.

Fa0/1 is conncted to the switch using a 192.168.3.0 /24 network.

DHCP is correctly assaigning ip addresses to the switch.

I connected the Fa0/0 port to the wall and used the following command to obtain an ip on the Fa0/0 port: ip adress dhcp.

I used the following route command: ip route dhcp.

That didn't work so I used the ip route 0.0.0.0 0.0.0.0 Fa0/0.

When I run the sh cdp neighbors command I see a multilayer switch that show me connected to the Ga2/26 port with ip:192.168.179.254.

I also see that the default vlan is 200 and the voice vlan is 800.

A linksys router is about to let us access the internet.

I am able to ping the 192.168.179.254 address from the 1841 router.

What am I missing to connect to the internet.

I forgot to mention that I successfully receive an ip from the wall.  The latest ip I received was 192.168.179.100 /24.

If someone will tell me how to make a topology diagram, I will gladly post it.

Thanks in advance

24 REPLIES 24

Hi,

I don't know how I didn't noticed this before but  if you have a linksys router to go on the internet then it is probably doing the NAT so you don't need to

and you must give your default route this router as next hop.

To make a simple sketch just draw with paint and do a screenshot  and post the switch  config, on switch issue sh cd nei detail and same on 1841.

Regards.

Alain.

Don't forget to rate helpful posts.

Thanks for the info Alain.

I was trying to replace the linksys witht he 1841.  When I had the linksys router connected and performed a trace route I was able to hit everyhop that was listed before the internet.

The school has blocked pings past a certain point.

The last hop is a 172.16.31 network.

The default gateway that is listed for a seperate port in the same room is 192.168.247.254

I can ping both of these but no internet access.

Is there anyreason why different ports in the same room would have different gateways?

Thanks for the help

Hello,

How are you testing for Internet access, with a web broswer?  I noticed that your DHCP pools you created on the router don't provide DNS servers as part of the address assignment.  If you are not manually setting the DNS servrers on the PC to get around this, it will not know how to look up the websites that you try to access.

You can try adding this command to your DHCP pools:

     dns-server 4.2.2.1 4.2.2.2

Where 4.2.2.1 and 4.2.2.2 are publicly accessible DNS servers.  If your school doesn't allow outbound DNS traffic, you'll have to find out what the internal DNS servers that you need to use are and swap them in place of 4.2.2.1 and 4.2.2.2.

Hope that helps.

Andy

Hi Andy,

It appears that when the router obtains the dhcp address for Fa0/0 it is automatically getting the dns servers.

When I type ping yahoo.com, I am seeing the correct ip translation.  If this is just an illusion please let me know.

Thanks

Chris

It is possible that the DNS servers from the Fa0/0 interface are getting passed along.  I've never actually dealt with a secnario where the router is obtaining it's address from DHCP, it's always been set statically.  But, if you are swapping back and forth between the working Linksys and the Cisco router, it also could be that you have yahoo.com and any other names that you looked up while on the linksys stored in your DNS cache.  The ping command would use the cached address if it is available.  One quick way to find out is do "nslookup yahoo.com" from a command prompt and see if you actually get a response back from the DNS server(s).  You could also do "ipconfig /flushdns" (assuming you are using Windows) to clear the cache and then try the ping again to see if it still works.

Andy

Sorry for the confusion.  I have attached an image of the setup.

This is what I am trying to achieve.

If you replace the 1841 with the linksys I can connect to the internet.

If the 1841 is connected to the wall, I have the cisco router obtaining ip from dhcp when plugged into the wall.

Hi,

What devices does this sketch represent? Is the router your 1841? what is this L2 switch below? Is the router directly connected to this

L3 switch on the right and where is the internet connection?

Can you do a sh cdp nei on the router please and a sh ip arp.

Regards.

Alain.

Don't forget to rate helpful posts.

The diagram is how I was picturing it.  Am I understanding correctly that your trace route makes it to the same

point before stopping with both the 1841 and the Linksys?

Also, for the router passing along the DNS settings thatit receives on Fa0/0 to it's DHCP clients, this is possible.  However it also looks like you need a command for it to do this that is not appearing in your config examples above.  You would need to enter:

ip dhcp pool mypool

     import all

The other settings you specify in the pool config, such as lease and default router, will override what is imported from the dhcp client on Fa0/0.

Did you try the nslookup or ping after clearing the DNS cache?  It still seems to me like it may just be a name resoltion issue, especailly if your trace routes do look the same when done on the 1841 and the Linksys.

Here is the trace route performed when connected to the 1841:

tracert yahoo.com

1  1ms     1ms        1ms      10.10.10.1

2     1 ms     1 ms     1 ms  192.168.179.254
  3    23 ms     1 ms     1 ms  172.31.67.161
  4     3 ms     5 ms     2 ms  172.31.6.149
  5     *        *        *     Request timed out.

The 179.254 is the multiswitch on the otherside of the wall.

The router to the left of the wall is the 1841, and the L@ switch is the cisco 2960 catalyst switch.

I am having no issues with the 2950.  I have no access to the L3 switch.

I will have access to the router on thursday.

Hi Guys,

I pulled this info by plugging directly into the port:

GW: 192.168.179.254

DHCP Server: 192.168.179.253

I have also retrieved the 2 DNS Servers.

Would setting the DNS info router fix this?

Also would it be possible to set the dhcp server to 192.168.179.253 or would my ap address dhcp be taking care of this?

Thanks for the input