cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

MPLS / LDP issue

103
Views
0
Helpful
0
Comments

I have a new Access router coming into the mix in our network- The configuration is in- it shows LDP is up and functional- and the correct routing table is showing up in the new access router.  However, traffic is not passing over the link (MPLS traffic on the CustA vrf).  Any suggestions? Could it be the area configuration for MPLS LDP?

Thanks

Greg

Relevant configs:

New Router A (Connected to Old Router B)

interface Loopback0
ip address 10.100.254.10 255.255.255.255

router ospf XXXXX
mpls ldp autoconfig area 3
log-adjacency-changes
redistribute connected subnets
passive-interface GigabitEthernet2/0
network XX.XX.XX.XX 0.0.0.3 area 3

router bgp XXXXX
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.255.2.1 remote-as XXXXX
neighbor 10.255.2.1 update-source Loopback0
!
address-family ipv4 mdt
  neighbor 10.255.2.1 activate
  neighbor 10.255.2.1 send-community both
  neighbor 10.255.2.1 soft-reconfiguration inbound
exit-address-family
!
address-family vpnv4
  neighbor 10.255.2.1 activate
  neighbor 10.255.2.1 send-community both
  neighbor 10.255.2.1 next-hop-self
  bgp redistribute-internal
exit-address-family
!
address-family ipv4 vrf CustA
  redistribute connected
  no synchronization
  bgp redistribute-internal
exit-address-family

Old Router B

interface Loopback0
ip address 10.255.2.1 255.255.255.255

router ospf XXXXX
mpls ldp autoconfig area 0
log-adjacency-changes
redistribute connected subnets
passive-interface Port-channel1
network XX.XX.XX.XX 0.0.0.0 area 0
network XX.XX.XX.XX 0.0.0.0 area 0
!
router bgp XXXXX
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.100.254.10 remote-as XXXXX
neighbor 10.100.254.10 update-source Loopback0
!
address-family ipv4 mdt
  neighbor 10.100.254.10 activate
  neighbor 10.100.254.10 send-community extended
  neighbor 10.100.254.10 route-reflector-client
  neighbor 10.100.254.10 soft-reconfiguration inbound
exit-address-family
!
address-family vpnv4
  neighbor 10.100.254.10 activate
  neighbor 10.100.254.10 send-community extended
  neighbor 10.100.254.10 route-reflector-client
  neighbor 10.100.254.10 next-hop-self
  bgp redistribute-internal
exit-address-family

address-family ipv4 vrf CustA
  redistribute connected
  redistribute static
  default-information originate
  no synchronization
  bgp redistribute-internal
exit-address-family

CreatePlease to create content