2022-12-19 09:39 AM 2024-09-30 02:42 PM 更新
interface GigabitEthernet0/0/0
no shutdown
ipv6 dhcp client request vendor
no ipv6 address dhcp
#RA方式の場合明示的にIPv6アドレスをDHCPで取得しないようにする
ipv6 address autoconfig
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 nd ra suppress all
exit
interface GigabitEthernet0/0/0
no shutdown
ipv6 address dhcp
ipv6 dhcp client vendor-class mac-address
ipv6 dhcp client request vendor
ipv6 dhcp client pd prefix-from-provider
ipv6 address prefix-from-provider ::aa:bb:cc:dd/64 または /80
ipv6 nd autoconfig default-route #RAでのデフォルトルートは取得する
ipv6 nd ra suppress all
exit
ip route 0.0.0.0 0.0.0.0 Tunnel0
ip nat route vrf 10 0.0.0.0 0.0.0.0 global
#簡単のためにNATルートを利用していますが、Data-PolicyのNATでも動作可能です。
#Data-Policyの場合はNATルートを削除
ip nat inside source list nat-dia-vpn-hop-access-list interface Tunnel0 overload
interface GigabitEthernet0/0/0
no shutdown
no ip address
ipv6 dhcp client request vendor
ipv6 address autoconfig default
ipv6 enable
ipv6 nd ra suppress all
negotiation auto
exit
!
interface Vlan10
no shutdown
vrf forwarding 10
ip address 192.168.1.254 255.255.255.0
exit
!
interface Tunnel0
no shutdown
ip nat outside
!nat64 enable ! nat64の設定は不要でした。
tunnel source GigabitEthernet0/0/0
tunnel mode ipv6
tunnel route-via GigabitEthernet0/0/0 mandatory
exit
!
#IPv6のSD-WANトンネル
interface Tunnel1
no shutdown
ip unnumbered GigabitEthernet0/0/0
ipv6 unnumbered GigabitEthernet0/0/0
tunnel source GigabitEthernet0/0/0
tunnel mode sdwan
exit
!
#IPv4のSD-WANトンネル
interface Tunnel1000
no shutdown
ip unnumbered Tunnel0
tunnel source Tunnel0
tunnel mode sdwan
exit
!
sdwan
interface GigabitEthernet0/0/0
tunnel-interface
encapsulation ipsec
#max-control-connections 0 #IPv6コントローラがない場合に入れる
color gold
exit
exit
!
interface Tunnel0
tunnel-interface
encapsulation ipsec
color silver
exit
exit
!
nat64 settings fragmentation header disable
nat64 provisioning mode jp01
version draft-ietf-softwire-map-03
address-resolution-server http://<address-server-url>
tunnel interface Tunnel0
tunnel source GigabitEthernet0/0/0
!
nat64 route 0.0.0.0/0 GigabitEthernet0/0/0
ip nat route vrf 10 0.0.0.0 0.0.0.0 global
#NATルートの場合はLoopbackインタフェース及びVRF0にIPv4のアドレスが存在しなくてもDIA通信可能
#Data-Policyを使う場合はNATルートは不要ですが、VRF0に明示的にIPアドレス、この場合はLoopbackインタフェースを持つ必要がある
#ip nat insideの設定は不要
interface GigabitEthernet0/0/0
no shutdown
no ip address
ipv6 dhcp client request vendor
ipv6 address autoconfig default
ipv6 enable
ipv6 nd ra suppress all
negotiation auto
nat64 enable
exit
!
interface Vlan10
no shutdown
vrf forwarding 10
ip address 192.168.1.254 255.255.255.0
nat64 enable
exit
!
interface Tunnel1 #IPv6トンネル
no shutdown
ip unnumbered GigabitEthernet0/0/0
ipv6 unnumbered GigabitEthernet0/0/0
tunnel source GigabitEthernet0/0/0
tunnel mode sdwan
exit
!
#interface Tunnel1000
# no shutdown
# ip unnumbered Tunnel0 #自動で生成されるMAP-Eトンネルを設定値にできるように改修
# tunnel source Tunnel0 #自動で生成されるMAP-Eトンネルを設定値にできるように改修
# tunnel mode sdwan
#exit
#!
sdwan
interface GigabitEthernet0/0/0
tunnel-interface
encapsulation ipsec
color mpls
#IPv6コントローラがない場合に入れる
#max-control-connections 0
exit
# interface Tunnel0 #自動で生成されるMAP-Eトンネルを設定値にできるように改修
# tunnel-interface
# encapsulation ipsec
# color public-internet
# exit
# exit
!
nat64 settings fragmentation header disable
nat64 provisioning mode jp01
version draft-ietf-softwire-map-03
!
config-transaction
crypto pki trustpoint TP
enrollment url bootflash:
revocation-check none
fingerprint AD7E1C28B064EF8F6003402014C3D0E3370EB58A
commit
end
crypto pki authenticate TP
MAP-E-Router#crypto pki authenticate TP
Reading file from bootflash:TP.ca
Certificate has the following attributes:
Fingerprint MD5: 324A4BBB C863699B BE749AC6 DD1D4624
Fingerprint SHA1: AD7E1C28 B064EF8F 60034020 14C3D0E3 370EB58A
Trustpoint Fingerprint: AD7E1C28 B064EF8F 60034020 14C3D0E3 370EB58A
Certificate validated - fingerprints matched.
Trustpoint CA certificate accepted.
MAP-E-Router#
5.Root証明書配布をvManage20.13.x以降から実施可能となりました。
別回線やIPv6でvManageとルータとの接続性がある状態から遠隔でのインストールとなります。
詳細は以下の手順をご覧ください。
https://www.cisco.com/c/en/us/td/docs/routers/sdwan/configuration/sdwan-xe-gs-book/manage-certificates.html#c-fht-ca-certifcates
show nat64 map-e
show nat64 statistics
show ip nat translations
show nat64 translations
show platform hardware qfp active statistics drop
show platform hardware qfp active feature nat datapath statistics
show platform hardware qfp active feature nat datapath sess-dump
debug ip nat 1 detailed
debug nat64 detail
debug platform hardware qfp active feature nat64 data detail
検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう
シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします
下記より関連するコンテンツにアクセスできます