キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
告知

JTAC-Mid-Career-Recruitment-2021.8

 

986
閲覧回数
5
いいね!
6
返信
ULT7737
Beginner

専用線接続でのルーター(Cisco C841)のconfig設定方法について

PPPoE接続から、PPPoE接続を利用しないで専用線で接続するconfigを作成してみましたが、ルーター(Cisco C841)経由でインターネットに接続ができません。

 

configを抜粋して記載しますので、対応方法等をご存知でしたら何卒、ご教授のほどよろしくお願い致します。


【config抜粋】
ip dhcp pool ccp-pool
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
interface GigabitEthernet0/0
description /*** to LAN ***/
switchport trunk allowed vlan 1,2
switchport mode trunk
no ip address
!
interface GigabitEthernet0/4
description /*** to_WAN ***/
ip address xxx.xxx.xxx.xxx 255.255.255.224
duplex auto
speed auto
no cdp enable
!
interface Vlan1
no ip address
!
interface Vlan2
no ip address
!
ip nat inside source list 1 interface GigabitEthernet0/4 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/4
!
access-list 1 permit xxx.xxx.xxx.xxx 0.0.0.31

 

1 件の受理された解決策

受理された解決策
kk_king08
Beginner

こんにちは。

接続の構成を把握はできておりませんが、インターネットの接続テストはどのように実施されましたでしょうか。C841 に接続されているスイッチ配下の PC などからでしょうか。まずは、C841 から "ping 8.8.8.8" が可能か確認してみてください。設定として気になる点が3つあります。

  1. スタティックルートのネクストホップをインタフェース指定されている
  2. Vlan1 と Vlan2 に IP アドレスの設定がない
  3. インタフェースに NAT の設定がない

1 については、インタフェース指定ではなく IP アドレスで設定してみてください。
(誤)ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/4
(正)ip route 0.0.0.0 0.0.0.0 <IP アドレス>

2 と 3 については、以下のように IP アドレスと NAT の設定を追加してみてください。
!
interface GigabitEthernet0/4
ip nat outside
!
interface Vlan1
ip address <IP アドレス> <ネットマスク>
ip nat inside
!
interface Vlan2
ip address <IP アドレス> <ネットマスク>
ip nat inside
!

また、以下の箇所については Vlan1 と Vlan2 のネットワークを設定する必要があります。
access-list 1 permit xxx.xxx.xxx.xxx 0.0.0.31

設定変更後もうまくいかない場合は、C841 からの "ping 8.8.8.8" が可能か、配下からの "ping 8.8.8.8" が可能かを確認し、構成なども記載があるともう少し何か分かるかもしれません。

元の投稿で解決策を見る

6件の返信6
kk_king08
Beginner

こんにちは。

接続の構成を把握はできておりませんが、インターネットの接続テストはどのように実施されましたでしょうか。C841 に接続されているスイッチ配下の PC などからでしょうか。まずは、C841 から "ping 8.8.8.8" が可能か確認してみてください。設定として気になる点が3つあります。

  1. スタティックルートのネクストホップをインタフェース指定されている
  2. Vlan1 と Vlan2 に IP アドレスの設定がない
  3. インタフェースに NAT の設定がない

1 については、インタフェース指定ではなく IP アドレスで設定してみてください。
(誤)ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/4
(正)ip route 0.0.0.0 0.0.0.0 <IP アドレス>

2 と 3 については、以下のように IP アドレスと NAT の設定を追加してみてください。
!
interface GigabitEthernet0/4
ip nat outside
!
interface Vlan1
ip address <IP アドレス> <ネットマスク>
ip nat inside
!
interface Vlan2
ip address <IP アドレス> <ネットマスク>
ip nat inside
!

また、以下の箇所については Vlan1 と Vlan2 のネットワークを設定する必要があります。
access-list 1 permit xxx.xxx.xxx.xxx 0.0.0.31

設定変更後もうまくいかない場合は、C841 からの "ping 8.8.8.8" が可能か、配下からの "ping 8.8.8.8" が可能かを確認し、構成なども記載があるともう少し何か分かるかもしれません。

元の投稿で解決策を見る

適切な解説の上でのご返信ありがとうございます。

 

現在、すぐに結果を確認できる環境にいないため、結果のご連絡が遅くなりそうなことをお詫び申し上げます。

 

また、結果については確認出来次第、コミュニティに報告させていただいます。

 

ご教授ありがとうございます。

 

 

 

 

 

返信ありがとうございます。

ip routeの設定を入れたところ、ルータから8.8.8.8にping疎通できました。ありがとうございます。

 

しかし、配下のPCはインターネット接続できません。今回の設定は、NATをせず(今はPC接続ですが、下位のF/WでNATするため)にそのままグローバルIPでアクセスしたいのですが、その場合Vlan301はどのように設定すればよいでしょうか?

 

また、Vlan1,2,1002-1005はデフォルトで設定を入れなければいけないものかと認識しておりましたが、そこも誤りがありますでしょうか?

構成をもう少し教えていただけますでしょうか。
下位の F/W で NAT されて、そのままグローバル IP でアクセスされたいとのことですが、C841 の WAN 側にグローバル IP が設定されているかと思います。C841 の WAN 側のアドレスとは別のアドレスになりますでしょうか。C841 の LAN 側は Trunk に設定されていますが、接続先はスイッチでよろしいでしょうか。Trunk の設定にて vlan301 を許可されていないようではありますが。 

返信ありがとうございます。

 

構成

インターネット(WAN) > c841ルータ > L2スイッチ > F/W

 

F/WでNATをするため、c841ルータではNATの設定をせず、インターネット(WAN)にはVlan301に設定されているIPアドレスの通信がそのままでていく構成としたいです。

 

たりない情報あれば、ご指摘ください。

 

どうかお願いいたします。

 

 

PPPoEを設定しないので、単純にLANポートをaccessポートとして設定すると

疎通できました。

 

どうもありがとうございました。おかげさまで接続可能となりましたので、解決策として承認させていただきます。