取消
显示结果 
搜索替代 
您的意思是: 
cancel
946
查看次数
0
有帮助
0
评论
liu_zhimin
Spotlight
Spotlight

L3 Routing Protocols – Things to know

ƒ

Each VDC supports 4 instances of each Interior Gateway Protocol (IGP)

(IE: EIGRP, ISIS, OSPF, RIPv2)

ƒ

Each VDC supports 1 instance of each Exterior Gateway Protocol (EGP)

(IE: MP-BGP)

ƒ

All routing protocols support Virtual Routing and Forwarding (VRF)

instances - VRF instances do not require unique protocol instances

ƒ

EIGRP, ISIS, OSPF, PBR and MP-BGP require the Enterprise Services

License

ƒ

The feature command is required to enable all routing protocols except

static routing

ƒ

The NX-OS supports 16 ECMP to a destination (user configurable)

ƒ

MP-BGP supports 2 and 4 Byte AS Numbers (plain-text & AS.dot notation)

ƒ

MP-BGP requires an address family configuration per neighbor

ƒ

OSPF always displays x.x.x.x notation regardless how it is entered

ƒ

OSPF is the only routing protocol that supports statefull synchronization

between supervisors (NSF is used for all other routing protocols)

 

1、EIGRP Configuration

EIGRP is a Cisco proprietary routing protocol. The EIGRP feature must

be enabled before an EIGRP instance or interface can be configured for

EIGRP. EIGRP is applied per interface instead of under the routing

process.

 

n7000(config)#

feature eigrp--Enable the EIGRP feature first!

n7000(config)#

router eigrp 10 --Create the instance 

n7000(config-router)# router-id 192.168.1.1--specify a 32-bit router ID

n7000(config)# interface ethernet 2/1

n7000(config-if)#ip address 192.168.10.1 255.255.255.0

n7000(config-if)#ip router eigrp 10  --Enable the interface for EIGRP and

specify the EIGRP instance

Configuring a “Passive” Interface:

 

 

n7000(config)# interface ethernet 2/2

n7000(config-if)#

ip address 192.168.11.1/24

n7000(config-if)#

ip router eigrp 10

n7000(config-if)#

ip passive-interface eigrp 10

 

2、EIGRP Common Configuration Options

n7000(config-if)# ip ?

authentication Configures EIGRP authentication subcommands

bandwidth Set bandwidth for interface used in EIGRP metric calculation

bandwidth-percent Configures IP-EIGRP bandwidth limit

delay Set delay for interface used in EIGRP metric calculation

distribute-list Filter networks in routing updates

eigrp EIGRP interface configuration commands

hello-interval Configures IP-EIGRP hello interval

hold-time Configures IP-EIGRP hold time

load-sharing Style of load sharing

next-hop-self Configures IP-EIGRP next-hop-self

offset-list Add or subtract offset from EIGRP metrics

passive-interface Suppress routing updates on an interface

split-horizon Configures IP-EIGRP split-horizon on interface

summary-address Configures IP-EIGRP summary address on interface

n7000(config-router)# ?

address-family Configure an address-family

authentication Configures EIGRP authentication subcommands

autonomous-system Specify AS number for Address Family

default-information Control origination of a default route

default-metric Set metric of redistributed routes

distance Define an administrative distance

exit Exit from command interpreter

flush-routes Flush routes in RIB during restart

graceful-restart Peer resync without adjancency reset

log-adjacency-changes Log changes in adjacency state

log-neighbor-warnings Enable/Disable IP-EIGRP neighbor warnings

maximum-paths Forward packets over multiple paths

metric Modify EIGRP routing metrics and parameters

no Negate a command or set its defaults

redistribute Redistribute information from another routing protocol

router-id router-id for this EIGRP process

shutdown Shutdown this instance of EIGRP

stub Set IP-EIGRP as stubbed router

timers Set EIGRP timers

vrf Configure VRF information

 

EIGRP Process Verification

Use the show ip eigrp command to verify the EIGRP Instance configuration

n7000# show ip eigrp

IP-EIGRP AS 10 ID 192.168.1.1 VRF default

Process-tag: 10

Status: running

Authentication mode: none

Authentication key-chain: none

Metric weights: K1=1 K2=0 K3=1 K4=0 K5=0

IP proto: 88 Multicast group: 224.0.0.10

Int distance: 90 Ext distance: 170

Max paths: 8

Number of EIGRP interfaces: 3 (1 loopbacks)

Number of EIGRP peers: 2

 

3、

EIGRP Routing and Neighbor Verification

The following show commands are useful for viewing EIGRP routes and

verifying neighbor connectivity.

Verifying EIGRP Routes:

n7000# show ip eigrp route

IP-EIGRP Topology Table for AS(10)/ID(192.168.1.1) VRF default

P 192.168.1.1/32, 1 successors, FD is 128320

via Connected, loopback0

P 192.168.2.1/32, 2 successors, FD is 130816

via 192.168.10.2 (130816/128320), Ethernet2/1

via 192.168.11.2 (130816/128320), Ethernet2/2

Verifying Neighbors:

n7000# show ip eigrp neighbors

IP-EIGRP neighbors for process 10 VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 192.168.11.2 Eth2/2 14 00:07:52 8 300 0 24

0 192.168.10.2 Eth2/1 13 00:07:52 6 300 0 23

n7000# show ip eigrp neighbor detail

IP-EIGRP neighbors for process 10 VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 192.168.11.2 Eth2/2 13 00:10:20 8 300 0 24

Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 2

0 192.168.10.2 Eth2/1 12 00:10:21 6 300 0 23

Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 2

 

4、OSPFv2 Configuration

OSPFv2 is a standard based routing protocol defined in RFC 2328. The

OSPF feature must be enabled before an OSPF instance can be

configured. OSPF is applied per interface instead of under the routing

process.

n7000(config)#

feature ospf

n7000(config)#

router ospf 10

n7000(config-router)# router-id 192.168.1.1

n7000(config)# interface ethernet 1/13

n7000(config-if)# ip address 192.168.10.1 255.255.255.0

n7000(config-if)# ip router ospf 10 area 0

Configuring a “Passive” Interface:

n7000(config)# interface eth 1/1

n7000(config-if)# ip address 192.168.10.1 255.255.255.0

n7000(config-if)#

ip router ospf 10 area 0

n7000(config-if)#

ip ospf passive-interface

 

OSPFv2 Common Configuration Options

n7000(config-if)# ip ospf ?

authentication Authentication on the interface

authentication-key Configure the authentication key for the interface

cost Cost associated with interface

dead-interval Dead interval

hello-interval Hello interval

message-digest-key Message digest authentication password (key)

mtu-ignore Disable OSPF MTU mismatch detection

network Network type

passive-interface Suppress routing updates on the interface

priority Router priority

retransmit-interval Packet retransmission interval

shutdown shutdown ospf on this interface

transmit-delay Packet transmission delay

n7000(config-router)# ?

area Configure area properties

auto-cost Calculate OSPF cost according to bandwidth

default-information Control distribution of default route

default-metric Specify default metric for redistributed routes

distance OSPF administrative distance

exit Exit from command interpreter

flush-routes Flush routes on a non-graceful controlled restart

graceful-restart Configure graceful restart

log-adjacency-changes Log changes in adjacency state

max-metric Maximize the cost metric

maximum-paths Maximum paths per destination

no Negate a command or set its defaults

policy Policy related information

protocol OSPF protocol

redistribute Redistribute information from another routing protocol

router-id Set OSPF process router-id

summary-address Configure route summarization for redistribution

timers Configure timer related constants

vrf Display per-VRF information

OSPFv2 Process Verification

Use the show ip ospf command to verify the OSPF configuration.

n7000# show ip ospf

Routing Process 10 with ID 192.168.1.1 VRF default

Stateful High Availability enabled

Graceful-restart is configured

grace period: 60, state: (null)

Last graceful restart exit status: None

Supports only single TOS(TOS0) routes

Supports opaque LSA

Administrative distance 110

Reference Bandwidth is 40000 Mbps

Initial SPF schedule delay 200.000 msecs,

minimum inter SPF delay of 1000.000 msecs,

maximum inter SPF delay of 5000.000 msecs

Minimum hold time for Router LSA throttle 5000.000 ms

Minimum hold time for Network LSA throttle 5000.000 ms

Minimum LSA arrival 1000.000 msec

Maximum paths to destination 8

Number of external LSAs 0, checksum sum 0

Number of opaque AS LSAs 0, checksum sum 0

Number of areas is 1, 1 normal, 0 stub, 0 nssa

Number of active areas is 1, 1 normal, 0 stub, 0 nssa

Area BACKBONE(0)

Area has existed for 00:05:55

Interfaces in this area: 2 Active interfaces: 2

No authentication available

SPF calculation has run 6 times

Last SPF ran for 0.000588s

Area ranges are

Number of LSAs: 3, checksum sum 0x16114

<Text Omitted>

OSPFv2 Routing and Neighbor Verification

The following show commands are useful for viewing OSPF routes and

verifying neighbor connectivity.

Verifying OSPFv2 Routes:

n7000# show ip ospf route

OSPF Process ID 10 VRF default, Routing Table

(D) denotes route is directly attached (R) denotes route is

in RIB

192.168.1.1/32 (intra)(D) area 0

via 192.168.1.1/Lo0*, cost 1

192.168.10.0/24 (intra)(D) area 0

via 192.168.10.1/Eth1/13*, cost 40

Verifying Neighbors:

n7000# show ip ospf neighbor

OSPF Process ID 10 VRF default

Total number of neighbors: 1

Neighbor ID Pri State Up Time Address Interface

192.168.2.1 1 FULL/DR 00:00:27 192.168.10.2 Eth1/13

n7000# show ip ospf neighbor detail

Neighbor 192.168.2.1, interface address 192.168.10.2

Process ID 10 VRF default, in area 0 via interface Ethernet1/13

State is FULL, 6 state changes, last change 00:00:57

Neighbor priority is 1

DR is 192.168.10.2 BDR is 192.168.10.1

Hello options 0x2, dbd options 0x42

Last non-hello packet received 00:00:49

Dead timer due in 00:00:37

OSPFv2 Troubleshooting Commands

n7000# restart ospf 10

n7000# clear ip ospf 10 neighbor ?

* Clear all neighbors

A.B.C.D Source IP address, or router ID of the neighbor

ethernet Ethernet IEEE 802.3z

loopback Loopback interface

port-channel Port Channel interface

n7000# debug ip ospf ?

10 Process tag

adjacency Adjacency events

all All OSPF debugging

database OSPF LSDB changes

database-timers OSPF LSDB timers

events OSPF related events

flooding LSA flooding

graceful-restart OSPF graceful restart related debugs

ha OSPF HA related events

hello Hello packets and DR elections

lsa-generation Local OSPF LSA generation

packets OSPF packets

policy OSPF RPM policy debug information

redist OSPF redistribution

retransmission OSPF retransmission events

spf SPF calculations

spf-trigger Show SPF triggers

 

 

 

 

 

 

 

 

 

 

 

入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:









快捷链接